locked
Remote access to WHS via new Sky hub RRS feed

  • Question

  • Just changed from my old Sky router (Netgear DG834GT) to the new Sky hub - June 2013.

    Routers configured identically as far as I can tell. Laptop running Windows 7.

    On the old router I can connect to the WHS via both the console and remote access. If remote access fails I can 'repair' the link via the console.

    On the new Sky hub, I can connect to the WHS via the console but the 'repair wizard' in WHS does not configure UPnP on my router.

    Has anyone else suffered the same experience? How did you resolve the problem? (Sky, to date, have not been at all helpful - it is 'my problem' as they are not responsible for the configuration of 'other devices'!).

    Sunday, June 30, 2013 8:00 AM

Answers

  • There is a 'tick' in the 'ON' box on the UPnP page but oly one device (my laptop) appears on the list of devices here.

    In the meantime I finally managed to speak to someone at Sky who knew what they were talking about and provided this solution for resolving my problem..... I have notated the instructions in italics to indicate extra actions

    <form action="http://SRVS/CGI-BIN/WEBCGI.EXE" method="post" name="13f94d7daac167c1_theForm" target="_blank">
      • Select Advanced
      • Select LAN IP Setup
      • Below Address Reservation heading, click Add
      • Enter the following details:
      • IP address to reserve
      • The MAC Address of the device
      • Device Name
    1. Select Security.
    2. Select Services.
    3. Select the Add Custom Service button. (you only need to do this for services that are not already in the Firewall Rules drop down menu. You need to obtain details of what services /port numbersyou need to open from the maker or supplier of the equipment you are trying to connect to).
    4. Enter the following details where applicable:
      • the name for the application (make a note of this)
      • the port settings
      • protocol for the port you need to open (TCP or UDP)
      • the port range (Start Port/Finish Port)
      • the port number to translate to  (Not applicable on my router).
    5. Select Apply.
    6. Select Firewall rules.
    7. Select Add below Inbound Services.
    8. Below Firewall Rules - Inbound Services, the Service dropdown holds a pre-defined list of a number of applications that you may wish to allow through your firewall.
    9. Select the appropriate application from the drop down menu (created in step 11).
    10. From the Action drop down select ALLOW Always.
    11. From the Send to LAN Server heading enter the IP address of the attached device where the traffic is to be forwarded to (eg your home PC).

    To find out the devices connected to your router select the Maintenance heading then Attached Devices tab.

    1. Click Apply at the bottom of the page to save the changes.

    If there are problems setting up the Port Forwarding, here are some things to check:

    • Have all the ports been forwarded that are needed, and is the right protocol being used?
    • Is there a firewall active on the home PC, such as McAfee, Norton or Windows Firewall? Port Forwarding may need to be set up within the firewall on the PC if trying to connect remotely to an application on the PC. Seek the manufacturer's advice for further assistance before doing so.
    • Adding a new Port Forwarding rule may prevent the router from functioning as required. If this occurs, either remove the newly added rule by selecting the radio box next to the rule and selecting Delete from the buttons below, or reset the router.
    </form>

    • Marked as answer by km1947 Tuesday, July 2, 2013 9:05 AM
    Tuesday, July 2, 2013 9:03 AM

All replies

  • Make sure UPnP is actually enabled in the router's configuration.

    I'm not on the WHS team, I just post a lot. :)

    Monday, July 1, 2013 12:30 AM
    Moderator
  • There is a 'tick' in the 'ON' box on the UPnP page but oly one device (my laptop) appears on the list of devices here.

    In the meantime I finally managed to speak to someone at Sky who knew what they were talking about and provided this solution for resolving my problem..... I have notated the instructions in italics to indicate extra actions

    <form action="http://SRVS/CGI-BIN/WEBCGI.EXE" method="post" name="13f94d7daac167c1_theForm" target="_blank">
      • Select Advanced
      • Select LAN IP Setup
      • Below Address Reservation heading, click Add
      • Enter the following details:
      • IP address to reserve
      • The MAC Address of the device
      • Device Name
    1. Select Security.
    2. Select Services.
    3. Select the Add Custom Service button. (you only need to do this for services that are not already in the Firewall Rules drop down menu. You need to obtain details of what services /port numbersyou need to open from the maker or supplier of the equipment you are trying to connect to).
    4. Enter the following details where applicable:
      • the name for the application (make a note of this)
      • the port settings
      • protocol for the port you need to open (TCP or UDP)
      • the port range (Start Port/Finish Port)
      • the port number to translate to  (Not applicable on my router).
    5. Select Apply.
    6. Select Firewall rules.
    7. Select Add below Inbound Services.
    8. Below Firewall Rules - Inbound Services, the Service dropdown holds a pre-defined list of a number of applications that you may wish to allow through your firewall.
    9. Select the appropriate application from the drop down menu (created in step 11).
    10. From the Action drop down select ALLOW Always.
    11. From the Send to LAN Server heading enter the IP address of the attached device where the traffic is to be forwarded to (eg your home PC).

    To find out the devices connected to your router select the Maintenance heading then Attached Devices tab.

    1. Click Apply at the bottom of the page to save the changes.

    If there are problems setting up the Port Forwarding, here are some things to check:

    • Have all the ports been forwarded that are needed, and is the right protocol being used?
    • Is there a firewall active on the home PC, such as McAfee, Norton or Windows Firewall? Port Forwarding may need to be set up within the firewall on the PC if trying to connect remotely to an application on the PC. Seek the manufacturer's advice for further assistance before doing so.
    • Adding a new Port Forwarding rule may prevent the router from functioning as required. If this occurs, either remove the newly added rule by selecting the radio box next to the rule and selecting Delete from the buttons below, or reset the router.
    </form>

    • Marked as answer by km1947 Tuesday, July 2, 2013 9:05 AM
    Tuesday, July 2, 2013 9:03 AM
  • So what they really tell you in there is that the UPnP support isn't all that reliable. :)

    I'm not on the WHS team, I just post a lot. :)

    Wednesday, July 3, 2013 11:54 AM
    Moderator
  • All I know is that it didn't work for me between the new Sky hub and the WHS, which is why I had to look for a solution to manually set up the services to configure the WHS.

    It is now working OK but it was a lengthy and frustrating experience to find the solution I needed from Sky.

    Wednesday, July 3, 2013 5:23 PM