locked
Changing view from LEAD to LEAD: INFORMATION gives Insufficient Permissions Error RRS feed

  • Question

  • Hi,

    CRM2013 update here. Some users seems to have not enough rights to change views from LEAD to LEAD:INFORMATION. I am not able to find anything about this in security profile. 


    Developer


    • Edited by N0sTr4D4m Thursday, November 14, 2013 12:50 PM
    Thursday, November 14, 2013 11:13 AM

Answers

  • Hi,

    Try giving READ privileges to the PROCESS CONFIGURATION entity for each Security role that gets Insufficient permissions.

     

    Thanks,

    Swaroop 

    • Proposed as answer by Swaroop_d Friday, November 15, 2013 1:45 PM
    • Marked as answer by N0sTr4D4m Friday, November 15, 2013 1:56 PM
    Friday, November 15, 2013 1:44 PM

All replies

  • Hi,

    I think your question is about multiple forms in CRM 2013.

    LEAD and LEAD:INFORMATION are two forms for Lead entity.

    Follow these steps and check to see if all security roles are enabled for LEAD:INFORMATION forms

    1. Go to Settings -> Customizations -> Customize the System

    2. Navigate to Lead entity

    3. Expand Lead. select Forms

    4. Select Information form and click on Enable Security roles

    The next screen will tell you which security roles are enabled for this form. Make sure you select Enable all security roles for this form.

    This should resolve your issue.

    Thanks,

    Swaroop

    Friday, November 15, 2013 6:45 AM
  • Hi,

    I did checked these settings before.  Forms were set to "display to everyone". Also all security roles seems to be enabled.  But some users still get permission error. 

    I made mistake in problem description. We are trying to change views from LEAD: INFORMATION to LEAD. LEAD seems to have problem.  But this only happens on some of the records. 


    Developer

    Friday, November 15, 2013 7:49 AM
  • Hi,

    Try giving READ privileges to the PROCESS CONFIGURATION entity for each Security role that gets Insufficient permissions.

     

    Thanks,

    Swaroop 

    • Proposed as answer by Swaroop_d Friday, November 15, 2013 1:45 PM
    • Marked as answer by N0sTr4D4m Friday, November 15, 2013 1:56 PM
    Friday, November 15, 2013 1:44 PM
  • Thank you! it works!

    Developer

    Friday, November 15, 2013 1:56 PM