locked
"Backup Service is not running" error RRS feed

  • Question

  • Hello, I am excited about WHS, and I installed it for the first time a couple of days ago.  I mainly am using it for file sharing across 4 locally used computers, and later for remote use when ppl want to view our photos.

    When I installed, I installed on an 80gb IDE system drive, and 2 250gb SATA drives for pool.  Everything went fine, however, my backup service wont start.  I get this error when I open up the console:

     

    "The Windows Home Server Computer Backup service is not running.  Some Windows Home Server Console functions will not be available.  Please restart Windows Home Server.  If the problem persists contact Product Support"

     

    When I go to Services, and try to start it (it is set to automatic) I get this error:

     

    "The Windows Home Server Computer Backup service on Local Computer started and then stopped.  Some services stop automatically is they have no work to do, for example, the Performance Logs and Alerts service"

     

    I have tried rebooting many times.  because of this error, When i attempted to install the connection software on my main PC, a Vista Ult, it found it ok, but couldn't finish the wizard because the backup service wasn't running.  If i go into the console on the server, my main pc is there, but greyed out.  If i click on it and attempt to remove it, it says that I can't, and gives me an error about the service not running again.

    I can browse the server via network neighborhood, and find the shared folders.

    One thing the console did tell me was that one of my 250gb drives wasn't connected under health, altho the total storage cleary was counting it.  I removed the drive from WHS console (had enough room) and all drives are now healthy, however the backup still wont start.  I have tried everything I know of other than do a reinstall.  I am currently copying all my files off the drive (taking FOREVER) to an additional drive on the server, but not in the pool so I can look at starting over.

    Any help would be SOOOO appreciated, as this will be a cool device to have in the house if I can get it to work.  Look forward to the release.

    I had a server earlier, and tried 2008, but thought this added some cool features (backup) that made it worth it, while allowing easy user policies without requiring AD.

     

    On an additional note, I read somewhere that you can record Vista MCE directly to the WHS and have other vista machines in the house watch the show and have them show up in recorded tv under both.  Is that correct with this software??  I dont need the server to record, but i would love to share amoungst my two Vista MCE computers int he house.

     

    Thanks

    Ryan

    Thursday, July 5, 2007 5:43 PM

Answers

  • We have had many reports of this issue come in, and it is a known issue.
    Thursday, July 5, 2007 6:39 PM
    Moderator

All replies

  •  Ryan Marchini wrote:

    On an additional note, I read somewhere that you can record Vista MCE directly to the WHS and have other vista machines in the house watch the show and have them show up in recorded tv under both. Is that correct with this software?? I dont need the server to record, but i would love to share amoungst my two Vista MCE computers int he house.

    Thanks

    Ryan



    Create a new folder for recording shows to, then set your MediaCenter(s) to store the recorded show in that folder. It requires quite a bit of network bandwidth but it does the job.
    Thursday, July 5, 2007 6:09 PM
  • I appreciate it.  Any idea on the backup problem?
    Thursday, July 5, 2007 6:33 PM
  • We have had many reports of this issue come in, and it is a known issue.
    Thursday, July 5, 2007 6:39 PM
    Moderator
  • So, as of right now, there is nothing that can be done about it?!

    is it worth waiting, and then re-installing, or will it work to install/upgrade over the existing install when the fix is found?

    Ryan

    Thursday, July 5, 2007 7:11 PM
  • I have had very similar problems with a similar server configuration...I have new a SATA drive and a new IDE drive (300 meg each).  The server frequently will drop the IDE drive saying it has a problem...I'm quite sure the drive is OK since I have run various diagnostics and reformatted several times.

     

    When the drive shows up as "bad", the console does not give me the available option of trying a repair.

     

    I'm tired of doing reinstalls since I do run the server "headless" in my basement...it's a real effort to reconnect monitor, keyboard and mouse to do these reinstalls.

     

    I have only had one successful backup on a single client PC since the initial install over 2 weeks ago because I can't keep the backup service active.

     

    I hope a fix is available soon!!!  I guess I assumed that a Release Candidate would not have such a fatal flaw on what I consider the driving impetus for having a home server.  I am reluctant to try any more exploration of the software (i.e. I'd love to get more web sites and Sharepoint Services running).

    Thursday, July 5, 2007 7:50 PM
  • I would suggest reinstalling, and just for fun make sure that you have the latest drivers for everything, latest BIOS, etc.
    Thursday, July 5, 2007 8:18 PM
    Moderator
  • I will try to install again.  I'll download and burn new cd too, just in case.

    hopefully this will help.  Now I just have to wait for all my files to transfer over - it's taking forever!!!!!!  should it take 14hrs to do 100gb?  Sad

    Is it advised to try to install with just one drive to start with (sys drive), and add addt'l drives later, or better to start big with all three drives i mentioned earlier?

     

    Thursday, July 5, 2007 8:23 PM
  • Try installing with one drive. Let the install finish, go thru the initial setup experience, and then start adding more drives one at a time.
    Thursday, July 5, 2007 8:27 PM
    Moderator
  • I re-installed WHS on the same OS drive (new install, not upgrade) without any other drive on the system.  All seems to be up and running now.  Backup is running now, and my clients can finish the connection wizard.  Let's hope it stays that way.

    Thanks for all the help Tom  Smile

    Ryan

    Friday, July 6, 2007 4:44 PM
  • You are welcome!
    Friday, July 6, 2007 5:47 PM
    Moderator
  • Yeah im having the same problems with the

    "The Windows Home Server Computer Backup service is not running.  Some Windows Home Server Console functions will not be available.  Please restart Windows Home Server.  If the problem persists contact Product Support"

    i have tried restarting the server many times and im still having the same problems... i also tried starting the services manually but still had no luck... ?\

     

     

    Bruce

    Sunday, July 22, 2007 2:28 PM
  • Tried the same with the same problem - is a fix to the problem around the corner ???
    Wednesday, July 25, 2007 9:15 PM
  • At this point, the earliest we will probably see a fix is when we can get our hands on a copy of the WHS eval or buy a system builder license.
    Wednesday, July 25, 2007 9:53 PM
    Moderator
  • I have reinstalled three times after this problem occurs. I take it that based on the comments above this is not an issue that has been resolved?
    Saturday, July 28, 2007 3:26 AM
  • This is a known issue, that should be resolved in the RTM build.
    Saturday, July 28, 2007 4:11 AM
    Moderator
  • Its not fixed in RTM -  i have the problem - backup service wont start

     

    Sunday, August 19, 2007 3:49 AM
  • Has anyone got a fix to this?
    Its obviously effecting quite a few users.

    It worries me that it may not be fixed in RTM.
    This is a serious problem.

    THe fix shouldnt be just to re-install.

    Please, if anyone can shed any light, it would be greatly appreciated by many..


    Tuesday, August 21, 2007 1:55 AM
  • I am having the same issue, I did a reinstall and it did not resolve the issue.  The hard drive showed as failed but when I moved it to a different IDE chain it works fine.  However nothing I do can get the backup service working.  If this is still in RTM then there is no way I can say I would buy or recommend this to anyone.  When this happens it is nothing more than a basic file server, which I can do much more efficiently.
    Tuesday, August 21, 2007 8:04 PM
  • I'm having the same problem which just started yesterday after a USB drive got "lost" and was listed as missing but showed up as a non-shared drive.  I added the drive back and then the backup service wouldn't run.  I guess I'll just go back to XP on that computer as all this file transferring back and forth is a real pain even for a beta test.  I hope when they release this to the public they fix many of these issues or there is going to be a lot of unhappy campers.  It's a great idea but if it's not reliable it will get a black eye in a hurry.

     

    Previously I was using the same computer only as file storage for over 1 TB of videos and other files along with a media extender and with few programs installed on XP it had no problems, never needing rebooting except for updates.  It would be great if WHS could be serve the video reliably along with the regular backups of all the home computers but it's just too much of a hassle to keep it going with the present version.

     

    So, so long and thanks MS for letting me try it out.

    Thursday, August 23, 2007 10:41 PM
  •  

    After running WHS for several weeks without having any issues I'm now stuck with the "Backup Service Not Running" problem.  I tried to re-install WHS but no luck.  This started about the time when I added a new PC to the network.  Did anybody figure out a reliable fix for this?
    Thursday, September 27, 2007 6:58 PM
  • This problem struck my WHS last week.  After several reboots, restarting the backup service, etc., I decided to attempt manual backups of each of the six nodes which are serviced by WHS.  I found that two of the computers were causing the backup service to fail.

     

    I disabled the backups for those two computers, and have not had a problem since.  Thus, I believe that it is the connector software which is causing the problem; I will try reinstalling the software at a later date to try and confirm this. 

    Hope this info is of some use to you.

     

    Rob

    Friday, September 28, 2007 2:21 AM
  • Sorry for kicking this to the top again, but I did want to post the results of my test.  Like the original poster, I was receiving the "backup service not running" message.  The appearance of the message on my server seems to be a bit different, so I will provide a bit of background info.

     

    Server info: Custom built unit w/ one 320GB SATA and two 180GB IDE drives.  Running RC1; Installed properly on the first attempt, was running w/o issues for about 3 months.  The server has 6 PC's connecting to it, with varying OS's.

    Symptoms: Automatic backups failing, manual backups causing the Backup service error to appear.  "Network Critical" status.

    Attempted fixes: Restarting the server, restarting the PC's.  Stopping and restarting the backup service in the MMC console.

    The fix that worked: After restarting the server, I tried manual backups on each of the six computers.  Found two nodes were causing the backup service to fail.  Disabled the automatic backups for these two computers, and the backup service ceased to have problems.  I reinstalled the connector software on one of the two computers.  Tried backup again.  Backup failed, saying that there were errors on the HDD, and that a chkdsk /r needed to be run.  Did so, and it found bad clusters.  Tried a manual backup again.  Success.  Ran chkdsk on the other, then reinstalled the connector.  Success.  Also, the automatic backups both completed successfully last night.

     

    Hope this info is of use to someone.

     

    -Rob

    Tuesday, October 9, 2007 12:53 PM
  •  

    Hi guys,

     

    i've been evaluating this release for a while now, and i've now all of a sudden got the "backup service not running" error.

     

    i'd like to say i've found the answer, but i havent, i'd also like to say i know what i did wrong, apart from breathe on the damn thing, but also, i cant.

     

    its a shame that this product has so much promise, yet simple things like this seem to be tripping us up, otherwise i'd be shouting from the rooftops how good it was as this is the backup/managmenet solution i've been looking for and havent found for so long.

     

    has anyone got any updated information on this error yet?

     

    cheers

    Friday, October 26, 2007 9:33 PM
  • My server just got this problem as well tonight. Everything shows healty and I cannot find a cause for the backup service to fail as soon as it starts. There really needs to be a patch for this problem soon.  Ive been running OEM for 3 weeks now without a hitch until this and am not inclined to do a clean install and have to worry about the 4TB of data that is now stored on the server.

    Sunday, November 4, 2007 9:39 AM
  • Same problem here on the OEM version which has run fine for weeks. Although seems to have been preceded by one of my USB drives failing.
    Tuesday, November 6, 2007 12:20 AM
  • I've had a similar problem with my OEM installation.  pjtaylor, AllenSmoker, mr_claypole, and anyone else having this problem, will you please check your event viewer Homeserver log for a pair of errors that appear after each reboot.  The first error will read "Backup, Event: 272 "Unexpected error 0x6 from CreateFile on D:\folders\{00008086-058D-4C89-AB57-S7F909A47AB4}\{92AC9F66-6C3C-43EB-AA29-F0D68586DEDB}.Machine.configdat: The handle is invalid"  and the second will be similar to "Client Backup server failed at D:\qhsv_1_rtm_qfe\qhs\src\backup\util\diskfile.cpp(145).  I am thinking that the invalid file handle is caused by an interruption of communication between the server and a client, then the invalid file handle causes the backup service to crump.  In my case, the interruption was caused by a momentary power outage.  Both the server and the client were on UPS, but the network switch's UPS failed.  Reading several related threads reveals possible communications or power glitches.

     

    Please let me know what you find.

     

    Thanks

     

    Tuesday, November 6, 2007 5:47 PM
  • Yep, that's the error. I was about to reply to your previous post with regards to your solution. I don't think I'm quite technical enough to understand it! Can you elaborate?
    Tuesday, November 6, 2007 10:38 PM
  • I have explained it some time ago in this thread: http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=2291860&SiteID=50, however that went one step further in order to fix the problem and keep existing backups.

     

    I have slightly adapted the instructions from that thread:

     

    1. on WHS in cmd shell browse to D:\folders\{00008086-058D-4C89-AB57-S7F909A47AB4}

    2. list contents with dir command. (should contain a lot of .dat files)

    3. next do "fsutil reparsepoint delete index.4096.dat" (replace with index.4096.dat with file generating error)

    4. repeat step 3 for all files generating the error

    5. delete all files in folder

    6 cleanup database from settings menu in WHS console

     

    Instead of steps 5 and 6 you could also use the database cleanup tool provided in the WHS toolkit: http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=2253939&SiteID=50

    Tuesday, November 6, 2007 10:56 PM
    Moderator
  • That's done the trick. Apologies for not going back far enough!
    Tuesday, November 6, 2007 11:18 PM
  •  pjtaylor wrote:
    That's done the trick. Apologies for not going back far enough!
    No need to apologise!! It's often not easy to find the answer you need within the large number posts on this active board
    Tuesday, November 6, 2007 11:27 PM
    Moderator
  • I have the same error but that fix didn't work for me. Do you have any other solution?

     

    Thanks

     

    Wednesday, November 7, 2007 9:25 PM
    Moderator
  •  

    try the windows home server toolkit. If you get rid of your previous backups (erase the database) it might solve your problem.
    Wednesday, November 7, 2007 9:32 PM
  • I downloaded the toolkit and try to install it on the server the way it is described in another thread and it doesn't want to install. I get the error network path not found.

     

    Klode 

     

    Wednesday, November 7, 2007 10:19 PM
    Moderator
  • Klode,

     

    Please elaborate.  What happened when you tried the fix?

     

    Thursday, November 8, 2007 1:22 AM
  •  Klode wrote:

    I have the same error but that fix didn't work for me. Do you have any other solution?

     

    Thanks

     

    You need to supply more information:

     

    What error? Please detail?

    What "fix" did you try?

    If it's some custom fix tell what you did step by step, include where it went wrong (exact error messages)

    Thursday, November 8, 2007 2:49 AM
    Moderator
  • WIth your network error when trying to install the toolkit, are you able to connect to the server? I have to restart mine every so often when I get the errors you are talking about. But I can tell you, if you get the toolkit installed, it fixed all backup errors I was getting.

     

    You do lose all your backups though.

     

    Also, install the toolkit as an addin using the steps outlined in the information with the toolkit. I am not sure what you read in what thread, but I installed my toolkit just as it instructed and everything went fine.

     

    Hope that helps,

     

    Friday, November 9, 2007 5:41 PM
  • Same error message as thread starter after a comple re-installation of WHS oem-version.

     

    Uninstalled all Home Server Connector Software on the workstations (some were up and running), restarted the server and all worked just fine. No need to repair any databases in my case.

    Friday, May 16, 2008 1:23 PM
  • I have the retail product and then problem is still there.  This is third time the home server has crashed in a year of running, with no warning and ended up in a state where recovery is not possible.  When you do get a problem help is non existent form microsoft, you get some people on the forums doing their best to help, but the people who wrote the software are no where to be seen. (Busy sorting out Vista I suppose). This software has a brilliant design concept, but a very flakey implementation.  Fancy a critical server relying on that noddy system that it uses for I/O.  No wonder the system can't get up agan when it falls over. I am going to give up on WHS, money down the drain.  I shall put XP on the server and find third party software to look after backup.
    JG
    Wednesday, November 19, 2008 10:53 AM
  • What's the fix?
    Friday, September 24, 2010 5:23 AM