none
The FileSyncProvider received an unexpected error while applying a synchronized change. RRS feed

  • General discussion

  • I recently started getting this error message from SyncToy 2.0, and I thought I'd mention how I fixed it.

    I had 2 PCs, one stored my files, the other accessed them like a terminal. The terminal PC was directly wired to the router, the connection to the file storage PC was wireless. I used SyncToy on the terminal PC to echo a backup of the files onto its spare hard disk. It worked very well, with never a problem. A month or so ago, my main hard disk failed - boy was I glad I'd got a backup of the family's files, which I just converted into being the main file storage, and gave the family instant ccess to their files :)

    I replaced the broken hard disk, and set the SyncToy to copy the files back. However, this would not work - I repeatedly got the error message above, normally after syncing only about 20-50 files. I couldn't really understand this as it was exactly the same network configuraion I had before. I never had the problem before and I always had it now.

    So I installed SyncToy 2.0 on the PC with the new empty hard disk and set it to echo the files back down to itself. It may be early to say but it has done over 4,000 files so far, first time, with no problem.

    So my conclusion is that Synctoy works very well to 'pull' files, but not for 'push'. Try to 'push' and the message above seems to appear.

    I know this is difficult for anyone trying to synch to a NAS etc. However, it may help some people?

    Cheers

    Eric
    • Edited by bb193 Wednesday, July 15, 2009 12:22 PM
    Wednesday, July 15, 2009 11:17 AM

All replies

  • Hi -

    I was a little confused as to your setup so I apologize if this does not apply. But we know that in the currrent version there is a problem sync'ing files over wireless networks. Wireless networks are "lossy" and we did not do a good job of handling those kind of errors. But the underlying technology really does not discriminate between "pushing" vs "pulling" files. And just to spread the word out more - we do not recommend using SyncToy 2.0 with NAS drives - we know there is a corruption issue.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Friday, July 17, 2009 12:55 AM
    Moderator
  • Thanks for the reply.

    The precise configuration doesn't really matter. I have one computer with a wireless network connection to the router (A) and another with a wired connection to the router (B).

    I installed SynchToy on B. For 6-8 months, I had SyncToy pulling files to B from A, every hour, on the hour. This involved tens of thousands of files, and tens of gigabytes of data. I never had a failure of SyncToy - not one. I know this because I had put a logging process in place (http://social.microsoft.com/Forums/en-US/synctoy/thread/d0970c9c-9178-4856-a267-2567e7c2e354) which logged every transfer - no errors were reported in any of these logs. My wireless lan infrastructure works fine with SyncToy.

    Then the disk in A failed. I made B my primary file storage which the family could access (many thanks SyncToy - you saved my life!) and replaced the disk in A.

    Then I changed SyncToy on B to push the files back from B to the empty disk in A. It failed consistently with the error given above, after transferring only a few handfuls of files, or a short number of minutes. Every time. It did not work. I had made no changes to the network or anything. What had worked perfectly for months now never worked.

    So I installed SynchToy on A and pulled the data to A from B. This worked fine. I have so far transferred over 13,000 files, again involving tens of gigabytes. I have not had a single problem. Not one. It just works.

    I understand what you are saying about not distinguishing between push and pull. However, I'm just reporting the results of my very simple test. The conclusion I come to is that pull works fine, push does not work. This may involve issues about having a wireless conenction - there may be a flaw or weakness around latency, error detection/correction or something. If someone wants to test out other configurations, that would be great. It may be that such tests actually find the conditions for success or failure are more complex than I suggest - which might lead to a fix being found.

    Really, I was just trying to make a helpful suggestion to anyone who gets the error message above. Try pull rather than push. My small test suggests it is much more likely to work.

    Cheers

    Eric
    Friday, July 17, 2009 8:35 AM
  • I'm sure there is something else wrong with using it with NAS drives.

    However, my hypothesis suggests that 'pushing' fies to a NAS drive is bound to fail.

    I just wonder if storing files on a NAS drive and 'pulling' them off onto a disk in the PC would work....? Anyone tried that, or got that configuration working?

    Cheers

    Eric
    Saturday, July 18, 2009 9:14 AM