none
Unable to run synctoy or install latest version RRS feed

  • Question

  • I had installed Synctoy some time ago and had not used it in quite a while. Today when I tried to run Synctoy, I get a Windows Installer message "The feature you are trying to use is on a network resource that is not available.  Click "OK"  to try again, ot enter an alternate path to a folder containing the installation package 'Setup[1].msi' in the box below. I have tried installing the Synctoy 2.0 again and get the same message. If I try to Add/Remove programs and remove Synctoy, I get the same error message. Does anyone know how I can remove Synctoy and start over again, or is there a way to get past this error? 

    Friday, November 7, 2008 6:46 PM

Answers

All replies

  • It seems like you deleted the contents of your temporary folders and the uninstaller cannot find the file Setup[1].msi.

     

    Can you try to download SyncToy 2.0 again and reinstall it?

     

    Maria del Mar Alvarez - MSFT

    Tuesday, November 18, 2008 1:25 AM
  • I am having the same issue with being unable to install SyncToy 2.0 or remove SyncToy 1.4.

    In response to the other reply about reinstalling the program it is apparently not possible because the Synctoy 1.4 version has been removed and can no longer be downloaded. 

    Is there a manual way to go in and remove SyncToy 1.4 without having to have the old Setup.msi file?  It seems rather strange for a program to put a file that is necessary for uninstallation in a temporary files folder.  Surely there is another way to solve this?

    Using the Microsoft Installer Removal Tool does not solve the problem.  The installation of SyncToy 2.0 still stops asking for the Setup.msi file.


    Tuesday, November 18, 2008 3:23 PM
  • I am looking for a way for you guys to uninstall SyncToy 1.4 without the setup.  I will get back at you within 48 hours.

     

    Maria del Mar Alvarez Rohena - MSFT

    Tuesday, November 18, 2008 5:52 PM
  •  

    I am having the same problem

     

    Thursday, November 20, 2008 11:25 PM
  • I am having a simular issue, only I had 2.0 installed and running but it no longer works.  I want to reinstall it but I am unable to uninstall and I'm getting the same issue about not finding the correct setup.msi file.

     

    I believe my issue is the result of some data corruption that occured, however now I seem to be stuck unable to uninstall SyncToy 2.0 so I can reinstall it.  The closest thing I could find in my searches was this post.

     

    Any thoughts would be appreciated.

     

    Thanks,

    Jason

     

    Sunday, November 23, 2008 5:54 AM
  • Did you try to re-download SyncToy 2.0 and re-install from the Setup file?

     

    You can get SyncToy 2.0 from here http://www.microsoft.com/downloads/details.aspx?FamilyID=c26efa36-98e0-4ee9-a7c5-98d0592d8c52&DisplayLang=en

    Monday, November 24, 2008 10:56 PM
  • I installed SyncToy 2.0 yesterday on XP Home PC (SP3). Never had any version of SyncToy installed before. It would not run. Re-downloaded the software from the above mentioned site & reinstalled. Reinstallation actually gave two options: 1) Repair or 2) uninstall. I tried each one by one. It didn't work. Tried uninstalling from control panel, re-install, repair, uninstall, re-install...nothing helped. Then, I installed SyncToy 2.0 beta after uninstalling SyncToy 2.0. SyncToy 2.0 beta worked fine. So, I installed SyncToy 2.0 again.

     

    Eventually, I right clicked SyncToy 2.0.exe file, selected Properties, clicked on Compatibility tab and selected "Run in 256 colors" under Display settings. Then it ran fine! Of course, my monitor switched the display mode. Once I close SyncToy, the display goes back to my normal display setting.

     

    This whole ordeal took 3 hrs+ out of my life, BTW.

     

    This should give Microsoft folks some clues as to how to fix it. Right now, at least I can use SyncToy 2.0 but 256 color mode is a bit crummy

     

    Enjoy!

     

    Wednesday, November 26, 2008 7:23 AM
  • I did try the link above to download the latest version and install it.  I think my issue was that all the application files were deleted but the application still had all it's entries in the registry (The story how that happened is long and painful and I'm not fully sure I understand what happened).  So to fix my problem I searched the registry for "synctoy" and deleted any entries I found that were not pointing to the .exe install file that I had downloaded from the link above.

    WARNING: I do not recommend anyone messing with the registry.  I was frustrated and only had a slight idea of what I was doing as I was following some tips I found online on how to manually remove applications from Windows XP.  Always make a backup of the registry before you start doing things to it. 

    If anyone who does know what they're doing in this regard, can you post or link to some instructions on how to remove Synctoy manually if needed (which files and registry changes to make)?

    Once I finished my wreckless attempts at removing Synctoy manually, I rebooted and installed Synctoy 2.0 without issues and everything appears to be golden.

    Thanks for the help.
    Jason
    Wednesday, November 26, 2008 4:10 PM
  • Well, I found the problem! In my case, it was related to Firewall. I have "CA Internet Security Suite 2009" installed that has firewall that has a security feature which blocks many (unknown) applications and keeps them from running. It has the capability to select applications and/or executable files as "Trusted" and/or "Safe". Once I selected the SyncToy application as "Trusted" and "Safe" SyncToy 2.0 ran fine.

     

    So, any of you out there having similar issue, check your firewall/security software to make sure it is not blocking SyncToy from running.

     

    HTH

     

     

    Saturday, December 13, 2008 9:43 PM
  • Thanks Jason.

    I did as you stated and did and edit and found all references to Synctoy in the registry and deleted them and then SyncToy 2.0 installed without any problems. Now for the real test, I am going to reboot my system and see what I might have screwed up in the registry. Keeping my fingers crossed.

     

    Ricky

    Wednesday, December 31, 2008 9:44 PM
  • I just wanted to post that i too searched the registry for all instances of "Synctoy" and deleted the all traces of it, then tried a fresh install and it worked perfectly..

    thanks for the advice.
    Tuesday, January 13, 2009 3:06 AM
  • It looks like people have had luck with msicuu2.exe

    http://forums.microsoft.com/Sync/ShowPost.aspx?PostID=3607028&SiteID=75

     

    Liam


    Program Manager, Data Replication and Synchronization - http://msdn.microsoft.com/sync/
    Wednesday, February 18, 2009 5:04 PM