HPC Pack Update 3 locking LogonUI.exe on Windows 10 RRS feed

  • Question

  • It appears I've found an issue with the HPC Pack on Windows 10 workstation nodes, causing LogonUI.exe to freeze (or otherwise not respond to) Ctrl-Alt-Del at the lock screen.  I can trigger it by either pressing CAD and not entering credentials and letting the screen re-lock, or by entering credentials wrong until the account locks, thereby also re-locking the screen.  In either case, the keyboard appears completely unresponsive although the mouse works.  Short of a hard shutdown, the only solution is to use tasklist and taskkill remotely to end LogonUI.exe.

    Removing all HPC components stops the issue from occurring.  I have tried various other software combinations, including removing EMET and our antivirus, before resorting to removing HPC.  Once I discovered HPC was the issue, I tried stopping individual processes, as well as all of them, and also by adding idledetector.notidle to %CCP_Home%\Bin.  Nothing apart from removing it helps.  This has not happened on Windows 7 at all.

    Has anyone else seen this, and is there a solution?  We are big fans of workstation nodes as it lets our engineers use every machine in the office overnight, but this has been a serious problem.  It happens frequently to users that start to unlock their workstation and then get a question from a co-worker, a phone call, or other distractions.

    Monday, June 20, 2016 6:36 PM

All replies

  • Hi,

      We will look into the problem now and respond back to this thread once we get any clue.

    Qiufang Shi

    Tuesday, June 21, 2016 12:56 AM
  • Hi, bryan

    We didn't repro the problem with Win 10 Version 1511(November Update of Win 10), OS Build 10586.318, using the step:

    1. Make the computer HPC R2 Update 3(4.05.5079) installed, and work as workstation in a cluster. Assign template and make the node online.

    2. Lock the screen, and then use Ctrl-Alt-Del at the lock screen. (Work. As it show screen to input password, and can input with keyboard)

    3. Wait the screen to re-lock, or entering credentials wrong until the account locks, and use Ctrl-Alt-Del at the lock screen again. (Work. As it show screen to input password, and can input with keyboard)

    Could you offer more about your environment:

    1. What's the Win 10 version?

    2. Is any program(workload) running through HPC when the issue you described happened? Could you try stop all the HPC Services through Services, and repo the issue again?

    3. Is this issue happened on one specific workstation node or all the win 10 workstation nodes?



    Tuesday, June 21, 2016 3:23 AM
  • Hi,

    Our systems are the same version, 1511 Build 10586.318, though I should mention we are using Pro in case that makes any sort of difference.  The HPC components are the same version.  All office workstations are using a template that keeps them offline during working hours, so there is nothing running on them when this happens.  I can try moving one to an always online template and see if it persists.  When marked as offline, I tried stopping individual and all services and couldn't prevent the issue.  I've been able to cause it on any system with all the workstation nodes installed.  It was just today I figured out that removing HPC resolved it, so I can also check if having just the console installed also causes it.

    Just for reference, this is my previous thread on the locking issue.  As mentioned, it was earlier today I found that HPC fixed it:



    Tuesday, June 21, 2016 3:45 AM
  • Hi, bryan

    When the issue happened, could you use mouse click to get into the screen to input password? Does keyboard input work in that screen?

    There is setting naming as "Ease of access" in the password input screen, and could you check if "Filter keys" included in this setting button is enabled when the issue happened?

    Could you double confirm, if this would repro when you stopped HPC Idle Detector Proxy Service and also has killed process HpcIdleDetector.exe.

    Best Regards,


    Tuesday, June 21, 2016 4:45 AM
  • Hi,

    First, I just thought I should mention the build on my workstation is now 10586.420, I updated yesterday.  The issue remains though.

    I have found that the ease of access button does not appear until after pressing CAD, so while I can move the mouse there's nothing to click.

    The issue did remain when I stopped the Idle Detector process as well as killing the executable (I had not previously checked for the executable).

    I also tried moving my workstation to an always-online template, however the issue kept up there as well.


    Tuesday, June 21, 2016 1:41 PM
  • Hi, bryan 

    Would you please help to provide the following information, as this may help to infer the root cause.

    There are two screen:

    The first is "Lock Screen" commonly with image, time, network.

    The second is "Password input Screen" commonly can be shown when "Click mouse left button" or "use Ctrl+Alt+Delete" in the "Lock Screen"

    As last rely,

    1. Could you "use mouse click (please both try the left and right button)" to get into the "Password input Screen" from the "Lock Screen"?

    2. If you can "use mouse click" to get into the "Password input Screen", does keyboard input work in "Password input Screen"?

    3. There is setting naming as "Ease of access" in the "Password input Screen", could you check if "Filter keys" included in this setting button is enabled?



    Wednesday, June 22, 2016 2:35 AM
  • Hi,

    Ctrl-Alt-Del is enforced by policy, so I can't use the mouse to get past the lock screen.  I did just lock the screen and get to the password input screen, under Ease of Access, Filter Keys is off.


    Wednesday, June 22, 2016 1:17 PM
  • Hi, bryan

    We have no repro with lots of settings, and still need your help to offer more information and try some experiments regarding the issue:

    1. Could you export your workstation node's node template and paste it here?

    2. Could you fulfill such experiment and provide results:

        a. Lock the screen, and open "On-Screen Keyboard" in "Ease of access"

        b. Try press Ctrl or Alt button, see if the corresponding key in the "On-Screen Keyboard" would change color?

        c. Get the issue repro(by wait some time or error password input). When it's in the "Lock Screen", try long press Ctrl or Alt button(For each button, please press for 5-10 seconds), will the color change on "On-Screen Keyboard"?

        d. Could you use "On-Screen keyboard" to type Ctrl+Alt+Del to unlock the "Lock Screen"?

    3. You have mentioned uninstallation HPC could solve the issue, by which means you did the uninstallation? Just uninstall HPC Server\Client\Excel Components from appwiz.cpl or also uninstall some other programs installing with HPC using System Recover? Will just remove some HPC like just remove HPC Sever Component help to solve the problem? Do you reboot the computer after uninstallation? If you just uninstall and do not reboot, will the issue be fixed?

    4. Have you tried if you install HPC back after uninstalling, will cause the issue repro again?

    5. In another discussion thread, I found you said not each computer get this issue, so does every computer installing HPC get this issue? If not what's the common setting for the computers have this issue except installing HPC?



    Thursday, June 23, 2016 8:32 AM
  • Hi,

    I locked the screen, enabled the Onscreen Keyboard, and saw that Ctrl and Alt would light.  I then triggered the screen lock issue with the keyboard still up, and even though Ctrl-Alt-Del did not take me to the password screen, Ctrl and Alt still changed on the onscreen keyboard.  However, I cannot use the onscreen keyboard to successfully enter Ctrl-Alt-Del and get to the password entry.

    I used the Control Panel to uninstall all HPC components and reboot.  Today I will try to vary how that is done, reinstall, and narrow it down if possible.

    In the other thread, I meant that not all computers were affected as far as Windows 10 was concerned; at that time I was afraid it was a 10 problem.  I have been able to trigger it on anything that has the workstation components installed.  I have not seen it on a machine that only had the console, though I will try to verify that.

    Finally, here is the template that user workstations are under:

    <?xml version="1.0" encoding="utf-8"?>
    <Template xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          Value="False" />
          Value="10" />
          Value="USER_INPUT_AND_CPU" />
          Value="10" />
          Value="20" />
          Value="600" />
          Value="Determines availability policy for a given workstation with idleness policy." />

    Thursday, June 23, 2016 1:21 PM
  • Hi,

    I have done a bit of extra testing today.  I took a laptop that was recently setup with 10, same as the other systems.  It was tested several times and did not show the locking issue.  First I installed just the client components, which did not introduce any new services.  This did not affect the machine at all.  Next I installed the workstation node components, did not do anything on the server (I didn't adopt the system or apply a template, it was left pending) and immediately was able to cause the locking issue.  Then from Control Panel, I removed only the HPC Pack 2012 R2 Server Components, leaving the client services, Excel services, and MPI.  I did not reboot.  This fixed the issue right way; I have tried it several times and was able to get to the password screen each time.  Then I reinstalled the Server Components, again without rebooting, and immediately again the issue happened.

    I also set up a new virtual machine and disabled all applications in MDT, so the VM installed nothing but 10, and removed GPOs and blocked inheritance on the OU it joins.  Here too it happened.
    • Edited by bryan.doe Thursday, June 23, 2016 9:03 PM adding information
    Thursday, June 23, 2016 3:56 PM
  • Hi, bryan

    Here listed the results of experiment, please give comments if anything described is not accurate:

    1. The "On-Screen Keyboard" testing show: Even when issue happened, in the "Lock Screen", when you press Ctrl or Alt through keyboard, OS can get the event normally, because the corresponding key light on the "On-Screen Keyboard", however LogonUI doesn't respond. Only if you kill the process LogonUI remotely, and after it restart again, LogonUI can get the keyboard events normally.

    And When you use mouse to click Ctrl, then Alt, then Del on the "On-Screen Keyboard", unlock still fail when issue happened.

    2. Uninstallation testing show: HPC Sever Component is related to the issue, even without any action like template assigning. Pure installation and uninstallation can cause and solve the issue.


    1. Experiment on virtual machine show: Without GPO influence, (I suppose in this condition you can use mouse click or any key to unlock the screen when the issue not happened? As no strict Ctrl+Alt+Del policy in this case? Would you please comment on this?), even in this condition, the issue still keeps (cannot use ctrl+alt+delete to unlock).

    Could you use mouse to unlock when issue happened in this case?

    How do you press Ctrl+Alt+Del, through emitting keyboard events using Hyper-v(and etc)?

    2. Could you try this testing if you haven't do binary delete and reboot last time: Stop HPC Idle Detector Proxy Service, set the service as disabled; Kill process HpcIdleDetector.exe ;Delete HpcIdleDetector.exe and HpcIdleDetectorProxyService.exe in %CCP_HOME%bin folder, and reboot the computer. Will the issue happen again?

    Actions we can take further:

    1. If the problem still keep, would you please provide a mail address, and we may discuss about if we can get the complete memory dump file of the newly made testing virtual machine you tried, and about how we can move the data collected. And whether it's possible we can get the vhd of the vm established just for testing.



    Friday, June 24, 2016 7:40 AM
  • Hi,

    Your recap of the situation thus far looks accurate.

    For the virtual machine, I was using VMware Workstation, which has a dedicated button for the CAD sequence.

    I already deleted the VM (I can create a new one), but I changed the GPO on my test laptop so that it would not require CAD.  I'm unable to reproduce the issue.  As soon as I press Ctrl (any key, actually), it brings up the password screen.  With the CAD requirement disabled I can also use the mouse to unlock the screen.

    After re-applying the GPO to force CAD, I rebooted, then stopped and deleted files and services as described, then rebooted again.  I was able to reproduce it immediately.


    Friday, June 24, 2016 9:27 PM
  • Hi, bryan:

    Could you offer more details about the GPO settings forced in your side besides forcing CAD? We will try to establish a private domain and testing with the GPO settings you provided.

    And as last reply, what's the conclusion for this:

    "Question - 2. Could you try this testing if you haven't do binary delete and reboot last time: Stop HPC Idle Detector Proxy Service, set the service as disabled; Kill process HpcIdleDetector.exe ;Delete HpcIdleDetector.exe and HpcIdleDetectorProxyService.exe in %CCP_HOME%bin folder, and reboot the computer. Will the issue happen again? "



    • Edited by Jiachen Fan Saturday, June 25, 2016 8:57 AM
    Saturday, June 25, 2016 8:55 AM
  • Hi,

    Sorry about that.  For question 2, I did all that exactly, and the issue kept up.

    On regular systems, there are lots of GPOs in use, but when I tried the clean install it was just a single one forcing the use of CAD.  I blocked all others, so it seems like that rules anything in GPO out.  I suppose my next move is grabbing the more recent volume license .iso and try clean installing from that.  They have all been  installed by MDT as well, I'll look through the task sequence for anything.

    Very odd issue, for sure.  Seems typical that it's just me ;)  Thanks for all the help so far!

    Monday, June 27, 2016 4:52 PM
  • Hi, bryan:

    You are welcome. This issue is hard to repro, and we are willing to offer more help. 

    We have tried setting up a private domain with GPO forcing the use of CAD, still no repro, with Win 10 Version 1511 10586.218 x64.

    Another experiment worth doing through VM is (take snapshot) and then disable all the HPC services, deleting all the binaries under %CCP_HOME% folder and restart the VM, try if the problem still can repro. We will double check if any part in HPC setup would cause a System Level impact.

    Best Regards,


    Tuesday, June 28, 2016 4:15 AM
  • Hi Jason,

    I just wanted to say I haven't forgotten about this issue.  I've been out of the office most of this week.  I probably won't be in tomorrow either but will try to get back to this early next week.  Hoping we can find what's going on!


    Friday, July 1, 2016 3:53 AM
  • Hi, bryan:

    Let's continue the cooperation on investigating this issue when you are available. As we don't have repro locally, we still need your assistant to do experiments and collect information. Two paths may help to find the root cause as what we have been cooperating to do:

    1. First path is to experiment and try to exclude the factors. Currently as the experiments, we know after installing server component will cause the problem(all services will get automatically started), and idle detection service will not cause the problem. In this path, to get progress, we need your help to continue the experiments to find out if setup will cause the problem or disabling some more services with reboot can solve the problem (as the experiments mentioned in the last reply) and what's the part of setup causing the problem(next step, if setup is the root cause).

    2. Second path is to collect the dump of LogonUI.exe and kernel dumps and investigate if LogonUI.exe rely on anything HPC could influenced. And this may need your help to collect the dump and send to us. As mentioned previously, if this way is possible, please leave a private mail account, which we may discuss the way to share data.

    An interesting thing is no repro find in private domain with GPO forcing the use of CAD, with Win 10 Version 1511 10586.218 x64 and HPC 4.05.5079. Anything more specific about the environment can be provided?



    Wednesday, July 6, 2016 1:44 AM
  • I had  same issue last Oct 17 2016 if im not mistaken. and until now its pretty hard for me to recover this issue. Logonui repeated many times, i cant handle to do CTRL ALT DEL, because of auto switching, black screen with logon at command prompt and switch to console plain black. ENter user credential...... and so and switch to another logonui. image
    • Edited by mikonewbie Wednesday, October 19, 2016 1:57 AM
    Wednesday, October 19, 2016 1:27 AM
  • Oh man, I feel terrible I never got back around to this thread.  Apologies.  It's still been an issue for us, but I removed the HPC pack from a handful of users that would constantly trigger it, so it hasn't really happened much more.  That said, we are not yet running Windows 10 version 1607, so I don't know if it has improved there.  I've also considered dropping the Ctrl-Alt-Del requirement, as my understanding is 10 doesn't really need it, but I'll need to look into that more.

    mikonewbie - were you able to try a remote tasklist/taskkill?  That reliably fixes it for me.  I've never wound up like your screenshot.
    Wednesday, October 19, 2016 1:15 PM
  • This is unfortunately still going on.  I had hoped upgrading to Windows 10 1703 would resolve it, but that didn't help.  I then had hope that moving to HPC Pack 2016 would fix it, but there again I'm not seeing any improvement.  In fact, I found that with 2016, the screen shows only the background image, no user information.
    Friday, August 4, 2017 3:48 PM
  • Sorry for lost tracking this issue. We will revisit this issue again.

    Qiufang Shi

    Monday, August 7, 2017 9:40 AM
  • No problem, that's more on me than anything.  Let me know what I can do to help narrow it down.  Thanks!
    Monday, August 7, 2017 2:54 PM
  • Hi bryan,

    We tried again to repro this issue locally with Win10 Pro workstation nodes but failed. Could you check the event logs on the workstation nodes that has the logon UI hang issue in your environment and see if there is any error or warning events? Especially for HPC related events under Event Viewer -> Applications and Services Logs -> Microsoft -> HPC -> IdleDetectorProxy / Management.


    Yutong Sun

    Tuesday, August 8, 2017 8:56 AM
  • First, I should note a few minor changes:

    -With HPC Pack 2012, if the screen relocked, it looked like Ctrl-Alt-Del wasn't responding - the lock screen otherwise looked normal.

    -With HPC Pack 2016, I'm now finding that nothing is on the screen except the lock screen image; no text, no user name, nothing. 

    -With 2012, if I tried to remote desktop to the affected system, it basically went into meltdown mode and became progressively more unresponsive until it had to be hard shutdown.  This was why I was using tasklist and taskkill remotely. 

    -With 2016, I can RDP to the system, and the normal lock screen immediately comes up, and I can log in locally.

    In short, the situation seems a bit improved.

    As for the event log, there are no errors under IdleDetectorProxy or Management.

    Wednesday, August 9, 2017 1:41 PM
  • I am also experiencing this exact issue across a variety of PCs, in an intermittent fashion.

    Running Windows 10 1703, with HPC Pack 2012 R2 Update 3 Workstation nodes.

     Has there been any answers or updates to this issue? I see that updating to 2016 Client did not solve it for others, but I have not tried it myself.

    Friday, March 23, 2018 5:52 AM
  • Still an issue here.
    Thursday, March 29, 2018 1:08 PM
  • Hi Byran, MFXr

      I know this is painful, and we tried several times to reproduce the problem without any luck. Are you able to create a support ticket to Microsoft and have support engineer to spot on the issue?

    Qiufang Shi

    Friday, March 30, 2018 6:51 AM
  • My first comment had an error in it, and that was saying it was intermittent. It isn't, as it affects any PC with HPC workstation pack installed.

    I have tried stopping HPC services one by one, then all of them, uninstalling HPC components one by one, and the problem is solved only when HPC is completely uninstalled.

    I have then installed a new HPC server with HPC 2016 Update 1, upgraded my test PC to Windows 10 1709, then installed 1 workstation node to test.

    The problem occurs in just the same way, immediately . It is easily repeatable.

    As soon as the PC screen goes to sleep, then you go to login, press ctrl+alt+del there is no response.

    You can remotely manage the PC and kill the LogonUI.exe to make it responsive, but that obviously does not help much.

    We did not have any issues like this at all with Windows 7, 8, 8.1 and was only introduced when we went to Windows 10.

     I will have to look into a support ticket, but this is very frustrating as it seems to be a common, and easily replicable  issue.

    Friday, April 6, 2018 6:55 AM