locked
Large Capacity Hard Drive Issue RRS feed

  • Question

  • I just instaled home server on a 100gb IDE hard drive no problem. my roomate had went out to best buy today and picked up a 750 gb SATA hard drive, so im deciding to use the 750gb instead. i instaled it, its recognized in the bios and everything, but when running the windows instalation, it tells me that no hard drive is detected. does anyone know why this maybe? am i forgeting something in the setup process?

     

    Monday, April 23, 2007 5:04 AM

All replies

  • Without knowing the specifics of your hardware, the most likely issue is that WHS doesn't have a driver for your SATA controller. If you still have the 100GB IDE drive in working condition you can boot with it as the boot drive and check the device manager with the SATA controller and drive also installed. I suspect you'll find the SATA controller with a yellow ! in device manager indicating there is no driver present. This would be strictly an information gethering excercise and not required to get up and running.

     

    You'll need to get a driver from your SATA controller manufacturer that can be installed during the setup process (or from you motherboard manufacturer if the SATA controller is embedded in the board). One with only a setup.exe and accompanying files will be next to useless. You'll need a driver set that has an oemsetup.inf file included. You want to obtain a Windows 2003 Server version of the driver if possible. If not, you may have success with a Windows XP driver.

     

    Once you have the driver disk, see the post from Ken Warren (the eigth post down) in this thread http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1505203&SiteID=50 for an explanation as to when to use this driver disk.

     

     

    Monday, April 23, 2007 12:01 PM
  • Is the 100 gig drive connected and hot as well as the 750 when you try to install?

     

    I purchased 2 250 gig drives to use in my test box and when i tried to install with both drives connected and hot I received the same error. I was not able to install it with two hot drives connected. However when i disconnected the second drive it installed with no problems at all. After install completed i just shutdown and reconnected the drive booted back up and added the second drive. No idea why it had a problem seeing individual drives with more than 1 connected.

    Monday, April 30, 2007 3:20 AM
  • I had the same error when installing on 2 320GB IDE drives. Since these were brand new drives, there were no partitions on them. I used the manufacturer utilities (WD in this case) to create partitions on both drives, and the install saw the drives. The partitions were erased during the install, so what you pick for size is of no consequence.

     

    Hope that helps. 

    Monday, April 30, 2007 3:34 AM