locked
Shadow Copy Error On Startup RRS feed

  • Question

  • Not many details on this one - Shadow Copy just stops and gives an error pretty much every time I reboot.

    Is this a common issue?

    Any suggested fixes?

    Thanks.
    Wednesday, March 12, 2008 5:08 PM

All replies

  • Where do you see this error, on your home computer or through the connector? 

     

    Wednesday, March 12, 2008 11:58 PM
    Moderator
  • I see this on my home server directly when I start it up or restart it.
    Thursday, March 13, 2008 2:44 AM
  • Bump.

    Anyone have any idea what the issue might be.  I'm concerned that this error is resulting in the loss of the shadow copy ability within WHS.

    Are there any ways to check and see if Shadow Copy is still actually working?
    Friday, March 21, 2008 5:08 PM
  • You might want to read this :

     

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=3020613&SiteID=50

     

    not sure if its what you are experiencing or not?


    Andrew

     

    Friday, March 21, 2008 5:10 PM
    Moderator
  • Thanks for the link - that's good to know, though I think I read about that previously.

    My error is on startup - everytime WHS loads.

    I haven't tried to actually use Shadow Copy yet.  I just assume it works and is ready in case something happens.  Though this appears not to be the case now.

    So maybe it's related - maybe not.
    Friday, March 21, 2008 5:24 PM
  •  

    Try running "chkdsk /f c:" on your home server.
    Friday, March 21, 2008 10:16 PM
    Moderator
  • Please check out the eventlogs on your WHS. Log on to your WHS using RDP or KVM, then do Start, Run, type eventvwr.msc and hit Enter.

     

    You can check if the service is running in a number of ways:

     

    1. The easiest way which will also show if it's functional: On your WHS open explorer window, right click D partition, properties, then Shadow copies, Select D drive. This will tell of there are any shadow copies.

    2. Another option is: On your WHS do Start, Run, type services.msc and hit Enter. Look for the status of Volume Shadow Copy. You can also double click and then Start the service. Wait for a few minutes to see if it fails. If it fails please check out the eventlogs

     

    Hopefully  this will give you a clue what's happening. Otherwise it's just guessing.

     

    Sunday, March 23, 2008 1:18 PM
    Moderator
  • I ran chkdsk and no errors came up.


    Looked at both the Event Logs and Services.

    Event logs showed a failure of WMSPerf.dll, there was also a failure of .Net 2.0 related to ACT!, a contact management software - however the dll failed on one startup and the .Net failed on the second.

    The dll failure and warnings were much more common in the log though, and Act has been running just fine - so I'm not sure the .Net issue is a problem.


    When I looked at the Services, I found Volume Shadow Copy running, but set on manual startup.  I switched this to Automatic.

    Odd thing is during the last two startups, I didn't receive the volume shadow copy error.  So I'm not sure that it's solved, but it isn't failing at the moment.

    Any ideas on the WMSPerf.dll failure?



    Wednesday, March 26, 2008 4:27 PM
  • I don't think the WMSperf.dll failurue is relevant here.

     

    WHS backup however may run into problems if something is wrong with the NET 2.0 Framework. You could try repairing from Control Panel, Add or Remove Programs, or reinstall.

     

    VSS should normally be set to manual, no need to have it running all the time. However if the problem was only in starting the VSS then setting to automatic may be a work-around

    Thursday, March 27, 2008 12:14 AM
    Moderator
  • I'm having this same issue and shadow copies don't work for me.  I just thought it was a result of the shadow copies not working, invalid handle issue.  I just say ok to the error and move one.  There are no chkdsk problems and my network health is green..

     

    Thursday, March 27, 2008 1:30 AM