locked
Login Problem : Insufficient Permissions RRS feed

  • Question

  • hello

    i'm the admin of my crm

    When i try to login to crm with an existing username and password of another user

    the following error ocurred

    Insufficient Permissions

    the logged-on user does not have the appropriate security permissions to view these records or perform the the specific action.

     

    any help ????

    Thursday, September 16, 2010 3:13 PM

Answers

All replies

  • hello

    i'm the admin of my crm

    When i try to login to crm with an existing username and password of another user

    the following error ocurred

    Insufficient Permissions

    the logged-on user does not have the appropriate security permissions to view these records or perform the the specific action.

     

    any help ????

    • Merged by DavidJennawayMVP, Moderator Thursday, October 21, 2010 2:41 PM Duplicate thread. Please only post the question in one forum
    Thursday, September 16, 2010 3:12 PM
  • Check the security group of that user. Check whether he has access to the entity which is being opened. Check the level of access. i.e. user, bu, child bu or organisation.

    Regards

    Faisal

    Thursday, September 16, 2010 3:21 PM
  • Check for Event viewer for more details error.

    Try to enable trace using CrmDiagTool4 http://dynamicsexchange.com/Blogs/Archives.aspx?month=11

    and check error log

    Let's know what error details you got


    Mahain : http://mahenderpal.wordpress.com
    Thursday, September 16, 2010 3:42 PM
    Moderator
  • This got me in the beginning as well. Make sure that the user you are trying to log in as has the Write privledge on the 'System User' entity on the Business Management tab to some degree (Individual, BU, BU and bleow, organization level). If they don't have any permissions to write to that entity then they will not be able to log into CRM.
    Thursday, September 16, 2010 4:01 PM
  • what security role this user have got ?
    MayankP My Blog My twitter
    Thursday, September 16, 2010 6:32 PM
  • Try removing the existing roles and re-add them as sometime crm security does not propagate. Also make sure that appropriate roles are set i.e. not  related to system.

     


    Hope this helps. Amar
    Thursday, September 16, 2010 7:56 PM
  • thanks Sleahy for your efforts

    but unfortunately it didn't work

     

    the surprise now is that i have assigned the same security role to another user and i can login with it successfully !!!!

     

    is there something wrong with the user creation itself ??

    Thursday, September 16, 2010 11:41 PM
  • I've run into an issue when setting a new Security Role when the role didn't have Write permission on User Settings.  Take a look at a stock Role like CSR to compare.
    Friday, September 17, 2010 2:19 AM
  • Hi Mostafa,

    I would suggest you use the CRM DiagTool to capture the missing permission/privilege GUID.

    then use SQL to query to query privilegebase table to see which one is missing. (You can refer to the name column)

     

    regards,

    Toong Yang


    http://eastoceantechnical.blogspot.com/
    Friday, September 17, 2010 6:01 AM
  • Hi,

    It seems that you have created a new Security role rather than Copy Existing "System Administrator" Role.

    Always copy an existing role and do the changes like add / remove roles.

    Go to CRM -> Setings -> Administration -> Security Roles -> Select "System Administrator" Role -> More Actions -> Copy Role -> Specify new Role Name

    Hope this helps.


    Thanks, Ranjitsingh R | http://mscrm-developer.blogspot.com/ | MS CRM Consultant
    • Proposed as answer by Ranjitsingh R Friday, September 17, 2010 1:10 PM
    Friday, September 17, 2010 1:10 PM
  • I don't think that the problem is in the security role because when any other security role is assigned to this user the same error occurs
    Friday, September 17, 2010 4:50 PM
  • when i assign anothe security role to this user the same error occurs
    Friday, September 17, 2010 5:12 PM
  • thanks alot for u guys problem finally solved itself !!!!!

     

    but i have another issue:

    when the user try to access the knowledgebase the same error occurs

     

    how ot allow the user to access the knowledge base using security role ???

     

    thanks in advance

    Friday, September 17, 2010 7:58 PM
  • thanks alot for u guys problem finally solved itself !!!!!

     

    but i have another issue:

    when the user try to access the knowledgebase the same error occurs

     

    how ot allow the user to access the knowledge base using security role ???

     

    thanks in advance

    Friday, September 17, 2010 7:58 PM
  • You will need to modify the assigned role and add knowledgebase read access
    Hope this helps. Amar
    Friday, September 17, 2010 8:03 PM
  • that's the point i don't know in which tab can i do this ????

    Friday, September 17, 2010 8:07 PM
  • You can goto Settings -> Administration -> Users , then click on user for which you are getting problem

    once you open user record , on left hand side , click on Roles , option , then on Center of screen u will see the roles you have assigned to that user , now in this role , by double clicking you can check if the roles has access to Read the records for entities if not then please give them access of Read.

     


    Vilas http://www.mscrm-vilas.blogspot.com
    Friday, September 17, 2010 9:56 PM
  • Any suggestions please ????
    Friday, September 17, 2010 11:04 PM
  • the problem is there is no clear way to allow access to knowledge base in a user defined security role !!!
    Friday, September 17, 2010 11:05 PM