locked
Error While Configuring CRM 2011 E-mail Router RRS feed

  • Question

  • Hello everyone,

    We are attempting to configure the e-mail router for a client with CRM 2011.  We are to the point where we are selecting the "Load Data" button on the "User, Queues, and Forward Mailboxes" tab.  We get an error stating that "the provided uri did not return any service endpoints".  We have double checked all settings and all are correct.  The error in the event log is...

    Exception information:

    Exception type: NotSupportedException

    Exception message: Security settings for this service require Windows Authentication but it is not enabled for the IIS application that hosts this service.

    It appears from researching this error that we need to have "Negotiate" as part of the windows authentication (see below), but we don't know where to do this in IIS 7.

    <windowsAuthentication enabled="false">
       <providers>
          <add value="Negotiate" />
          <add value="NTLM" />
       </providers>
    </windowsAuthentication>

    Has anyone run into this problem with CRM 2011?  Does this seem to be the way to correct the error?  Does anyone know how to configure this in IIS 7?

    Any help would be greatly appreciated.

    Thank you.

    Thursday, May 5, 2011 10:57 PM

Answers

  • It seems to be in there for me, although you need to right click on Windows auth and select 'Providers'. e.g. this, then this, then add the negotiate provider from the drop down. I'm running Windows Server 2008 R2 so it may be different in the original release.

    If you still can't find it, you can edit the config file directly - %windir%\system32\inetsrv\config\applicationHost.config (please please please back this file up first!)

    Find the <location path="Microsoft Dynamics CRM"> section. Within that section you will see a <providers> node. You can add in the negotiate value there and then restart IIS. (snippet from my file below)

    <location path="Microsoft Dynamics CRM">
        <system.webServer>
          <defaultDocument>
            <files>
              <clear />
              <add value="default.aspx" />
            </files>
          </defaultDocument>
          <security>
            <authentication>
              <windowsAuthentication enabled="true">
                <providers>
                  <clear />
                  <add value="NTLM" />
                  <add value="Negotiate" />
                </providers>
    

     

     


    Neil - My CRM Blog
    • Marked as answer by DHood Friday, May 6, 2011 4:55 PM
    Friday, May 6, 2011 3:40 PM

All replies

  • Hi DHood,

    Give the answer in this thread a try.

    Neil.


    Neil - My CRM Blog
    Friday, May 6, 2011 3:01 PM
  • Hi Neil,

    I found this thread and it seems like it might work, but I can't figure out how to do it in IIS 7.  The instructions appear to be for IIS 6?

    Do you have any idea how to do this in IIS 7?

    Friday, May 6, 2011 3:22 PM
  • It seems to be in there for me, although you need to right click on Windows auth and select 'Providers'. e.g. this, then this, then add the negotiate provider from the drop down. I'm running Windows Server 2008 R2 so it may be different in the original release.

    If you still can't find it, you can edit the config file directly - %windir%\system32\inetsrv\config\applicationHost.config (please please please back this file up first!)

    Find the <location path="Microsoft Dynamics CRM"> section. Within that section you will see a <providers> node. You can add in the negotiate value there and then restart IIS. (snippet from my file below)

    <location path="Microsoft Dynamics CRM">
        <system.webServer>
          <defaultDocument>
            <files>
              <clear />
              <add value="default.aspx" />
            </files>
          </defaultDocument>
          <security>
            <authentication>
              <windowsAuthentication enabled="true">
                <providers>
                  <clear />
                  <add value="NTLM" />
                  <add value="Negotiate" />
                </providers>
    

     

     


    Neil - My CRM Blog
    • Marked as answer by DHood Friday, May 6, 2011 4:55 PM
    Friday, May 6, 2011 3:40 PM
  • Interesting, the "Providers..." option is not there when I right-click on Windows Authentication.

    I was able to edit the config file directly (after backing it up of course), and the "Load Data" button now works.

    Thanks very much for your help.  I have no idea why the option isn't there when I right-click.

    Friday, May 6, 2011 4:55 PM