WGA and Silicon Image RAID drivers. RRS feed

  • Question

  • I have 4 genuine, non-counterfeited copies of Windows XP on 4 seperated, networked pc's. I run automatic Microsoft updating on all the machines. One of the machines has 2 identical SATA drives running as JBOD RAID, it downloaded the WGA tool and went Blue Screen Of Death with an stop message referring to si3112r.sys (this is the file that is needed at Windows XP install, press F6 etc) I rang Microsoft support and they, after I read out the relevant serial number to them, believed that my copy of Windows XP Home edition was genuine. I followed the Micro Tech's advice and tried a clean install (repartition, format, reinstall) with the latest Silicon Image drivers (looked the same as the old ones to me) for my Mainboard  (Gigabyte GA7N400 rev. 2) and ran the Atomatic Updater again. The updates all installed just fine until it tried to install the WGA tool again. This resulted in the same Blue Screen and stop message. After a lot of toing and froing the techs suddenly declared that they had a driver/WGA problem, although they at first tried to convince me that my RAID drives were bust! Obviously not as they load up and run Windows XP just fine until I try to instll the WGA tool. I now have an Operating System that I now have to turn off automatic updating on to prevent the Blue Screen and stop message. The Micro Techs have left my case open.....
    I am horrified at the total money grabbing philosophy behind WGA. The tool is obviously totally untested and I believe ZDNet when they state that MS are using us, the poor punter, as unpaid software testers, we must be mugs!

    System details follow:-

    Item Value 
    OS Name Microsoft Windows XP Home Edition 
    Version 5.1.2600 Service Pack 2 Build 2600 
    OS Manufacturer Microsoft Corporation 
    System Name ********* 
    System Manufacturer NVIDIA 
    System Model AWRDACPI 
    System Type X86-based PC 
    Processor x86 Family 6 Model 10 Stepping 0 AuthenticAMD ~2191 Mhz 
    BIOS Version/Date Award Software International, Inc. FH, 23/12/2004 
    SMBIOS Version 2.3 
    Windows Directory D:\WINDOWS 
    System Directory D:\WINDOWS\system32 
    Boot Device \Device\HarddiskVolume2 
    Locale United Kingdom 
    Hardware Abstraction Layer Version = "5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)" 
    User Name ******\**

    Time Zone GMT Standard Time 
    Total Physical Memory 1,024.00 MB 
    Available Physical Memory 818.05 MB 
    Total Virtual Memory 2.00 GB 
    Available Virtual Memory 1.96 GB 
    Page File Space 2.40 GB 
    Page File D:\pagefile.sys 


    Resource Device 
    I/O Port 0x00000000-0x00000CF7 PCI bus 
    I/O Port 0x00000000-0x00000CF7 Direct memory access controller 
    I/O Port 0x000003C0-0x000003DF NVIDIA nForce2 AGP Host to PCI Bridge 
    I/O Port 0x000003C0-0x000003DF VgaSave 
    Memory Address 0xD8000000-0xDFFFFFFF NVIDIA nForce2 AGP Host to PCI Bridge 
    Memory Address 0xD8000000-0xDFFFFFFF Video Controller (VGA Compatible) 
    IRQ 22 Standard OpenHCD USB Host Controller 
    IRQ 22 Standard Enhanced PCI to USB Host Controller 
    I/O Port 0x00009000-0x0000BFFF PCI standard PCI-to-PCI bridge 
    I/O Port 0x00009000-0x0000BFFF Creative AudioPCI (ES1371,ES1373) (WDM) 
    IRQ 9 Microsoft ACPI-Compliant System 
    IRQ 9 NVIDIA nForce PCI System Management 
    IRQ 16 Realtek RTL8169/8110 Family Gigabit Ethernet NIC 
    IRQ 16 Texas Instruments OHCI Compliant IEEE 1394 Host Controller 
    Memory Address 0xE0000000-0xE2FFFFFF NVIDIA nForce2 AGP Host to PCI Bridge 
    Memory Address 0xE0000000-0xE2FFFFFF Video Controller (VGA Compatible) 
    Memory Address 0xA0000-0xBFFFF PCI bus 
    Memory Address 0xA0000-0xBFFFF NVIDIA nForce2 AGP Host to PCI Bridge 
    Memory Address 0xA0000-0xBFFFF VgaSave 
    I/O Port 0x000003B0-0x000003BB NVIDIA nForce2 AGP Host to PCI Bridge 
    I/O Port 0x000003B0-0x000003BB VgaSave 


    Resource Device Status 
    Channel 4 Direct memory access controller OK 
    Channel 2 Standard floppy disk controller OK 

    [Forced Hardware]

    Device PNP Device ID 


    Resource Device Status 
    0x00001000-0x0000107F Motherboard resources OK 
    0x00001080-0x000010FF Motherboard resources OK 
    0x00001400-0x0000147F Motherboard resources OK 
    0x00001480-0x000014FF Motherboard resources OK 
    0x00001800-0x0000187F Motherboard resources OK 
    0x00001880-0x000018FF Motherboard resources OK 
    0x00001C00-0x00001C3F Motherboard resources OK 
    0x00002000-0x0000203F Motherboard resources OK 
    0x00000000-0x00000CF7 PCI bus OK 
    0x00000000-0x00000CF7 Direct memory access controller OK 
    0x00000D00-0x0000FFFF PCI bus OK 
    0x00000A79-0x00000A79 ISAPNP Read Data Port OK 
    0x00000279-0x00000279 ISAPNP Read Data Port OK 
    0x00000274-0x00000277 ISAPNP Read Data Port OK 
    0x0000CC00-0x0000CC1F NVIDIA nForce PCI System Management OK 
    0x00009000-0x0000BFFF PCI standard PCI-to-PCI bridge OK 
    0x00009000-0x0000BFFF Creative AudioPCI (ES1371,ES1373) (WDM) OK 
    0x00009400-0x000094FF Realtek RTL8169/8110 Family Gigabit Ethernet NIC OK 
    0x0000AC00-0x0000AC07 Silicon Image SiI 3512 SATARaid Controller OK 
    0x0000B000-0x0000B003 Silicon Image SiI 3512 SATARaid Controller OK 
    0x0000B400-0x0000B407 Silicon Image SiI 3512 SATARaid Controller OK 
    0x0000B800-0x0000B803 Silicon Image SiI 3512 SATARaid Controller OK 
    0x0000BC00-0x0000BC0F Silicon Image SiI 3512 SATARaid Controller OK 
    0x0000F000-0x0000F00F NVIDIA NForce 2(tm) SPP/IGP ATA Controller OK 
    0x000001F0-0x000001F7 NVIDIA NForce 2(tm) SPP/IGP ATA Controller OK 
    0x000003F6-0x000003F6 NVIDIA NForce 2(tm) SPP/IGP ATA Controller OK 
    0x00000170-0x00000177 NVIDIA NForce 2(tm) SPP/IGP ATA Controller OK 
    0x00000376-0x00000376 NVIDIA NForce 2(tm) SPP/IGP ATA Controller OK 
    0x000003B0-0x000003BB NVIDIA nForce2 AGP Host to PCI Bridge OK 
    0x000003B0-0x000003BB VgaSave OK 
    0x000003C0-0x000003DF NVIDIA nForce2 AGP Host to PCI Bridge OK 
    0x000003C0-0x000003DF VgaSave OK 
    0x00000010-0x0000001F Motherboard resources OK 
    0x00000022-0x0000003F Motherboard resources OK 
    0x00000044-0x0000005F Motherboard resources OK 
    0x00000062-0x00000063 Motherboard resources OK 
    0x00000065-0x0000006F Motherboard resources OK 
    0x00000074-0x0000007F Motherboard resources OK 
    0x00000091-0x00000093 Motherboard resources OK 
    0x000000A2-0x000000BF Motherboard resources OK 
    0x000000E0-0x000000EF Motherboard resources OK 
    0x000004D0-0x000004D1 Motherboard resources OK 
    0x00000800-0x00000805 Motherboard resources OK 
    0x00000290-0x0000029F Motherboard resources OK 
    0x00000020-0x00000021 Programmable interrupt controller OK 
    0x000000A0-0x000000A1 Programmable interrupt controller OK 
    0x00000080-0x00000090 Direct memory access controller OK 
    0x00000094-0x0000009F Direct memory access controller OK 
    0x000000C0-0x000000DF Direct memory access controller OK 
    0x00000040-0x00000043 System timer OK 
    0x00000070-0x00000073 System CMOS/real time clock OK 
    0x00000061-0x00000061 System speaker OK 
    0x000000F0-0x000000FF Numeric data processor OK 
    0x000003F0-0x000003F5 Standard floppy disk controller OK 
    0x000003F7-0x000003F7 Standard floppy disk controller OK 
    0x00000060-0x00000060 Standard 101/102-Key or Microsoft Natural PS/2 Keyboard OK 
    0x00000064-0x00000064 Standard 101/102-Key or Microsoft Natural PS/2 Keyboard OK 

    Monday, July 3, 2006 1:41 AM


All replies

  • Berserker,

    Just did a check of the Silicon Image support pages for the 3512 chipset---NO mention of JBOD support, only RAID 0, 1 and 10.

    Monday, July 3, 2006 3:56 AM
  • Correct me if I'm wrong but I always thought JBOD was RAID 0, if not forgive my ignorance - the setup is RAID 0
    Monday, July 3, 2006 10:03 AM
  • Beserker,

    Someone with the same problem, try my fix and let me know:


    Monday, July 3, 2006 3:43 PM
  • Cheers Dan, I will try this t'mrw pm (GMT). I presume this is a Windows executable as opposed to the *.sys file loaded at Windows setup (press F6 etc.)?
    As an aside I now know the difference between JBOD and RAID 0; the Internet is wonderful
    Monday, July 3, 2006 8:58 PM
  • Beserker,

    Yes, it is an .exe file from Windows Update.

    Good Luck and post back.

    Tuesday, July 4, 2006 2:07 AM
  • Dan,

    I go to the drivers update page and add the driver to the download basket and try and download them. They don't. Instead there is an error number (0x800A138F) and an option to send the error number to Microsoft.

    This is starting to worry me as the Technical Support people at Microsoft conference called me to one of the Senior Complaints people here in the UK. He made it very clear to me that if you have'nt got this tool installed, you are eventually going to have a disabled copy of Windows XP. I don't see why I need to buy a new mainboard because Microsoft can't sort out a fault in their software.


    Thursday, July 6, 2006 9:43 AM
  • I can run the coa program on the relevant pc (I do not have WGA installed on it!) and it returns:-

    Diagnostic Report (1.5.0540.0):
    WGA Data-->
    Genuine Validation Status: Genuine
    Windows Product Key: *****-*****-QQHXP-HGBJF-C8J39
    Windows Product Key Hash: Uw/C+CoAi2oPqgPhTubz86ymw8w=
    Windows Product ID: 55285-015-1474273-21692
    Windows Product ID Type: 5
    Windows License Type: Retail
    Windows OS version: 5.1.2600.2.00010300.2.0.hom
    Download Center code: 58MDQR5
    ID: 38800015-f6de-4ca4-b078-11df8180ec41
    Is Admin: Yes
    AutoDial: No
    Registry: 0x0
    WGA Version: Failed to retireve file version. - 0x80070006
    Signature Type: Unknown.
    Validation Diagnostic:

    System Scan Data-->
    Scan: Complete
    Cryptography: Complete

    Notifications Data-->
    Cached Result: N/A
    Cache refresh Interval: N/A
    Extended notification delay(non-genuine): N/A
    Extended notification delay(un-activated): N/A
    All disabled: N/A
    Reminder reduced: N/A
    File Exists: Yes
    Version: 1.5.532.2
    Signatue Type: Microsoft

    OGA Data-->
    Office Status: 109
    Office Diagnostics: B4D0AA8B-467-80070002

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Win32)
    Default Browser: D:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>38800015-f6de-4ca4-b078-11df8180ec41</UGUID><Version>1.5.0540.0</Version><OS>5.1.2600.2.00010300.2.0.hom</OS><PKey>*****-*****-*****-*****-C8J39</PKey><PID>55285-015-1474273-21692</PID><PIDType>5</PIDType><SID>S-1-5-21-515967899-682003330-725345543</SID><SYSTEM><Manufacturer>NVIDIA</Manufacturer><Model>AWRDACPI</Model></SYSTEM><BIOS><Manufacturer>Award Software International, Inc.</Manufacturer><Version>FH</Version><SMBIOSVersion major="2" minor="3"/><Date>20041223000000.000000+000</Date></BIOS><HWID>053C3E9F0184B96F</HWID><UserLCID>0809</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>GMT Standard Time(GMT+00:00)</TimeZone></MachineData>   <Software><Office><Result>109</Result><Products/></Office></Software></GenuineResults> 


    Thursday, July 6, 2006 10:05 AM
  • I'll keep bumping this till one of the miroserfs do something about it.

    Thursday, July 6, 2006 6:03 PM
  • Beserker,

    See this page:  http://www.siliconimage.com/support/supportsearchresults.aspx?pid=63&cid=3&ctid=2&osid=4&

    Since you have written that your disk are arranged in a RAID-0 array, you will need the second driver on the list,

    Friday, July 7, 2006 4:00 AM
  • Dan,
    The Silicon Image drivers at that link do not work, they are for a Silicon Image 2 port SATA RAID PCI card, whereas I have an "on board" Silicon Image SATA RAID chipset. However, I tried using the RAID in JBOD mode, you select this in the Gigabyte, GA7N400, BIOS, using the relevant driver at "Press f6, etc." and the WGA tool works in this set up. However, I now have two 75GB drives instead of one 150GB drive. Sigh, at least the bloody tool works.
    I would like some appreciation for my beta testing WGA and Silicon Image drivers but I doubt if any will be forthcoming.
    Wednesday, July 12, 2006 3:23 PM
  • Beserker,

    Sorry that our "end around" play to get the drivers was stopped for a loss!

    You are correct in that the drivers on the page I linked are for a discreet expansion card and not for an on-board chipset.  I thought they might be worth a shot to try.

    Now that you are validated can you get to WU to get the correct and latest drivers for your RAID?

    Wednesday, July 12, 2006 3:34 PM
  • Lol, no, I have never found that part of Windows Update to be very reliable. I think I will count my blessings Dan.

    Thanks for your help, if my knowledge of RAID was pretty sketchy before I started this journey, it is'nt now!

    Wednesday, July 12, 2006 4:19 PM