locked
Quick Search view in Outlook different to Internet Explorer RRS feed

  • Question

  • Hi

    I have a user that is using CRM 2011 for Outlook.  They open a custom view in the Case entity.  They then use Quick Find to search for a particular case.  The issue that they have is that the results view is not consistant with the customised Quick Find view.  All customisations have been published.

    I have confirmed that the Quick Find view displays as expected when using Internet Explorer.

    It would appear that Outlook is caching the Quick Find view somewhere but I dont know where.  The user has restarted their machine so all caches should be cleared.  This is not the only user that has this issue.

    Thanks


    Marc Collins www.QGate.co.uk

    Friday, April 5, 2013 5:01 PM

Answers

  • Hi,

    There is a little difference in the quick find in the browser and the Outlook. When you search in the browser at the quick find box, the results are independent of the current view which is user selected. Hence, it do a search on all of the data. But in Outlook it is some different. When you search in the Outlook it returns results from the current selected view. Hence, the results are from the current user view. Therefore, it is obvious that the results are different.

    BTW, recently I saw some threads that users said that in recent updates this difference does not exist. I do not tested it yet.


    If the answer helped you, remember to mark it as answer.


    Friday, April 5, 2013 5:36 PM
    Moderator

All replies

  • Hi,

    There is a little difference in the quick find in the browser and the Outlook. When you search in the browser at the quick find box, the results are independent of the current view which is user selected. Hence, it do a search on all of the data. But in Outlook it is some different. When you search in the Outlook it returns results from the current selected view. Hence, the results are from the current user view. Therefore, it is obvious that the results are different.

    BTW, recently I saw some threads that users said that in recent updates this difference does not exist. I do not tested it yet.


    If the answer helped you, remember to mark it as answer.


    Friday, April 5, 2013 5:36 PM
    Moderator
  • This is a feature that has changed in Update Rollup 12. Previously the Outlook client used the currently selected view as the filter and column definition, allowing you to search within a view rather than forcing the single Quick Find view for all searches as the web client does. After UR12 both clients should follow the same logic, based on this KB article 2822860:

    Update Rollup 12 changes quick find search behavior in the Microsoft Dynamics CRM Outlook client

    The problem is that many users actually prefer to have the ability to search from within a view. Inconsistent behavior between different clients is not good, but preferably MS should have done it the other way around and introduce the capability of searching from within the selected view also on the browser client. See this thread on the LinkedIn Dynamics CRM Group for some good discussion on the topic.


    Jukka Niiranen - My blog: Surviving CRM - Follow @jukkan on Twitter

    Sunday, April 7, 2013 10:48 AM
  • Thanks guys.

    I was not aware that there was a difference between IE and Outlook.

    The actual issue is that the view in Outlook does not display the correct columns.  The custom view and Quick find view have around 7 columns (They have been customised to be the same) however in Outlook, only 3 columns are displayed when using Quick Find.  Apart, from applying Update Rollup 12, what other ways can this be fixed?


    Marc Collins www.QGate.co.uk

    Monday, April 8, 2013 8:55 AM
  • Configure the view from Outlook. You could find the view editing and settings in the ribbon of an entity in Outlook.

    If the answer helped you, remember to mark it as answer.
    My Weblog -- My Website -- My Facebook

    Monday, April 8, 2013 9:07 AM
    Moderator