Synchronize and Contribute to WebDAV mapped drive fails, error 0x800700B7 RRS feed

  • Question

  • I'm trying to use SyncToy 2.1 on 32-bit XP Pro SP3 installation to contribute changes from a local folder to a remote folder hosted on a WebDAV drive on an Apache Unix server.

    I am currently using South River Technologies' WebDrive as a local client. I have previously observed the same problem using NetDrive.

    For each of three folder pairs, the local folder has a corresponding folder on each of three separate WebDAV drives (mapped as N: R: and S:). Two of them (R: and S:) work fine, but the third (N:) does not work.

    The folder pair that does not work is the one backing up the My Documents folder. It fails for both Synchronize and Contribute, giving a "red" error for the type of operation "New":

    ::   Error: Cannot write to the destination file. Cannot create a file when that file already exists. (Exception from HRESULT: 0x800700B7) Copying C:\[file on local drive] to N:\[file on remote drive]

    Again, this error message is the same regardless of whether the type of action is set to Synchronize or Contribute.

    The problem is that when I run a Contribute, it re-pushes every file up to the WebDAV drive every time, even when none of the files have changed.

    The files seem to have identical sizes and timestamps between the remote and local drives.

    I wonder about things like namespace conflicts in the path from the My Documents folder on the local side, and about how SyncToy handles Unix file permissions (and things such as handling files beginning with a Tilda "~" character; which is a perfectly legal character in Windows but denotes a System file in Unix).

    I have not been able to determine if the WebDAV shares are hosted all hosted from the same Unix box, or if they are coming from different machines. Also, I don't know how to observe any differences between the server's time and my local XP machine's time, but like I said, the timestamp for each file appears to be the same in Explorer side-by-side between the mapped drive and the local drive.

    I have tried deleting and recreating the folder pair. I have uninstalled and reinstalled SyncToy 2.1. No previous versions of SyncToy have been used. I have tried turning on "check file contents" with no improvement.

    So, why is SyncToy copying files if the same version of the file already exists at the destination?

    Thursday, March 3, 2011 2:30 PM