locked
Form onLoad event not firing RRS feed

  • Question

  • Hi everybody!

     I have a custom entity which has an onload event that was working properly till today....

     My code is only:

    alert("onload!!");

    but it is not firing...

    Any help would be very appreciated!!

    Regards, Carolina

    Thursday, October 21, 2010 9:51 PM

Answers

  • Thanks to all of you!!

    I got it solved , there was an error in an onchange event that caused this mess.

    When I disabled all the scripts of the form except onlad, it started to work....

    Thanks again...

    • Marked as answer by caroboerr Friday, October 22, 2010 12:37 PM
    Friday, October 22, 2010 12:37 PM

All replies

  • Try republishing the form after ensuring that the 'Event is enabled' checkbox is checked.

    Are there any javascript errors on the form when you open an entity instance?


    --pogo (pat)
    Friday, October 22, 2010 4:10 AM
  • Hi Carolina,

    Enable your browser to run scripts. See here: http://support.microsoft.com/gp/howtoscript


    Julio
    Friday, October 22, 2010 5:07 AM
  • is there any page error @ the bottom of the IE window, did you make any changes to the form\attributes?
    Friday, October 22, 2010 5:29 AM
  • Thanks Julio:

    my scripts were already enabled.

    My form was running properly till today, that stopped working.. now I can't fix it....

    I tried to disable the onload event, publish the entity  and enable it again only with an alert but it is not working....

    I think there is an error with the form that has nothing to do with scripts but is disabling script execution...

    Any other idea?

    Thanks a lot! Carolina

    Friday, October 22, 2010 12:13 PM
  • No, no errors are shown @ the bottom of the IE window.
    Friday, October 22, 2010 12:26 PM
  • Thanks to all of you!!

    I got it solved , there was an error in an onchange event that caused this mess.

    When I disabled all the scripts of the form except onlad, it started to work....

    Thanks again...

    • Marked as answer by caroboerr Friday, October 22, 2010 12:37 PM
    Friday, October 22, 2010 12:37 PM