locked
project server 2010: does february CU update sharepoint or project server databases? RRS feed

  • Question

  • Hi,

    I would like to know if February CU (KB2597152) does update the databases of sharepoint and project server. I have read the microsoft related KB regarding this update but there is no information regarding database update. Googling did not return any useful information too.

    Regards,
    George

    Friday, March 30, 2012 8:21 AM

Answers

  • Try following command

    PSCONFIG -cmd upgrade -wait -force -inplace b2b

     

    if this does not work then we need to test whether DBs are upgrading during provisioning or not. To do that try following steps

    1. Take SQL DB backup of 4 Project Databases and restore with another name

    2. Try provisioning another PWA site using restored databases

    If above step works then you may need to delete PWA site ,Remember to uncheck the checkbox (Delete site collection). If you don’t uncheck then /PWA site will be deleted and restoring content DB will be difficult.

    Once PWA instance is deleted re-provision using existing database and same PWA name

    Remember to TEST it and take FULL farm backup and SQL DB backup before trying any above steps


    Hrishi Deshpande – DeltaBahn Senior Consultant
    Blog | < | LinkedIn

    • Marked as answer by geo_d Wednesday, April 4, 2012 10:44 AM
    Saturday, March 31, 2012 2:54 PM

All replies

  • Hi there,

    Yes, after installing CU binaries you have to run SharePoint Configuration wizard.

    Execute following query on any project databases and version number should be 14.0.6117.5002


    Hrushikesh Deshpande – Senior EPM Infrastructure Consultant, www.DeltaBahn.com Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you

    Friday, March 30, 2012 4:13 PM
  • Hi,

    It appears that on my system, the February CU installs correctly and the sharepoint configuration wizard but the farm configuration wizard fails with no error but just an "internet explorer cannot display the webpage" error after an hour of the Processing screen. Is there a script or a tool to update the databases by themselves without the full installation because it seems that the installation is working fine and the only problem is the database updates that keeps failing.

    Regards,

    George

    Saturday, March 31, 2012 5:17 AM
  • After running sharepoint configuration wizard you dont have to go through the wizard you can skip.


    Hrishi Deshpande – DeltaBahn Senior Consultant
    Blog | < | LinkedIn

    Saturday, March 31, 2012 5:20 AM
  • After running sharepoint configuration, it succeeds and when I click finish, the central admin page opens by itself and asks to run the farm configuration wizard. If I do not run it, project server does not work and if I do run it, the problem described in my post above occurs. Here is my problem in details on this post http://social.technet.microsoft.com/Forums/en-US/projserv2010setup/thread/cde3dfa8-5d7c-4693-9be9-3fe7c1a865ba/. You help is much appreciated! Thanks again.
    Saturday, March 31, 2012 5:23 AM
  • Is it possible to use sharepoint's psconfig tool to run the update on project server's databases? Note: sharepoint upgrade has worked fine but the problem is only with project server!
    Saturday, March 31, 2012 7:43 AM
  • Try following command

    PSCONFIG -cmd upgrade -wait -force -inplace b2b

     

    if this does not work then we need to test whether DBs are upgrading during provisioning or not. To do that try following steps

    1. Take SQL DB backup of 4 Project Databases and restore with another name

    2. Try provisioning another PWA site using restored databases

    If above step works then you may need to delete PWA site ,Remember to uncheck the checkbox (Delete site collection). If you don’t uncheck then /PWA site will be deleted and restoring content DB will be difficult.

    Once PWA instance is deleted re-provision using existing database and same PWA name

    Remember to TEST it and take FULL farm backup and SQL DB backup before trying any above steps


    Hrishi Deshpande – DeltaBahn Senior Consultant
    Blog | < | LinkedIn

    • Marked as answer by geo_d Wednesday, April 4, 2012 10:44 AM
    Saturday, March 31, 2012 2:54 PM
  • Thanks Hrishi. The PSCONFIG command you posted solved the issue!
    Wednesday, April 4, 2012 10:44 AM