locked
Question about the unicast/broadcast based on Sora RRS feed

  • Question

  • Hi all,
       When I use iperf to test the sora connection. I set computer-A(TX) with 192.168.0.251, and computer-B(RX) with 192.168.0.252.

     1) when testing broadcast:
    set iperf on computer-A : iperf -c 192.168.0.255 -i 1 -t 1000 -l 1000 -u -b 10m
    set iperf on computer-B : iperf -s -i 1 -u
    Then the connection is successful.

    2) when testing unicast:
    set iperf on computer-A : iperf -c 192.168.0.252 -i 1 -t 1000 -l 1000 -u -b 10m
    set iperf on computer-B : iperf -s -i 1 -u
    Then I find that the RX mac statemachine need to send ACK,but the computer-A couldn't receive the ACK frame successfully.

    So I want to ask that the sora platform support the unicast transmission successfully now?
    if there is something wrong on the unicast structure?

    thanks a lot.

    Monday, February 21, 2011 2:47 AM

Answers

  • First make sure RX in A and B works.

    If both can work, test udp unicast, and check dbgview outputs.


    Sen Xiang (项森)
    • Marked as answer by Albert CAO Thursday, February 24, 2011 1:28 AM
    Wednesday, February 23, 2011 7:41 AM
  • Hi Albert,

    You should also first make sure your IP and ARP setting is correct.

    For example, can you do ping?

    please use arp -a to check if there is any entry for your other peer.

    Thanks,

    - Kun

    • Marked as answer by Albert CAO Thursday, February 24, 2011 1:28 AM
    Wednesday, February 23, 2011 2:20 PM

All replies

  • Could you clarify which is sora peer, which is commercial peer?

    thanks.


    Sen Xiang (项森)
    Wednesday, February 23, 2011 2:06 AM
  • Hello , Sen,

    Both A and B are Sora peer.

    And there BSSID is same .

    thanks.

    Wednesday, February 23, 2011 6:51 AM
  • First make sure RX in A and B works.

    If both can work, test udp unicast, and check dbgview outputs.


    Sen Xiang (项森)
    • Marked as answer by Albert CAO Thursday, February 24, 2011 1:28 AM
    Wednesday, February 23, 2011 7:41 AM
  • Hi Albert,

    You should also first make sure your IP and ARP setting is correct.

    For example, can you do ping?

    please use arp -a to check if there is any entry for your other peer.

    Thanks,

    - Kun

    • Marked as answer by Albert CAO Thursday, February 24, 2011 1:28 AM
    Wednesday, February 23, 2011 2:20 PM
  • Hello, Xiang and Tan,

    Thanks for your help. I have fixed the problem.

    Thursday, February 24, 2011 1:28 AM