locked
AV Software with WHS 2011 Integration RRS feed

  • General discussion

  • Thanks to Cir0 for pointing this out in another thread but I thought it would be worth highlighting this seperately. GData Internet Security for Homeserver is available and integrates with the WHS 2011 Dashboard (even though they call it "Console"). It provides protection to the server and up to 5 clients with central deployment of updates:


    G Data Internet Security - UK site

     

    G Data Internet Security - US site

    As far as I am aware, this is the first time a Company has formally stated that it has an AV product for WHS 2011.


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Thursday, January 5, 2012 9:15 PM

All replies

  • Thanks for the info. This looks very promising.

    I am finding, however, that (unless I'm missing something);

    1 - The US version you link to is not available to US customers (there's no US choice in the country dropdown at checkout).

    2 - The US specific website makes no mention of a WHS version.

    3 - G-Data cannot be bothered to respond to e-mail inquiries about US availibility.

    Saturday, January 7, 2012 2:32 PM
  • That's about it! I too am awaiting clarification from them but to date no response to my EMail. If you look at it in a positive light you might assume that they are correcting the website before responding, or perhaps not!!

     

     


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Saturday, January 7, 2012 2:42 PM
  • I ordered a copy to download last friday night. For some reason I am still not able to download any thing exept a bootable AV CD (G Data BootCD 2012) and Android clients but nothing for WHS and/or Windows clients.  :|

    Site is reporting: "Voor dit producttype kan geen huidige programmaversie worden gedownload." (Dutch) Or: No software download available for this product type.
    I am still waiting for support to react.

    Anyway: On http://www.gdata.nl/ it is called G Data IS voor HomeServer 2012. The productflyer (http://www.gdata.nl/fileadmin/dam_files/Ab_Mai_2010/Produkte/Steckbriefe/Retail/2012/NL/GDRISHS2012_NL_Factsheet_70770.pdf) states the things Phil states like:

    "Naadloze integratie in de Microsoft HomeServer 2011-console": Seamless integration in the WHS 2011 Dashboard/Console
    "Automatische verspreiding van updates in het netwerk": Automatic deployment of updates in the the network

    Well, I hope to report back soon and share my G Data findings with you here.

    Sunday, January 8, 2012 11:12 PM
  • Thanks. I await your findings with interest.

     


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Monday, January 9, 2012 12:05 AM
  • Argh... I got the download link by mail today, the link was not showing on the site because there is on only an English version available which is not showing on the Dutch site. Ehhh... Long live the global internet? Well, at least they helped me out right after the weekend so that is okay.

    I installed and registered the software via a rdp session to the desktop and after that I started the dashboard: NO more Dashboard, tried again, still no Dashboard. The green Windows Home Server 2011 popup shows but then disappears after a few seconds.
    I tried to load the Dashboard from another workstation and the following error popups appeared:

    Error popup 1:

    Error popup 2:

    Till now not much very luck with this product. Even after a reboot I have the same issue.
    I will troubleshoot some more later and inform you.

    For US "daredevils" :) : http://www.mswhs.com/2012/01/g-data-internet-security-for-home-server/ / http://www.gdatasoftware.com/products/anti-Virus-Produkte/shop/123-Private-User/1740-G-Data-Is-For-Homeserver.html

    • Edited by Cir0 Monday, January 9, 2012 2:42 PM
    Monday, January 9, 2012 2:41 PM
  • Thanks for the update and sorry to hear it did not work! If it's truly WHS2011 compatible, you should be installing it from a Client as a .wssx file - there should be no need to RDP into your Server.

    As for the link to the US site, its the same as posted above and there is still no way of specifying a US postal address for credit card verification - it would be OK if I lived in Nepal!

    Try disabling add-ins before you start the Dashboard and see if that helps.

     


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Monday, January 9, 2012 3:21 PM
  • Well... There is no .wssx file present on the .iso supplied. Instructions indicates:

    Installation of the G Data AntiVirus ManagementServer
    Insert the G Data DVD and press the Install button. Then select the G Data ManagementServer component by clicking on the adjoining button.

    Bad luck if you have a headless / "DVDless" setup. :) You really need to connect to the desktop to install this.

    Thanks for the tip on the add-ins, when I select this only the basic add-ins show, I installed much more add-ins which are not showing anymore.

    After disabling them all I still got the same errors.

    The Eventviewers Administrative Events is showing the following errors which all occur at the time I try to connect to the Dashboard locally or remotely:

    (Good old) Event 1000, Application Error:

    Faulting application name: Dashboard.exe, version: 6.1.8800.16389, time stamp: 0x4e1c6db6
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e21213c
    Exception code: 0xe0434352
    Fault offset: 0x000000000000cacd
    Faulting process id: 0xc28
    Faulting application start time: 0x01cccee8531d97ec
    Faulting application path: C:\Program Files\Windows Server\Bin\Dashboard.exe
    Faulting module path: C:\Windows\system32\KERNELBASE.dll
    Report Id: 940b5321-3adb-11e1-a471-14dae9b86124

    Event 1026, .NET Runtime

    Application: dashboard.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.Reflection.TargetInvocationException
    Stack:
       at System.RuntimeType.CreateInstanceImpl(System.Reflection.BindingFlags, System.Reflection.Binder, System.Object[], System.Globalization.CultureInfo, System.Object[])
       at System.Activator.CreateInstanceFromInternal(System.String, System.String, Boolean, System.Reflection.BindingFlags, System.Reflection.Binder, System.Object[], System.Globalization.CultureInfo, System.Object[], System.Security.Policy.Evidence)
       at System.AppDomain.CreateInstanceFrom(System.String, System.String, Boolean, System.Reflection.BindingFlags, System.Reflection.Binder, System.Object[], System.Globalization.CultureInfo, System.Object[])
       at System.AppDomain.CreateInstanceFromAndUnwrap(System.String, System.String, Boolean, System.Reflection.BindingFlags, System.Reflection.Binder, System.Object[], System.Globalization.CultureInfo, System.Object[])
       at Microsoft.WindowsServerSolutions.Administration.Extensibility.Tracking.TypeInfo.ShouldTypeBeLoaded(System.AppDomain, System.String, System.Converter`2<System.Type,Boolean>)
       at Microsoft.WindowsServerSolutions.Administration.Extensibility.Loading.PluginFileDiscoverer.CreatePluginInfo(System.IO.FileInfo, System.Xml.XmlNode)
       at Microsoft.WindowsServerSolutions.Administration.Extensibility.Loading.PluginFileDiscoverer.GetPluginInfosCore()
       at Microsoft.WindowsServerSolutions.Administration.Extensibility.Loading.PluginDiscoverer.GetPluginInfos()
       at Microsoft.WindowsServerSolutions.Administration.Extensibility.PluginManager.LoadPlugins[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](Microsoft.WindowsServerSolutions.Administration.Extensibility.Loading.PluginDiscoverer, Microsoft.WindowsServerSolutions.Administration.Extensibility.Loading.IPluginInstantiator, Boolean)
       at Microsoft.WindowsServerSolutions.Administration.Extensibility.PluginManager.LoadPlugins[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](Microsoft.WindowsServerSolutions.Administration.Extensibility.Loading.PluginDiscoverer, Microsoft.WindowsServerSolutions.Administration.Extensibility.Loading.IPluginInstantiator)
       at Microsoft.WindowsServerSolutions.Administration.Extensibility.PluginManager.LoadPlugins[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.String, System.String, System.Converter`2<System.Type,Boolean>, Boolean)
       at Microsoft.WindowsServerSolutions.Dashboard.AddinTabs.AddinPrimaryTab.CreateContent()
       at Microsoft.WindowsServerSolutions.Dashboard.AddinTabs.PrimaryTab.get_Content()
       at Microsoft.WindowsServerSolutions.Dashboard.Forms.Content.TabControlFactory.GetPages(Microsoft.WindowsServerSolutions.Administration.ObjectModel.Internal.IContentNode, Microsoft.WindowsServerSolutions.Dashboard.Forms.ComponentServices.NestedServiceContainer ByRef)
       at Microsoft.WindowsServerSolutions.Dashboard.Forms.Content.TabControlFactory.CreateTopLevelTab(Microsoft.WindowsServerSolutions.Controls.Subtab.SubtabBar, Microsoft.WindowsServerSolutions.Dashboard.Forms.Controls.Tabstrip.TabstripWinformsHost, Microsoft.WindowsServerSolutions.Administration.ObjectModel.Internal.IContentNode, Boolean)
       at Microsoft.WindowsServerSolutions.Dashboard.Forms.Content.TabControlFactory.CreateTabControl(System.Object, System.ComponentModel.IComponent)
       at Microsoft.WindowsServerSolutions.Dashboard.Forms.MainForm.RenderContent(System.Object)
       at Microsoft.WindowsServerSolutions.Dashboard.Program.Main()
    
    I hope G-Data support can do some magic but I am afraid am going to reinstall WHS in the near future :|

    Weird stuff with that CC verification, I paid mine version with iDeal.

    Monday, January 9, 2012 4:35 PM
  • Okay... http://social.microsoft.com/Forums/is/whs2011/thread/37570f98-3b08-447a-939b-4b10eab2959a brought my dashboard back.

    I renamed C:\Program Files\Windows Server\Bin\Addins\Primary\GDataAdminHomeServerAddin.addin to GDataAdminHomeServerAddin.addinx and the Dashboard is working locally and remotely again.

    Also the previous mentioned errors do not show up in the eventlog anymore when launching the Dashboard. This makes it pretty obvious the G-Data software is causing this issue.

    Other topics mention upgrading .net 4.0 when the Dashboard is not loading, I might try that also.

     

    Monday, January 9, 2012 5:07 PM
  • I am having the same issue.

    I found the G-Data Administrator program under the Program files folder and ran that to access the actual AV program.

    I am also having trouble getting the clients to the server.

    Cir0, have you had any more luck with the Dashboard?

     

    I contacted G-Data support and have sent in some screen shots.

    Wednesday, January 11, 2012 10:54 PM
  • I contacted G-Data support and have sent in some screen shots.


    Still no luck here, also I am having an issue when trying to add another client than the homeserver itself.

    First try fails, second try the software indicates it is allready installed, when I then check the status it states no software is installed. Nice circle!

     

    I did send a reminder to helpdesk yesterday, still no reply :( This kinda sucks...


    • Edited by Cir0 Friday, January 13, 2012 6:01 PM
    Thursday, January 12, 2012 5:56 PM
  • G-Data set me  a zip file of DLLs to replace the Administrator ones.

    This didn't fix the Dashboard problem though.

    At this stage I am pushing for a refund as the program doesn't work.

    I haven't been able to push out client installs and when I install them manually they don't ever connect back to the server for updates.

     

    Friday, January 13, 2012 9:44 PM
  • Well, still no awnser from the G-Data support, I am willing to troubleshoot more with them but it seems they do not care.
    After one week my expierence with G-Data is not good at all (till now).

    Anybody out there who is using G-Data on their Homeserver with more "luck"?

    Saturday, January 14, 2012 1:10 PM
  • Still no response from TeamUSA at G Data to my questions!!
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Saturday, January 14, 2012 1:20 PM
  • Another week! I just mailed support for a status update. Maybe I will get lucky and at least het a reply from G Data support.

    EDIT: I got a reply suggestion replacing some files which not solved the issue

    • Edited by Cir0 Monday, January 16, 2012 3:27 PM
    Monday, January 16, 2012 11:41 AM
  • Today I got a reply from G-Data support.

    They are suggesting an earlier reply of them must have bounced beacuse of the attached.zip. Anyway, I got the files you mentioned for Admin folder and like you I still got the same errors when I try to open the Dashboard. :|

    Also they are suggesting that
    - a (other) third-party add-in is causing this error. Could that be the cause?
    - you can use the G Data Administrator directly to manage the server / clients

    I asked for a fix deadline on this issue if any fix is to be expected and that I am not only very unhappy the seamless integration is nowhere to be found when using their workaround but the fact their add-in is crashing my dashboard is really not acceptable.

    Monday, January 16, 2012 3:26 PM
  • I called G-Data and was told that a U.S. version would be available in February 2012. In the meantime, I am using AVAST 4.48 WHS Edition. I may stay with AVAST but want to try G-Data's WHS 2011 when it becomes available.

    For whatever it is worth, I installed AVAST 4.48 WHS Edition via Remote Desktop. There were two installation packages: .exe and .msi

    If anyone chooses to install AVAST 4.48 WHS Edition via Remote Desktop, make sure you follow AVAST's instructions about which installation package to choose for a Remote Desktop installation.

     

    • Edited by Junior1929 Tuesday, January 17, 2012 12:43 PM
    Tuesday, January 17, 2012 12:12 PM
  • At this point, I don't think anyone would look beyond this fiasco.

    Saying there will be a US version doesn't make sence since the

    microsoft codecs are the same accross the board.

     

    Gdata simply did not properly test or beta the product before release.


    Tuesday, January 17, 2012 1:36 PM
  • New day, new G Data mail:

    Support asked me if I reinstalled the .net framework. Since this is not a requirement on their site and info leaflet I asked them that if there exists a .net depency they should state it on there site.
    I asked also if they can tell wat version/service pack is needed of .net before i start any reinstallation.

    Also they inquired if I allreayd reinstalled G Data and if any other add ins are installed... :|

    The story continues...

    Tuesday, January 17, 2012 8:22 PM
  • I have to say that i'm also experiencing exactly the same issues, I haven't yet logged a call with G Data support but from reading the above i'm not entirely sure if this will be much help or not.

    I'm assuming that you haven't had any updates since last week?

    Tuesday, January 24, 2012 12:53 PM
  • Offcourse it is always a good idea to raise a call, without a call G Data wl not be able to help you.

    I did some more troubleshooting with G data support, the last mail is dated 18th of january in which G Data suggests „AWIECO DriveInfo“ in combination with G Data is the cause of the Dashboard error.

    In short: I still have the same issues: no working dashboard (even when DriveInfo is not installed) and it is not able to add a a/v client.

    Tuesday, January 24, 2012 8:35 PM
  • Well it seem that a user found a way to get the AV clients to install. You have to enable the administrtive account on the Windows desktop with the same password as the administrative account on the WHS2011. then client install will work!

     

    Wednesday, January 25, 2012 10:15 AM
  • Well it seem that a user found a way to get the AV clients to install. You have to enable the administrtive account on the Windows desktop with the same password as the administrative account on the WHS2011. then client install will work!

     


    I created a simular account on the desktop as on the WHS.

    Remote installation keeps failing indicating the software is allready installed even after a deinstallation:

    Client installation indicates it has finished succefull but there is no client to be found:

     

    ... to be continued

    Wednesday, January 25, 2012 10:55 PM
  • ... back :)

    So, still no luck for me. :|

    Wednesday, January 25, 2012 10:56 PM
  • On Wed, 25 Jan 2012 22:56:27 +0000, Cir0 wrote:

    So, still no luck for me. :|

    Given that we're talking about an A/V solution here, I'd have given up long
    ago. If the app in question is this difficult to install I'd never trust it
    to protect anything.

    Personally I use nothing on my WHS2011 server as it never is used to access
    the Internet directly in the first place (that's what clients are for, not
    servers), my wife and I practice "safe computing", and I simply run
    Microsoft's Security Essentials on our client computers.

    Oh, and I happen to make my living doing high-end enterprise-wide security
    consulting for large organizations.


    Paul Adare
    MVP - Forefront Identity Manager
    http://www.identit.ca
    I smell a wumpus.

    Wednesday, January 25, 2012 11:13 PM
  • Paul's logic is pretty much mine. I use Avast on my clients, and nothing on my server, for the same reasons.
    Paul adare wrote:

    I smell a wumpus.

    Hunt the wumpus!
    I'm not on the WHS team, I just post a lot. :)
    Thursday, January 26, 2012 1:09 AM
  • An interesting experience from a user who appears to have it working:

    HERE
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Friday, January 27, 2012 6:04 PM
  • I was able to add a client (W7 x64) when I disabled the firewall during the client installation and had a admin on client and server with the same credentials.

    Now I am still waiting for a dashboard fix.

    Tuesday, January 31, 2012 12:08 AM
  • G-Data set me  a zip file of DLLs to replace the Administrator ones.

    This didn't fix the Dashboard problem though.

    At this stage I am pushing for a refund as the program doesn't work.

    I haven't been able to push out client installs and when I install them manually they don't ever connect back to the server for updates.

     

    I should update that I went for the refund.

    They never got the Dashboard working.

    I installed the clients manually but the uninstall didn't work. Uninstall ran but didn't remove the files or reg entries. I had to clean out the registry of a ton of entries on 4 clients. NOT IMPRESSED!

    Thursday, February 9, 2012 1:03 AM
  • For what its worth, I was helping a friend out with getting G-Data installed on his homeserver, and it was a major pain in the butt!  He was having the same trouble with the inop dashboard.  We did get his working eventually.  We found that the current version of the addin MyMovies and the StableBits DE addin do not work with G-Data.  The problems also seem to be related to Microsoft SQL Server, which both Gdata and MyMovies use.  We uninstalled MyMovies and StableBits DE and all traces of SQL Server.  Then we installed Microsoft SQL Express 2008, and then Gdata.  At this point, GData integrated into the dashboard and is functional. 

    Then he installed an older version of MyMovies (i forget which version) and that works ok.  The current MyMovies version caused a crash again, so he stayed with the old version.  StableBits DE wrecked havoc with the dash after Gdata was installed, so he switched to DriveBender DE, and that seems to work ok.

    His Homeserver has been running without flaw for 2 weeks now, and GData is working.  Hopefully this info can help someone else out.

    Tuesday, February 21, 2012 2:54 AM
  • Great post! Thanks for the helpful info.
    Thursday, February 23, 2012 12:49 AM
  • Well here it is April, 3 months since the beginning of this thread, and typically enough time for any worthy software developer to work out the bugs as significant as identified in this thread. I note that G Data still does not offer HomeServer for sale from their USA website. I also note that the USA support contact e-mail does not respond when asked about availability. The UK site still offers G Data HomeServer as a product for sale, as if it works and as if it is supported. Are there any UK customers who have installed it and would they care to comment about the stability and usefulness of G Data's HomeServer product?  I wonder...
    Tuesday, April 10, 2012 10:12 PM
  • Glad I saw this post. I'm not buying that software. Any other alternatives? Any planned?

    Thanks


    James A+, Network+, MCP

    Tuesday, April 17, 2012 3:51 PM
  • For what it's worth, I did actually get a response from G Data regarding availability in the U.S. In an e-mail dated 4/14/2012, I was told that their Internet Security product would be available for download/purchase within about a week.
    Sunday, April 22, 2012 8:29 PM
  • ...and as of Jan 2013 its still not on their website - thanks for the information everyone - I was about to purchase this (got stumped at the Nepal country issue) and came hunting for information. I will not be purchasing this now. 


    Sunday, January 6, 2013 9:01 PM