locked
Remote Desktop Span? RRS feed

  • Question

  • It seems that the default for remote desktop access through the website to my client computers uses the /span option by default, with no way that I've found to change it.

    Has anyone found a way to modify the default behavior to not use /span?

    Wednesday, September 8, 2010 8:56 PM

Answers

  • Please take a look at the Remote Desktop Services (Terminal Services) Team Blog, and in particular this post.

    It's pretty unlikely that Microsoft is going to do anything here (it's rare for users to have more than a single monitor), but that doesn't stop end users from experimenting to see if there's a way to prevent bahavior that they don't want. If you do so, and come up with something that works, get back to us. :)

    Edit: forgot to include this link: TS Gateway Step-by-Step Guide. We're interested in the Core scenario, I think.


    I'm not on the WHS team, I just post a lot. :)
    Friday, September 10, 2010 1:41 PM
    Moderator

All replies

  • It seems that the default for remote desktop access through the website to my client computers uses the /span option by default, with no way that I've found to change it.

    Has anyone found a way to modify the default behavior to not use /span?

    I haven't heard anyone mention that before.  You might want to file a bug report (or product suggestion) on Connect.
    Thursday, September 9, 2010 5:01 AM
    Moderator
  • Hi!

    Please check bug-report https://connect.microsoft.com/WindowsHomeServer/feedback/details/588610/wrong-aspect-ratio-showing-at-loginscreen-when-trying-to-log-in-via-website-to-the-server-with-two-monitors if it's the same for you. I added a screenshot there. If it is the same problem, it probably won't get fixed.

    Friday, September 10, 2010 1:06 PM
  • Please take a look at the Remote Desktop Services (Terminal Services) Team Blog, and in particular this post.

    It's pretty unlikely that Microsoft is going to do anything here (it's rare for users to have more than a single monitor), but that doesn't stop end users from experimenting to see if there's a way to prevent bahavior that they don't want. If you do so, and come up with something that works, get back to us. :)

    Edit: forgot to include this link: TS Gateway Step-by-Step Guide. We're interested in the Core scenario, I think.


    I'm not on the WHS team, I just post a lot. :)
    Friday, September 10, 2010 1:41 PM
    Moderator
  • I have seen this also. For me, it makes it unusable. Unless this can be set somewhere, I'll have to use something else from any machine that has multiple monitors.

    Reading through the links above and other sources, all of the settings for remote desktop are sent by the server. I have determined that the temporary RDP file that the remote client gownloads contains settings for both fullscreen and multimon ('screen mode id:i:2' and 'use multimon:i:1') . This should be something that can be changed, either per request or permanently, but I haven't been able to find where that file is generated from or where the settings actually come from.

    -timotl

    Friday, September 10, 2010 7:06 PM