locked
Crm Dynamics 2011 - Auto Number plug-in for Data Imported records RRS feed

  • General discussion

  • Hi,

    I would like to ask how can i make a plug-in (..which create automatic number when a record has been added to a certain entity) work when a record has been imported using crm dynamics data import. I have observed that when importing records the plug-in does not run, thus leaving autonumber field blank. However when i manually add a record, the plug-in works. Hope you could help me on this.

    Thanks and regards,

    Honey

    Wednesday, July 2, 2014 10:00 AM

All replies

  • Hi Honey,

    It may be that your plugin is only running if the depth is 1 (manually created). If you need it to run on import, this will either need to be removed, or increased to 2.

    This is only one of the possibilities for why it is not running, so if you don't see a depth check out could be something else.

    ~ Atomic Coder

    Wednesday, July 2, 2014 10:38 AM
  • Hi,

    I believe your Plugin is registered on Create of the certain entity. In your Plugin code, do you have a checking for depth? If yes, you need to remove that depth checking since the depth is 2 while importing records.

    Check for something like this in your code:

    context.Depth > 1


    Admin QuikView Solution for CRM 2013

    Wednesday, July 2, 2014 10:40 AM
  • Hi,

    There is a context.Depth code on my plug-in but the value is 1, should i remove the code in order to make the auto-numbering work during data import? Please advise.

    Thanks and regards,

    Honey

    Wednesday, August 13, 2014 6:36 AM