"Unsatisfied Dependency" or Error Getting Device Identifier RRS feed

  • General discussion

  • Hi,
    We are currently investigating two issues with Live Mesh for Mobile that return one or the other of the errors in the title of this thread, but we would like your help.  If you are experiencing either of these issues on your mobile device, and are willing to help us, please collect the Live Mesh logs from your mobile device and send them lmprev@microsoft.com, ATTN: Mobile: Logs Request.

    1. Connect the mobile device to your PC.
    2. Start the Windows Mobile Device Center, and ensure that it shows the mobile device as Connected.
    3. Select File Management, and copy all the logs from \Application Data\Live Mesh\Data\Log on the device to your PC.  
    4. Please zip all those logs and email them to us at lmprev@microsoft.com, ATTN: Mobile: Logs Request.
    Thank you for helping us track down the causes of these problems - and for your patience as we do so.

    <Update>  For those of you encountering issues with SQL CE 3.5, a current workaround that has worked for some is to install SQL CE 3.1.  There is a thread about it hereThanks to Jef K for that.

    Friday, October 31, 2008 8:04 PM

All replies

  • Ben,

    If you are getting the "Unsatisfied dependency" during install of the LiveMesh.cab file, and the install does not complete, will there even be a log in \Application Data\Data\Log?


    Friday, October 31, 2008 8:44 PM
  • Hi Jef,

    Unfortunately, if the install doesn't complete, and there are no logs in the indicated location, we have to ask you to simply be patient with us as we try to determine what the problem is.  We appreciate your desire to help, but in this case there's not much we can ask you to try, and nothing new we can tell you at the moment, I'm afraid.

    We'll update this post whenever new information becomes available.


    Friday, October 31, 2008 9:42 PM
  • Ben,

    No problem!    The installing of SQL CE 3.1 solved the installation problem for me, and I'm now syncing just fine.


    Friday, October 31, 2008 10:02 PM
  • Can you post a URL to a CAB of SQL CE 3.1?  Live Mesh doesn't want to work with 3.5.
    Saturday, November 1, 2008 11:41 AM
  • Saturday, November 1, 2008 1:54 PM
  • Logs sent as requested
    Saturday, November 1, 2008 3:51 PM
  • Since the problem appears to be SQL CE 3.1 and most of us use (or require) 3.5, will LiveMesh be fixed to use 3.5 anytime soon?


    Saturday, November 1, 2008 4:57 PM
  •  Hi, getting the famous "This mobile phone was not added to your mesh." message, sended you the log files.

    Regards, Tom
    Tuesday, November 4, 2008 8:59 AM
  • Problem still persists; if I keep trying to install and keep getting the same error are additional logs to one I already sent useful?
    Wednesday, November 5, 2008 12:06 PM
  • I was trying to log on to the mesh while the device is connected trough my PC. When I disconnected the USB cable and connected over 3G (UMTS) the Mesh connection went fine! I also read that some people have succes while connected for the first time with WiFi, after the first connection also 3G will work.

    Cheers Tom
    Wednesday, November 5, 2008 12:08 PM
  • I am still having and error getting the device identifier, has there been any resolution to this? I have tried over wifi and 3g and neither work.
    Thursday, November 13, 2008 4:33 PM
  • Logs sent - good luck!


    ATT Fuze aka HTC Touch Pro
    Tuesday, December 9, 2008 11:23 PM
  • After the recent update to live mesh, I am still having the error getting a device identifier. I have already submitted log files.
    Thursday, December 11, 2008 7:54 PM
  • Same here - have done an install on a new device (so no previous versions installed) and have the problem. I have sent the logs.

    Friday, December 12, 2008 3:50 PM
  • I have just connected over wifi rather than HSDPA and it worked!
    Friday, December 12, 2008 4:02 PM