locked
Personal Blog Site on my WHS Inaccessible From my Home Network, but Works Externally RRS feed

  • Question

  • For the past several weeks I've been experimenting with a variety of new 802.11 routers to try and find the best on for my home network.  Along the way I discovered that when I attempted to access my personal blog hosted on my HP MediaSmart WHS I received a "Peer Certificate has been Revoked" message in both IE and FireFox.  I even have great difficulty accessing with Windows Live Writer which I use to update and manage the blog.  When setting up my WHS <familyname>homeserver.com domain I selected the Microsoft provided solution with the free SSL from GoDaddy.

    Since all this works just fine externally, are there any suggestions out there on how to reset the certificate for local use of my site?  Is there something in the router setup that is affecting local access and how can I fix it?  Thanks for your time helping me with this perplexing issue.

    Doug
    Saturday, November 15, 2008 3:42 PM

All replies

  • The certificate you received is specific to the <vanityurl>.homeserver.com URL. It doesn't apply if you're accessing your server using e.g. https://hpserver. There are ways to apply a certificate to your server if you own your own domain, but I don't recommend you try to pursue them. Just accept that you'll get an SSL error inside your house.
    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by kariya21Moderator Sunday, November 16, 2008 2:34 PM
    • Unproposed as answer by SonCoder Sunday, November 16, 2008 5:24 PM
    Saturday, November 15, 2008 6:32 PM
    Moderator
  • There's also a way (can't remember the steps off the top of my head) to install your WHS's certificate into the root certificates on your client PC(s) - that way, you won't get a cert error whan accessing the WHS site locally, but you dont' need to muck around with the WHS itself (read:  no way to break your WHS.)
    Search around here - I did find the instructions on this forum; it's just been quite a while (like, the better part of a year) since I used said instructions.
    -Chris
    Saturday, November 15, 2008 6:38 PM
  • My thanks to both of you (Ken & Chris) for responding.  I understand your answers but am a bit perplexed.  I've had the WHS now for over a year and have had the blog up and running for 8 months or so.  During the majority of that time I had a Linksys BEFSR81 router.  My blog site as well as the other MediaSmart web services were all freely available here inside my home with absolutely no restrictions.  Windows Live Writer easily accessed the blog hosted on the WHS and allowed me to add/modify content.  Now, after going through all these different routers for the past several weeks I've discovered I can no longer access the web services I'm hosting from my local network.  Surely this must have something to do with router setup since that's all that's changed.  Is there some router setting that I can change that would easily open up WHS access from my local network?

    To your point, Chris, I didn't have the WHS certificate installed on my main PC for all those months and accessing the blog on my WHS was a breeze.  Why do I all of a sudden need to add the certificates now?  I did something that changed all this and I have to believe it was the router changes.  Does this make any sense?

    Ken:  I unchecked your post as the "answer" since you "imply" I should not be able to access the vanity URL from inside my home; but in fact I've been doing just that with no problems for 8 months with the old router.  You are clearly way ahead of me in your knowledge of these things but since I've been doing what you imply I shouldn't have been able to do, I'm still a bit confused.

    Thanks again for your time!
    Doug
    • Edited by SonCoder Sunday, November 16, 2008 5:29 PM
    Sunday, November 16, 2008 5:22 PM
  • I didn't say you can't access the server internally. I did say that doing so using a URL like https://server/remote would cause an SSL warning to appear. And so it will. I think at this point you're saying that you can't get to your remote access web site from inside your house using your vanity URL? If that's the case, it's likely because your router can't handle a loop back request, where an internal device tries to connect to the external IP address of your router.
    I'm not on the WHS team, I just post a lot. :)
    Sunday, November 16, 2008 10:33 PM
    Moderator
  • Thanks again for responding, Warren!  You are correct when you say, "at this point you're saying that you can't get to your remote access web site from inside your house using your vanity URL?".  I used to be able to do this with zero issues.  Is the loop back issue something I can affect with a setting on a typical router configuration page?

    Doug
    Sunday, November 16, 2008 11:41 PM
  • During the majority of that time I had a Linksys BEFSR81 router.  My blog site as well as the other MediaSmart web services were all freely available here inside my home with absolutely no restrictions.  Windows Live Writer easily accessed the blog hosted on the WHS and allowed me to add/modify content.  Now, after going through all these different routers for the past several weeks I've discovered I can no longer access the web services I'm hosting from my local network. 
    What are you using for a router now?
    As Ken said, a good many consumer-grade routers just don't do local-loopback.  It's also not usually a setting that you can change, as it's written into the device's firmware.
    By your own admission, it worked until you replaced the router.  Therefore, it's the router's fault, not WHS's.

    Question for you:  which problem would you like to fix - the certificate error when accessing your WHS locally (http://server), or the inability to access it from your LAN by its public address (http://yourname.homeserver.com) ?  The former is easier; the latter will likey require a different router.
    -Chris
    Monday, November 17, 2008 12:43 AM
  • Hi Chris,

    The new router is a Belkin N1 Vision.  In all aspects other than this issue this specific router has done better than all the other draft-N routers I tried from Netgear, Linksys, and D-Link.

    I can certainly get to my public address from within the LAN but when on that page if I select the Log-In button, up comes the SSL error.  I can also type in (http://<servername> and get the same page as the public address, but the Log-in button doesn't work from there either.

    I suppose I want to be able to edit my blog from within my LAN and then access the blog (for reviewing) from within my LAN without restriction.

    Doug
    Monday, November 17, 2008 1:01 AM
  • My recommendation will be to use your wired router (which previously worked fine) as a wired router. Use your wireless router in access point mode; the method of configuring it that way will vary (consult the manual), but you don't want it serving as your internet edge device.
    I'm not on the WHS team, I just post a lot. :)
    Monday, November 17, 2008 12:28 PM
    Moderator