locked
Plugin Timeout issue RRS feed

  • Question

  • Hi,

    I want to increase timeout of plugin to  10 minutes where i can increase. I know best practice is to write workflow for long  business process, that already i have communicated to team. But there is no custom code in my organization and only three workflows , couple of java script. So increasing time-out shouldn't be any issue and have impact.

    Thanks,

    Abhishek


    Abhishek


    • Edited by Abhisinha17 Thursday, January 22, 2015 3:27 AM Update
    Thursday, January 22, 2015 3:26 AM

All replies

  • Hi,

    If you are using CRM on-premise.  Please try to change the following registry in the server:

    HKLM\Software\Microsoft\MSCRM\SandboxClientOperationTimeoutInSec as a REG_DWORD key with a value in decimal greater than 120 (default is 120, which is equivalent to 2 minutes).

    HKLM\Software\Microsoft\MSCRM\SandboxHostOperationTimeoutInSec as a REG_DWORD key with a value in decimal greater than 120 (default is 120, which is equivalent to 2 minutes).  

    HKLM\Software\Microsoft\MSCRM\SandboxWorkerOperationTimeoutInSec as a REG_DWORD key with a value in decimal greater than 120 (default is 120, which is equivalent to 2 minutes).  

    Reference:

    http://blogs.msdn.com/b/crminthefield/archive/2011/06/13/microsoft-dynamics-crm-timeout-settings.aspx

    http://blogs.msdn.com/b/crminthefield/archive/2011/06/13/microsoft-dynamics-crm-timeout-settings.aspx
    http://blogs.msdn.com/b/crminthefield/archive/2011/06/13/microsoft-dynamics-crm-timeout-settings.aspx
    http://blogs.msdn.com/b/crminthefield/archive/2011/06/13/microsoft-dynamics-crm-timeout-settings.aspx
    Thursday, January 22, 2015 4:35 AM
  • Hi,

    I have registered in none and database mode. Is the path same?

    Thanks,

    Abhishek


    Abhishek

    Thursday, January 22, 2015 5:00 AM
  • Hi,

    You can't incrase the plugin timeout. It is default by 2 minutes.


    If you find this post helpful then please Vote as Helpful and Mark As Answer. Thanks and Regards, Polat Aydın My blog

    Thursday, January 22, 2015 10:09 AM