locked
Adding ComputeNode role to HeadNode failure RRS feed

  • Question

  • Hi,

    After setting up my headnode and 3 compute nodes in my cluster, I noticed that the headnode is only in the groups "WCFBrokerNodes, HeadNodes" when I also want it as a compute node.

    Taking it offline and then using the "Change Head Node Roles" option shows the compute node check box as unselected, but when I select it and hit ok, and bring the node online nothing changes, it doesn't appear as a compute node. I also tried running the elevated hpc powershell command (with the correct head node name) Set-hpcnode -name myHeadNode -role ComputeNode, and it throws the error below.

    Any help would be appreciated.

    Set-HpcNode : Cannot bind parameter 'Role' to the target. Exception setting "Role": "Node roles can only be None,
    ComputeNode, BrokerNode."
    At line:1 char:31
    + Set-hpcnode -name myHeadNode -role ComputeNode
    +                               ~~~~~~~~~~~
        + CategoryInfo          : WriteError: (:) [Set-HpcNode], ParameterBindingException
        + FullyQualifiedErrorId : ParameterBindingFailed,Microsoft.ComputeCluster.CCPPSH.SetHpcNodeCommand

    Saturday, February 2, 2019 10:18 AM

Answers

  • I may have found the issue. I have not deployed HPC Pack 2016 Update 2 fixes.

    "Enable Compute Node role of the headnode for non domain joined cluster" is in the patch notes so this patch will likely fix my issue. Will edit this post if I am successful. 

    Edit: The fixes patch solved my issue!
    • Edited by Davy10 Friday, February 8, 2019 7:05 AM Resolved
    • Marked as answer by Davy10 Friday, February 8, 2019 7:05 AM
    Wednesday, February 6, 2019 11:23 PM

All replies

  • Hi Davy10,

    What is the HPC Pack version are you on? You may check it from Help -> About in the Cluster Manager console.

    Could you also check the Change Node Role operation in Resource Management -> Operations and see if there is any error or warning message?

    Regards,

    Yutong Sun

    Sunday, February 3, 2019 1:12 AM
  • I am running HPC Pack 2016 version 5.2.6277.0.

    Checking the Operations, I get the warning "The node role of Node WORKGROUP\myHeadNode cannot be changed."

    Not sure if it's pertinent, but I went through the Operations during provisioning and saw that it "Failed to resolve the SID of the head node."

    Should I just perform a fresh installation on this node, or could there be some issue with my config that it won't allow the head node to also be a compute node?


    Sunday, February 3, 2019 6:52 AM
  • Has the head node joined the domain before installation? For on premise cluster, we recommend that you create the cluster in Active Directory domain.

    Regards,

    Yutong Sun

    Sunday, February 3, 2019 7:36 AM
  • I may have found the issue. I have not deployed HPC Pack 2016 Update 2 fixes.

    "Enable Compute Node role of the headnode for non domain joined cluster" is in the patch notes so this patch will likely fix my issue. Will edit this post if I am successful. 

    Edit: The fixes patch solved my issue!
    • Edited by Davy10 Friday, February 8, 2019 7:05 AM Resolved
    • Marked as answer by Davy10 Friday, February 8, 2019 7:05 AM
    Wednesday, February 6, 2019 11:23 PM