none
Hard drive reporting the incorrect size to BIOS RRS feed

  • Question

  • I had been getting low on disk space on my WHS and with no available bays decided to buy a new case with 9 drive bays. I also purchased an additional 1TB drive to add to the 2 1TB drives I already had installed.

    After putting every together, and booting up, I went into drive manager to see if I needed to initialize the new drive. To my surprise, it showed the new drive, but one of my old drives was only showing 33MB. I shut down and brought up the BIOS screen. Again, it show the new drive and one of my old drives as 1TB but the other drive only came up as 33MB.

    I swapped controllers, cables, took off the new drive and still no luck.

    It gets worse.

    I tried to bring up WHS console to see if my data was still out there and it will not come up at all. It first tells me the backup service is not running and the brings up the console for a second, then disappears. No errors, just goes away.

    I have duplication on most of my folders, so I thought I was somewhat safe but now I am wondering if I have lost everything.

    One other note is that when I click on my shared folders, it tells me that the network is not available. I have not connected it to my network, I wanted to be sure that everything was working before I did.

    Please help. There are pictures on the server that cannot be replaced.

    TIA

    Steve
    Saturday, October 10, 2009 12:42 AM

Answers

All replies

  • It sounds to me like a hardware issue of some sort. Is your motherboard an older one? Are you using SATA or IDE?

    What happens if you connect one of the drives in your server to another computer?
    I'm not on the WHS team, I just post a lot. :)
    Saturday, October 10, 2009 3:29 AM
    Moderator
  • Hi Steve,
    there was either a a firmware bug in a certain harddisk model or a controller driver bug (cannot remember which), that caused this behavior.
    Check the support pages of the maker of your harddisk and mainboard.
    Best greetings from Germany
    Olaf
    Saturday, October 10, 2009 10:32 AM
    Moderator
  • Thanks Ken,

    I gave up last night trying to figure it out and this morning planned to try the drive on another computer. It is a SATA drive. I wanted to make sure that I was pulling the right drive, so I powered up, went into BIOS setup and checked the sizes. They were still showing 1000GB and 33MB. I disconnected one and brought up BIOS again and noticed only one drive and it was showing 1000GB in the position that the 33MB was. Surprised, I shut it down again, reconnected the other drive and powered up. They both were showing 1000GB. Yeah!!!! I immediately connected a USB drive and am currently in the process of backup up my photographs to it.

    Everything looks good, but I do suspect a bad drive too. I plan on taking it off and getting in touch with Seagate's customer support.

    Here's what I plan to do (please let me know if this is incorrect):

    1. Power down and add the new 1TB drive to the system.

    2. Bring up WHS

    3. Initialize and format (?) the new drive.

    4. Add the new drive to WHS

    5. Remove the bad drive from WHS.

    6. Wait until everything is synchronized.

    7. Power down and remove the faulty drive.

    Does that sound like it will work?

    TIA,

    Steve

    Saturday, October 10, 2009 3:37 PM
  • there was either a a firmware bug in a certain harddisk model or a controller driver bug (cannot remember which), that caused this behavior.
    Thanks for the response Olaf.

    Both the drives in the system are exactly the same size and model and have been working for about a year now. I do think that the one is defective.

    Steve
    Saturday, October 10, 2009 3:43 PM
  • Found some comments about this in the Seagate forums.
    Also in a German thread I found mentioned, that this could be a bug of the Bios in certain GigaByte mainboards. And a similar entry in a blog Hitachi 1 TB hard disk turning into 32 MB brick on Gigabyte motherboard.
    Do you use such a board?
    Best greetings from Germany
    Olaf
    Saturday, October 10, 2009 10:28 PM
    Moderator
  • Great research Olaf!

    I do have a Gigabyte motherboard a GA-P35-DS3L. I checked their web site for a BIOS update and there it is Fix: Some of 1000 GB (1TB) HDDs will be detected size error.

    It has been reporting the correct size for the past day or so. I am not sure if I should flash the BIOS or leave it as it is until the problem comes up (if it does) again.

    Thanks again,

    Steve
    Sunday, October 11, 2009 4:07 PM