locked
missing reference to entity event log RRS feed

  • Question

  • Hi,

    I've inherited a CRM system that consists of a dev, test and live environment.

    When I try to import any customisations from dev into test, I get a import progress bar, stuck at 100%, and a event log message of:

    Site map for organization xxxxxxxx-xxxxx-xxxx-xxxxx-xxxxxxxxx contains reference to entity custom_audit but that entity was not found in the metadata cache

    My organisation guid replaced with x's.

    I'm a complete novice with Dynamics CRM, so I guess my question is: How do I go about finding what holds a reference to this missing entity and because it doesn't start 'new_' does this mean it's an out-of-the-box entity that has since been deleted?

    Many thanks in advance!

    Thursday, October 21, 2010 1:52 PM

Answers

  • Hi,

    if its a out-of box entity you cannot delete it even by mistake.

    if its a custom entity.check how the entity scheme name begins eg: new_custom entity( this new can be replaced be any name)

    you can check it Settings--> Administration-->System settings-->customization tab-->check the Prefix name.

    Thanks,

    saraswathy

     

    Thursday, October 21, 2010 3:47 PM

All replies

  • You can check this entity in customization section of CRM. Navigate to below page

    Settings-->Customization-->Customization

    It will display list of all entities where you can check  custom entity name

     


    Jai Ho CRM http://mscrmkb.blogspot.com Skype - amol.gholap

    Mark as answer if a post has answered the question
    Thursday, October 21, 2010 2:00 PM
  • Thanks,

    I've tried that and the entity 'custom_audit' isn't in the list, on any of the 3 environments.

    Thursday, October 21, 2010 2:06 PM
  • Can't we export all entities again and try importing it to other enviornment.

    If not, then search for 'custom_audit' entity name in your customization file  & try deleting from file and then importing it again

     


    Jai Ho CRM http://mscrmkb.blogspot.com Skype - amol.gholap

    Mark as answer if a post has answered the question
    • Marked as answer by november9 Friday, October 22, 2010 8:45 AM
    • Unmarked as answer by november9 Friday, October 22, 2010 8:45 AM
    Thursday, October 21, 2010 2:21 PM
  • There's only one reference to it in the XML and it doesn't matter whether I delete it or not.

    I can confirm that there is no custom_audit entity and that it appears that the reference it's complaining about is in the CRM data and not the customization.xml.

    Thursday, October 21, 2010 3:09 PM
  • Hi,

    if its a out-of box entity you cannot delete it even by mistake.

    if its a custom entity.check how the entity scheme name begins eg: new_custom entity( this new can be replaced be any name)

    you can check it Settings--> Administration-->System settings-->customization tab-->check the Prefix name.

    Thanks,

    saraswathy

     

    Thursday, October 21, 2010 3:47 PM

  • Cheers, thanks for the help.

    I've since found that these errors aren't effecting the import, but what I'm experiencing is a problem with an old IE7 bug in CRM.

    http://marioraunig.blogspot.com/2007/04/ie7-hangs-during-import-of.html

    Still not sure why I'm getting the custom_audit error though.  Will investigate in the future. :-)

    Friday, October 22, 2010 8:45 AM