locked
Resynchronizing Outlook Contacts RRS feed

  • Question

  • I use the feature on the Dynamics CRM Outlook client, to synchronize CRM Contacts into my Outlook Contacts folder.

    (This allows me to use off the shelf features e.g., on my cell phone, that can synchronize to Outlook Contact folders. )

    However, the synchronization was creating many duplicate Contact entries in Outlook.    So, I just deleted all of the Contacts in my Outlook folder, thinking that they would get refreshed from Dynamics Contacts.   However, my thinking seems to be incorrect - I can't figure out how to get it to do this resynchronization.  

    I need help identifying what it is that triggers the creation of a new Contact in Outlook from Dynamics.   This trigger is also probably related to what was creating the duplicate Contact entries.

    Thank you.

    Wednesday, April 1, 2009 10:09 PM

Answers

  • Try deleting and re-creating your local data rules for contacts to be something very restrictive and re-synchronize - this should re-set the rules/synch.
    Then change your local data rules to be what you would like them to be and re-synchronize them again.


    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Thursday, April 2, 2009 9:23 PM
    Moderator
  • Another thing that will make them resynchronize is if anything changes on the record ('isdirty').  So if you add a space or dash to email3 or some field that you are not usign on the contacts, they will resynchronize.
    Saturday, April 4, 2009 11:35 PM
    Moderator

All replies

  • Try deleting and re-creating your local data rules for contacts to be something very restrictive and re-synchronize - this should re-set the rules/synch.
    Then change your local data rules to be what you would like them to be and re-synchronize them again.


    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Thursday, April 2, 2009 9:23 PM
    Moderator
  • I've had a similar situation with a client running CRM 3.0 and that time I got a tool from MSFT support called "Delete Subscription" or similar, which would allow you to delete the correspondence between a particular machine and the CRM database, so that all synchronization status was refreshed. You then ran your CRM Wizard and all your data (based on the local access groups) would be refreshed.

    I don't have the same tool for CRM 4.0, (neither I have the old one, stupidly I never took it with me) but if anyone here can point me to the right direction I would love to have that tool back. And it would definitely solve phduserguy's problem.

    Another way, less drastic, is to uninstall the Outlook client and re-install it, or, even lighter, just run the configuration wizard.
    Saturday, April 4, 2009 8:10 PM
  • Another thing that will make them resynchronize is if anything changes on the record ('isdirty').  So if you add a space or dash to email3 or some field that you are not usign on the contacts, they will resynchronize.
    Saturday, April 4, 2009 11:35 PM
    Moderator
  • Normally I'd be receptive to the idea of uninstalling and reinstalling but there was a problem a few months ago getting the client software installed that resulted in a few weeks of close work with Microsoft support staff to resolve.   We were editing the registry and cleaning out the shards of the previous installation for weeks.   So, not I'm not eager to to that again!

    Tuesday, June 9, 2009 1:26 AM
  • As to the idea of changing the records, that makes sense except for the fact that there are several thousands records missing.

    This really is a defect in Microsoft Dynamics CRM, that synchronization with the Outlook client is both so fragile and inacessible.   It really isn't fair that Microsoft touts it as a differentiating feature vs. e.g., SalesForce.com, when the feature is so broken.
    Tuesday, June 9, 2009 1:34 AM
  • Scott's 4/2 suggestion seems to be a way to work around this Dynamics bug.  That is, one should

    1. Go to the Outlook Client, and do CRM->Modify Local Data Groups

    2. Find the My Contacts entry.

    3. Edit it so that it is restrictive, e.g., that Latitude is 90.

    4. Save the rule, and then close the Modify Local Data Groups window.

    5. Do CRM->Synchronize with Offline Data

    6. Then go to the Outlook folder Contacts and delete everything.  (Careful, you can't use Contacts for anything other than Dynamics CRM for some reason I don't understand, and if you are, then this is one consequence.   You'll have to go through them 1 by 1, I guess.)

    7. Fix the Data Group as changed in 3. to make it reasonable.

    8. CRM->Resynchronize.

     

    Tuesday, June 9, 2009 2:00 AM