locked
Remote Desktop not working correctly RRS feed

  • Question

  • I am having trouble with my Remote Desktop connection when connecting through the internet. The connection works when I connect through the intranet (local ip address staying inside the router). It used to work flawlessly from the outside and just recently stopped working (possibly an auto update to Onecare? ). Is there a setting that has changed in the setups or one that I should be looking for? Any help appreciated.

    Sunday, August 10, 2008 7:47 PM

Answers

  • In the advanced firewall ports and protocols list, make sure that you have Remote Desktop - subnet and Internet checked as well as the first option, which allows Remote Desktop within the local network.

    Are you initiating the RD connection to a remote PC via the Internet with OneCare on one or both PCs?

    -steve

    Monday, August 11, 2008 3:41 PM
    Moderator

All replies

  • In the advanced firewall ports and protocols list, make sure that you have Remote Desktop - subnet and Internet checked as well as the first option, which allows Remote Desktop within the local network.

    Are you initiating the RD connection to a remote PC via the Internet with OneCare on one or both PCs?

    -steve

    Monday, August 11, 2008 3:41 PM
    Moderator
  •  

    I have the subnet and Internet both checked, but for some reason it now only allows me in through the subnet. I usually initiate the RD session from my work computer (internet). When it failed recently, i attempted the acess from my laptop at home, getting through the subnet, but not getting through the internet. The domain does resolve correctly for the RD computer.
    Monday, August 11, 2008 7:28 PM
  • I'm lost. I understand the RD session attempt from work being via the Internet, but when at home, testing from one PC to another on the same LAN, how are you testing RD via the Internet?

    In any event, try turning off the OneCare firewall completely and testing. If it works, but setting the options for RD in the firewall ports and protocols list didn't work with the firewall on, you may want to contact support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Tuesday, August 12, 2008 1:06 PM
    Moderator
  • For what it is worth - I'm having the same trouble. Remote Desktop works from my subnet, but not from any external sources. I have a dynamic DNS setup -and I can get to my router via a browser, and my router is set to allow requests via the right port.

    This happened previously when OneCare was updated, too.
    Saturday, September 6, 2008 3:23 PM
  •  

     

    Patrick,

    Sounds like the identical issue that I was having. I can't say why, but it seems have "fixed itself". I tried to investigate why it started working again and found nothing. This I can say...between the time I last attempted to fiz it and it still didn't work, and the time that it started working again, I changed nothing. Must be something in auto updates possibly with One-Care or possibly in Windows.

     

    -Dave-

    Monday, September 8, 2008 3:24 PM
  •  

    You can use the remote assitance in vista to create a invitation this uses vista's teredo to create a peer to peer session..NO need to configure port forwarding in ur router as it connects ur home computer to office directly ..Much faster & reliable.. You can also check this soft which works using teredo:  http://www.lanoninternet.com
    Monday, September 15, 2008 8:00 PM