locked
Problem with KB2505438 and RAID (hardware) array RRS feed

  • Question

  • First let me start by saying that upgrading to WHS 2011 has been a complete pain in the a**.

    I have a custom PC - ASUS P5B Deluxe MB, E6300, 6GB RAM, 2 1TB drives that I was going to mirror for OS and PC backups and a RocketRAID 26404x4 RAID controller with 4 1.5 TB drives attached in RAID5.

    Installing was fine although it is an EXTREMELY slow process.

    I had my 1 TB drives mirrored, installed the drivers for the RAID card and had a disk with 4.5 TB unused space. The 1st time I went through this process I added the 4.5 TB drive through the dashboard which partitioned it as 2TB, 2TB, 500GB. No big deal. Not really how I wanted it because I was not going to include this drive in the server backup. So everything was going smoothly and I continued on installing MS updates. No problem until about the 2nd or 3rd round. After that I restarted and couldn't see any of the 3 partitions from the 4.5TB RAID array. The controller was still listed in device manager, but the 4.5TB disk was gone out of disk management. I tried a couple of things but could not ever get Windows to see the disk again.

    So I started over this time I pretty much did the same thing except instead of partitioning the 4TB drive I just went into disk manager myself and created one big partition. Again everything was good until about the 3rd restart and I couldn't see the drive again. It also was not seen using Diskpart.

    So I rebuilt it for the 3rd time. This time I paid attention to the Windows updates. I installed the first round of critical updates no problem. Restarted and it was still ok. Did the next group and also included IE9 which was a critical update but not checked. Restarted and it was ok. Then i went and checked again. There was one critical update that was not checked - KB2505438. So I checked it, installed and restarted - this time the drive is gone.

    I tried uninstalling the update but it still doesn't see the array. If I go into Diskpart it doesn't see it either.

    So I am about to begin the 4th installation of WHS 2011. Unless anyone has any ideas as to how I can get this array to become visible again.

    There isn't any data on it so its not a big deal other than the fact that it takes so long to install.

    However, this does really concern me for the future. What if this was an update 4 months down the road and I had the array full of data?

    Thursday, July 14, 2011 1:16 AM

All replies

  • This sounds to me like there's some sort of issue with your RAID HBA driver conflicting with the KB you mentioned. A few other people have reported similar issues.

    Could you please file a bug on Connect regarding this, and let us know the id when you've done so?


    I'm not on the WHS team, I just post a lot. :)
    Thursday, July 14, 2011 1:59 AM
  • I submitted a bug but the link on how to submit the logs doesn't work. The link for the toolkit doesn't work either so I don't know how to get the ID and send the logs.
    Thursday, July 14, 2011 3:26 AM
  • For the moment, I'd say don't sweat it. At worst, Microsoft's bug triage team will have to walk you through collecting the logs manually.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, July 14, 2011 4:08 AM