locked
Reinstalled, old data drives not added to the storage pool...any way to do it manually? RRS feed

  • Question

  • I was having a number of issues with an almost 3 year old WHS install, so I decided that it was time to just bite the bullet and reinstall the OS.  Oh, what fun I had.

    First, the setup; all components were used fine and without any problems in this machine for a while now:

    500GB system drive using SATA port 1 on an Asus mobo using an Intel P35 chipset with 4 SATA ports onboard.  All drives, including optical, are SATA.

    3x2TB data drives on a Rosewill SATA card using the SiL 3114 chipset (this one: http://www.newegg.com/Product/Product.aspx?Item=N82E16816132013)

    1x1.5TB drive an a TX4302 card for server backups, which I did before the process started.  I have all data from my shares, so if this goes ____ up, I'm not totally screwed

    So I start doing the no pants dance...er, I mean reinstall, with the server.  Pop the DVD in, get to the drives screen, and I only see the 500GB drive, so I load the drivers for the SiL 3114 card that the other 3 drives are connected to.  Still only see the 500GB drive. Click the back button and then the next button thinking that's what I need to refresh the drives, and no dice.  Decide that perhaps the server is smarter than I am, continue the reinstallation process, get to my shiny new OS install, and the data drives are showing up in drive manager with drive letters, but they aren't in the storage pool.  Fail.

    Take 2.  Following procedures found here, I disconnect all but the 500GB drive, select a clean install, get to the shiny new OS, shut down, reconnect the drives as they were before, pop the DVD in and select a reinstall, try to load the SiL 3114 drivers, still no dice, go through the process anyway, and same result.  Fail 2.

    Take 3.  Since the drives on the SiL 3114 card weren't being found, I decided that the install was having issues with the drivers.  So, I unplugged my optical drive, plugged the OS into the first onboard SATA port, and then plugged the 3 2TB drives from the storage pool into the other 3 onboard SATA ports.  Using an external USB optical drive, I go through the install steps again.  This time, it looks promising...all 4 drives are showing up in the drives screen.  I select the reinstall option, honestly hoping for the best and thinking that I might (just might) actually succeed.  Go through the install, get to my shiny new OS, update, update, and more update, and finally, with an OS that is brand new and patched to SP2/PP3, I go into the WHS console hoping to find 4 drives in my storage pool.  Nope.  the 500GB drive was in the storage pool (obviously), but the 3x2TB drives were in the "yet to be added" pile.  Ugh.

    So here I am.  Again, I'm not completely screwed, because I backed up my data first, but I'd really hate to lose my backups and have to copy all of that data back to the shares (manually, at that).

    Is there ANY WAY, unsupported or not, that I can manually force-add those 3 drives that used to be in my storage pool and still have data on them into the storage pool on my new OS install?

    I also have one other thought...even though the SiL 3114 card supports 2TB drives, I'm wondering if it might have been part of the problem during the install...but then again, I didn't have any more success after I plugged those drives into the onboard ports, so I might be grasping at straws.  Anyway, what I'm getting at is if I need to buy a new, different SATA controller, I can do that.

    Any advice?

    Thanks,

    Pete

    Saturday, September 4, 2010 2:45 PM

All replies

  • It's not possible to reintegrate your drives "after the fact". Instead, you will have to copy data off your drives one at a time, following the instructions in this FAQ.
    I'm not on the WHS team, I just post a lot. :)
    Saturday, September 4, 2010 3:01 PM
    Moderator