locked
WHSConnector_64x RRS feed

  • Question

  • I have not had very good luck backing up my Dell XPS 64bit.  I have uninstalled and reinstalled the connector software and it still doesn't backup.  Here is the message I receive from the view backup details:

    An unexpected exception occurred on the computer.
    COMException
    Incorrect function. (Exception from HRESULT: 0x800700001
    at
    System.Runtime.InteropServices.Marshal.ThrowExceptionFor HRInternal(Int32 errorCode,IntPtr errorInfo)
    at Microsoft HomeService Common Client Win32

    It won't scroll any further and let me read the rest.  My thought is that it isn't installing the 64bit connector but I'm no expert so I don't know what is going on.  I used to work until I believe the new upgrade came out and I just never took the time to communicate this out to the Forum and see if anyone would know what is happening here.

    Any assistance would be greatly appreciated.


    David Farris
    Tuesday, June 16, 2009 2:59 PM

All replies

  • Could you try running the command:
    chkdsk /r
    on all drives in that computer?

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, June 16, 2009 3:11 PM
    Moderator
  • Hi David,
    besides the chkdsk command, to which Ken already pointed, please check the event log of the client. There should be more pointing to not properly installed VSS or COM+ components or DCOM settings.
    (At least a GUID, which you can search for in the registry.)
    What is the output of the command line commands
    vssadmin list writers
    vssadmin list providers
    Which OS - Vista or Windows XP 64 Bit? The later is not supported by the Connector software.

    Best greetings from Germany
    Olaf
    Tuesday, June 16, 2009 9:39 PM
    Moderator