Communicator Web Access RRS feed

  • Question

  • I have communicator web access running on a Windows Server 2003 x64 r2 Standard system.  CWA was working for while and then all of the sudden I get an IIS 401.1 error page.  The CWAService account is a member of the RTCComponentUniversalServices and the RTCUniversalServerAdmins groups. 

    Any suggestions would be appreciated.
    Tuesday, October 14, 2008 3:33 PM

All replies

  • Any clues in your event viewer or IIS logs?  Any password changes recently on service accounts?


    Wednesday, October 15, 2008 2:09 PM
  • Please check the properties of the CWA service account that it has a password not set to expire

    This is a common issue with OCS Service accounts


    Wednesday, October 15, 2008 3:52 PM
  • The CWA service account is setup so that the password does not expire.  The event log ans ISS log don't seem to offer up anything useful.
    Wednesday, October 15, 2008 5:56 PM
  • Make sure that Enable32BitAppOnWin64 is enabled on IIS


    cscript.exe adsutil.vbs get W3SVC/AppPools/Enable32BitAppOnWin64

    Must return true


    Also check Web Service Extensions on IIS are enabled

    - Asp.NET 2.0 32 bit is allowed

    - cwaauth is allowed


    And also verify that the Communicator Web Access pool is running in IIS



    Wednesday, October 15, 2008 7:23 PM
  • Sorry for the delay in responding to this.  It seems to be a problem with enabling 32 bit ASP.  I am still working to resolve it.
    Monday, October 20, 2008 1:52 PM
  • I enabled Enable32BitAppOnWin64.  IIS extensions are running and the CWA Access pool is running in IIS.
    Any other suggestions?
    Monday, October 20, 2008 3:44 PM

    Maybe it is easier to reinstall the CWA
    Monday, October 20, 2008 11:17 PM
  • I tried a re-install of CWA yesterday and no luck.  Is this something I should open a support case with MS on?

    Tuesday, October 21, 2008 1:28 PM
  • Looks like you authentication problems


    Try to go through the article


    Tuesday, October 21, 2008 3:51 PM
  • ok I will give it a try
    Wednesday, October 22, 2008 12:55 PM