locked
Not able to open the deployment manager RRS feed

  • Question

  • We just did a in-place upgrade from CRM4.0 to CRM2011. The CRM site looks fine. We are able to log-in and view the data. However, when we try to open the deployment manager, it throws an error "Could not load file or assembly". Then, I tried to open the mmc snap-in it gave us more detailed error, as shown before.

    I tried the following things:

    1. Reinstalled the latest version of Microsoft Visual C++ 2010 Redistributable Pack (64bit & 32bit)

    2. Reinstalled the latest version of Microsoft Visual C++ 2008 Redistributable Pack (64bit & 32bit) 

    3. Checked the dlls in the Microsoft Dynamics CRM\Tools folder. All dlls with correct size are in place.

    4. Tried to open it as administrator

    After all these, we are still not able to open the deployment manager. The error stay the same. Do you have any suggestions that I can try?  

    Please help. Thank you.

    Sam Luo

    ---------------------------------------

    FX:{1ac9de3e-24ae-480d-9e15-65386b76e433}

    Could not load file or assembly 'Microsoft.Crm.Tools.Admin.DMSnapin, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.


    at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
       at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
       at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
       at System.Activator.CreateInstance(String assemblyName, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark)
       at System.Activator.CreateInstance(String assemblyName, String typeName)
       at System.AppDomain.CreateInstanceAndUnwrap(String assemblyName, String typeName)
       at Microsoft.ManagementConsole.Internal.SnapInClient.CreateSnapIn(String assemblyName, String typeName)
       at Microsoft.ManagementConsole.Internal.ClassLibraryServices.Microsoft.ManagementConsole.Internal.IClassLibraryServices.CreateSnapIn(String assemblyName, String typeName)
       at Microsoft.ManagementConsole.Executive.SnapInInitializationOperation.OnStart()
       at Microsoft.ManagementConsole.Executive.RunningOperationsTable.EnqueueOperation(Operation operation)
       at Microsoft.ManagementConsole.Executive.StandAloneComponentData..ctor(SnapInRegistrationInfo info, Int32 bookkeepingId)
       at Microsoft.ManagementConsole.Advanced.FrameworkSnapInFactory.Microsoft.ManagementConsole.Advanced.ISnapInFactory.CreateSnapIn(Int32 bookkeepingId, String snapInKey, Object& snapIn)


    Friday, April 18, 2014 11:05 AM

All replies

  • If you have multi DCs, you may need to add a registry key under:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

    Name:PreferredDc

    Value: The name of DC you used for CRM

    If still not work, try to repair your CRM deployment, then try again

    Wilson

    Monday, April 21, 2014 6:39 AM