locked
composite editor does not work and cannot be reinstalled RRS feed

  • Question

  • The OS is 32 bit Vista.

    I had an older copy of ICE which worked fine, but got an update notice, so I clicked for the update.  The installation appeared to occur, but the program refuses to run.  I have tried many different ways to delete this and reinstall the old one, which I still have as a download.  No go.  I get an installer error.  All instances of ICE now refuse to run.   I tried removing the program, removing the registry entries, removing all traces from Win. explorer, and still no go. I found a reference for how to fix the installer problem running a dll program, and that crashed, and then Windows crashed, and went to a disk check.  It's up and running again, but still no luck.  Can someone please give me a full list of what needs to be deleted or fixed to get a clean start on any version of 32 bit ICE?

    P.s.  When I tried deletion and reinstallation of the older versions, I got "Installer error #2753," which appears to suggest a corrupted registry.  No luck trying to fix that, which gave me another error.

    One more edit:  when I tried to run vbscript.dll as suggested, it said it was called but returned an error 0x80004005, which I should look up.  That's where I've stopped for the moment.  I have another laptop that runs Win7, and downloaded the latest ICE program to it, and it installed and ran fine,  so the problem is undoubtedly in Vista here.

    Thursday, December 3, 2015 12:07 AM

All replies

  • I'll reply to my own problem just in case this shows up in some archive down the road.  After Windows refused to delete previous instances, I gave up for a time.  But then just for an experiment, I hunted down an older, Win XP compatible version of the program, and tried to install that.  Instead of the usual error, it said it could not install because a newer version was installed.  So I went to the Control panel, and for reasons I'll never know, this time the uninstallation completed.  I then was able to install the old version.  I have not tried to install the newer one again since the old one is working.  Apparently it took a failed installation to make an uninstallation work, and an uninstallation to fix the registry problem.  Or maybe the phase of the moon was right this time.

    ICE itself is a really fine program, but golly, it's tricky to get up and running!

    Tuesday, March 1, 2016 8:43 PM
  • Hmmm. I can't say I've ever had those issues trying to uninstall or install ICE...

    I was going to suggest (before I saw that you'd found a solution) that you create a new desktop profile on your Vista machine and try installing ICE 'for this user only' on that new desktop profile.

    Also, unless you want ICE 1.6 nagging you that there is a newer version available every time you open it, you probably want to open ICE's options and disable the check for updates on ICE startup.

    I hope you'll have better fortunes in the future.

    Your fellow panner,
    N


    Tuesday, March 1, 2016 9:39 PM