none
Windows SharePoint Services Search has stopped working RRS feed

  • Question

  • On SBS2008.  When I try and start the Search service (from within Central Administration), I obtain this error message:
    "
     
    WSS_Search_OTTF1 on np:\\.\pipe\MSSQL$Microsoft##SSEE\sql\query contains user-defined schema.  Databases must be empty before they can be used.  Delete all of the tables, stored procedures and other objects or use a different database.
    I need some help on this, thanks so much
    Friday, September 4, 2009 5:13 PM

Answers

  • Help:
    I am still having trouble with this problem.  
    Also, for some reason I am having trouble with entering service settings userID's and passwords using server\username format.   Why?  
    • Marked as answer by hannsf Wednesday, September 9, 2009 4:06 AM
    • Unmarked as answer by hannsf Wednesday, September 9, 2009 4:06 AM
    • Marked as answer by hannsf Wednesday, September 9, 2009 4:38 AM
    Tuesday, September 8, 2009 6:13 PM

All replies

  • Hannsf,

    Rename the database "WSS_Search_OTTF1" to some other name. SharePoint is trying to create a new search database and find the file already exists so its not able to overwrite the schema of that database.

    And start the Search Service from Central Administration -> Operations -> Services on server -> Click on the Windows Sharepoint Services Search service.

    Thanks,
    Veera Reddy
    Friday, September 4, 2009 5:31 PM
  • Veera:
    Thanks for this reply, however I cannot find a WSS_Search_OTTF1 file on my server.   This is the only file I find with WSS_Search

    WSS_Search_WIN-EUGSO7LO7PY.mdf

    If I rename this file, I don't get a different result (I still get same error message referencing WSS_Search_OTTF1)
    Friday, September 4, 2009 6:00 PM
  • Check if, that the 'Service Account' and 'Content Access Account' service account specified are the same. They should not be working with two separate accounts. If it still does not work, Stop the service and while starting it again specify a common service account and create a new Search Database.

    Make sure you have logged with proper service account to the box.

    Thanks,
    Veera Reddy
    Friday, September 4, 2009 6:22 PM
  • Veera:
    I'm not sure if I'm doing this right.   I am trying to use the Administrator account for both the Service Account and the Content Access Account.   Please advise on this.  

    Also, I'm not sure if this is related - Search Index on my server is not working.  When I search for files on disk, a message displays that the search may be slow because the Index is not running.

    Friday, September 4, 2009 6:45 PM
  • Hannsf,

    Refer the below link for better understanding on Service Accounts planning (Windiows SharePoint Serices).
    http://technet.microsoft.com/en-us/library/cc288210.aspx

    For your current senario, use your administrator/system account to reconfigure the search. You check the indexing configuration on Search Configuration wizard. Stop the service and reconfigure it with new Search Database.

    Thanks,
    Veera Reddy

     

     

    Friday, September 4, 2009 6:59 PM
  • Veera:
    How do I create a new search database? 
    Is it OK to use the Administrator account for the Service Account and Content Access Acount?
    Friday, September 4, 2009 7:22 PM
  • Stop the Search Service, if it's already stopped. Start it, while starting it again specify a common service account and create a new Search Database. i.e give new name for "Search Database", option -> "WSS_Serach_CustomName" and clik ok.

    Here is the better explanation for Service accounts:

    • Service Account - You cannot use any built in accounts when specifiying the Service Account, however you can use local accounts. One account you can choose to use is the default Administrator account on your server, "myserver\Administrator".
    • Content Access Account - Use an account that has full read access to your SharePoint Content Databases. As a security precaution, try not to use an account that has write permissions on the database. For example: "mydomain\sqlserveruser".
    • Search Database - In most cases the default settings will work, change them as required.
    • Indexing Schedule - No new files will be searchable until they are indexed, depending on the load you wish to put on the server you can set this to be done as often as you want.

    Upon submitting the form, the search service should start and begin indexing the content in your SharePoint site. 

    Thanks,
    Veera Reddy

    Friday, September 4, 2009 7:41 PM
  • Veera:
    I now get a different error message:

    SPSearch (administrator)

    Friday, September 4, 2009 8:51 PM
  • Check out this for same issue:
    http://social.technet.microsoft.com/Forums/en-US/sharepointsearch/thread/d613060a-c67d-481b-9a68-2d9907f3b33a

    Enter the user name as in "server\user"

    Thanks,
    Veera Reddy
    Friday, September 4, 2009 10:31 PM
  • I can't get past the "

    Configure Windows SharePoint Services Search Service Settings on server OTTF1 " screen.

    It highlights in red "the username and password entered are not valid."

    I am using OTTF1\administrator as my username.

    Friday, September 4, 2009 11:32 PM
  • Help:
    I am still having trouble with this problem.  
    Also, for some reason I am having trouble with entering service settings userID's and passwords using server\username format.   Why?  
    • Marked as answer by hannsf Wednesday, September 9, 2009 4:06 AM
    • Unmarked as answer by hannsf Wednesday, September 9, 2009 4:06 AM
    • Marked as answer by hannsf Wednesday, September 9, 2009 4:38 AM
    Tuesday, September 8, 2009 6:13 PM
  • Moving to Off-topic.

    These continue to not be support forums for SBS 2008
    WSS FAQ sites: http://wssv2faq.mindsharp.com and http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 / MOSS 2007 Books (including foreign language) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Sunday, September 13, 2009 3:55 PM
    Moderator