none
Number of threads no longer includes threads that are not of the Question type. RRS feed

  • Question

  • One this page

    http://social.msdn.microsoft.com/Forums/en-US/category/sharepoint/

    which lists all the SharePoint forums, there is towards the end a forum called "Community Advancement" which is almost entirely used for posting notices of user group meetings throughout the world.

    These posts naturally are not questions that need to be "answered" and so they are posted as Discussion posts.

    There used to be 18 threads listed here of which 2 were marked as answered. Those two threads were the only ones of type Question because they were asking about general information about user groups. All the other threads were of type Discussion.

    So far so good. I knew there were 18 threads and so if the number increased I could go in to see if the additional thread was on topic.

    Now however on the above page that newsgroup only lists two threads. All the 18 threads are still there but as far as the stats on the overview page are concerned 16 of them don't exist !


    In other words an "improvement" has been made such that only Question type  threads are now regarded as being worth listing on the overview page. This means it is now impossible to use the number of threads listed to tell if any new content has been added because if that new content was added as a Discussion type thread the number won't increase.

    ---------------------

    The suggestion is therefore to go back to the old system of counting posts of all kinds in the totals, This new system has no merit.
    Thursday, November 27, 2008 1:45 PM

All replies

  • Actually, it's just a bug in a stored proc. It's already been fixed for the next version. It can crop up on any forum for just that stat and has to do with a diff between a GetSingle SP and a GetMultiple sp.
    Rob J, Forums Dev
    Thursday, November 27, 2008 11:28 PM
  • Thanks. I was giving an example - not assuming the bug was restricted to that one forum.

    If it's a bug, it's one that has crept in recently as this didn't use to happen
    Friday, November 28, 2008 6:50 AM
  •  Now that forum is showing the right number but another one in the same set

    http://social.technet.microsoft.com/Forums/en-US/sharepointaccessibility/threads/

    is showing 10 threads.

    This is neither the number of Question type threads; nor the total number of threads.

    In fact - in a new variation  it's the number of Question type threads that having been marked as answered.

    So as you only offered a choice of two "GetSingle SP and a GetMultiple sp." and there are so far *three* variations (All; All Question threads answered or not; All non-answered question threads), maybe you should look again at this.

    Friday, November 28, 2008 2:49 PM
  • It's the same for both cases. The bug was the singular SP select list had
    ..fields,
    UnansweredQuestions
    TotalThreads,
    ...more fields

    So UnansweredQuestions was being aliased as TotalThreads. If the Forum requested is not cached and the request goes down the "get a single forum" path, this bug will show.

    In Community Advancement there are 2 unanswered questions (the two sticky's) and in Sharepoint Accessibility there are 10.
    Rob J, Forums Dev
    Friday, November 28, 2008 4:24 PM
  • Thanks. By coincidence in Community Advancement there were two answered questions. Hence my connecting it with that.

    I always ignore the sticky ones ..... (they don't count :) )

     

    Friday, November 28, 2008 6:29 PM