locked
An error has occured - CRM 2011

    Question

  • All users are prompted with the error message when attemping to load several data sources such as accounts, Dashboard, contacts, etc

    "Error

    An error has occured

    Try this action again. If the problem continues, check the microsoft

    Dynamics CRM community for solutions or contact your organizations's

    Microsoft Dynamics CrM Administrator. Finally, you can contact Microsoft

     support."

    I know this probably a generic error message put perhaps if i shared potentially causes that prompted this error message may surface the underlying issue.

    The Server that hosted the CRM application became corrupted and unbootable. the SQL database for CRM is located on a different server. We was forced to rebuild the server under a different name. After we built the machine, we ran the Microsoft Dynamics 2011 installation wizard again. The installation was able to detect the previous deployment and installed the application. once the installation completed, we then ran the Update Rollup 3 and restarted the Server. we did not test to see if the application worked prior to installing the Update Rollup.

    What would you suggest?

    Many Thanks

    Monday, August 1, 2011 2:02 PM

All replies

  • You can turn on platform tracing in CRM to help understand the nature of the underlying issue:

    http://support.microsoft.com/kb/907490

    There is also a diagnostic tool here: http://mscrmtools.blogspot.com/2011/04/new-tool-crmdiagtool-2011.html

    Both of these solutions require you to enable tracing either using the tool or manually and then recreate the problem to generate a log file.  This should help you understand what is going on.


    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    • Proposed as answer by Jim Glass Jr Monday, August 1, 2011 3:49 PM
    • Unproposed as answer by James_Mc_D Tuesday, August 2, 2011 6:28 AM
    Monday, August 1, 2011 3:44 PM
    Moderator
  • Yes i did install this tool, didnt help me highlight the issue though. However i am gettin a new error page with the tools installed above, showing the error message below

    Error Description:
    An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Error Details:
    Exception of type 'System.Web.HttpUnhandledException' was thrown.

    Full Stack:
    [SocketException: The requested name is valid, but no data of the requested type was found]
      at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
      at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
      at Microsoft.Crm.Application.Utility.Util.IsLocalUrl(String url)
      at Microsoft.Crm.Utility.HelpUtility.UseLocalHelpServer(String helpServer)
      at Microsoft.Crm.Application.Controls.InAppContent.GetHelpPath(String path, String siteMapPath, Boolean& setRestricted, String& initScript)
      at Microsoft.Crm.Application.Controls.InAppContent.CreateChildControls()
      at System.Web.UI.Control.EnsureChildControls()
      at System.Web.UI.Control.PreRenderRecursiveInternal()
      at System.Web.UI.Control.PreRenderRecursiveInternal()
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    
    [HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown.]
      at System.Web.UI.Page.HandleError(Exception e)
      at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
      at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
      at System.Web.UI.Page.ProcessRequest()
      at System.Web.UI.Page.ProcessRequest(HttpContext context)
      at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
      at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    
    

    Other Message:
    Error Number:
    Source File:
    Not available

    Line Number:
    Not available

    Error Trace:

     
     
    Request URL:
    https://crm.cloud.jpreis.com/JPRCRM/workplace/home_dashboards.aspx?pagemode=iframe&sitemappath=Workplace%7cMyWork%7cnav_dashboards

     

    Tuesday, August 2, 2011 6:34 AM
  • It appears to be some kind of a network error where it can't find a request resource.  Are you using dashboards or iframes that are using an outside resource?
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Tuesday, August 2, 2011 2:41 PM
    Moderator
  • I have made some modifications to the dashboards using the builtin customisation too but i didnt add any references to outside sources. The dashboard is one of the entitys i am having issues with along with Contacts, Accounts and many more.
    Tuesday, August 2, 2011 3:07 PM
  • Wondering if whatever occurred on the CRM server to corrupt it also impacted the SQL database?  Based on what you are posting, it looks like the database also has corruption

    Regards, Donna

    Wednesday, August 3, 2011 4:30 PM
  • Maybe. How the sql database is located on a seperate server. It was the Servers OS that corrupted, not the application.
    Thursday, August 4, 2011 1:00 PM
  • I understand James, but we have no way of knowing if the corruption that occurred on the CRM server impacted the SQL database even though they are on separate systems.  We can assume it didn't write config changes to the database that could be the root cause of the behavior you are currently dealing with but at this point that seems like it might not be a viable assumption. 

    If you don't think that corruption occurred to the database in relationship to the CRM server crash then did you write some customization or make some other changes that we are not aware of that could cause the level of system wide issues you are currently seeing? 

    You state, "The dashboard is one of the entitys i am having issues with along with Contacts, Accounts and many more."  We don't generally see that level of system-wide issues unless there is corruption in your customization files, unsupported changes to the database, etc.  If this is a dev environment, I suggest a re-install or create a new Org and see if you still see the corruption.


    Regards, Donna

    Thursday, August 4, 2011 1:33 PM
  • If you reinstalled CRM and then tried to re-attach your old org you should be able to see if it's potentially corrupted by seeing if that fixes the issue?

    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!

    Friday, June 29, 2012 2:19 PM
    Moderator
  • Tuesday, June 11, 2013 2:53 PM
    Moderator