locked
Adding a new Group to a SubArea in SiteXML in CRM 2011 RRS feed

  • Question

  • I have been trying to achieve this thing by modifying the SiteXML, but I have failed so far. Ok, so let me address the issue. Generally the "Sales" section looks as follows. The "Attribute Administrator" is one of my custom links that point to a custom HTML page to be displayed in the right dashboard. I want this "Attribute Administrator" to appear in a seperate Group.

    I want the "Attribute Administrator" to appear in a seperate link like what we see in "Settings" having different Groups like "Business", "System", "Customization". I want a similar Group to apper under "Sales" Area.

    Now, what I have done is, I have modified the customizations.xml to include a Group and then the SubArea containing my custom link within it. The import was successful, but what happened was that the link appear right after all the links under Sales, instead of being in a seperate Group.

    What am I doing wrong? Is there anything I am missing out? Maybe something else by which it can be achieved. I am not in favor of using tools to edit my SiteMap as I fear messing up stuff. Please assist me on this. Thanks.

    Wednesday, June 6, 2012 11:07 AM

Answers

  • Hi,

    Just add ShowGroups="true" attribute in <Area> node as below :-

    <Area Id="SFA" ResourceId="Area_Sales" ShowGroups="true" Icon="/_imgs/sales_24x24.gif" DescriptionResourceId="Sales_Description">

    • Proposed as answer by _Vikram Wednesday, June 6, 2012 12:30 PM
    • Marked as answer by CRM Junkie Wednesday, June 6, 2012 12:42 PM
    Wednesday, June 6, 2012 12:30 PM

All replies

  • Use the following tool
    http://sitemapeditor.codeplex.com/
    add Group and than add sub area from the tool

    I hope this helps. If my response answered your question, please mark the response as an answer and also vote as helpful.
    Mubasher Sharif
    Check out my about.me profile!
    http://mubashersharif.blogspot.com
    Linked-In Profile
    Follow me on Twitter!


    Wednesday, June 6, 2012 11:34 AM
  • The SiteXML that this tool generated is the same as what I manually edited. Nevertheless, I imported the changed SiteXML (modified by this tool) and the result is the same. I am not getting it under a seperate Group, but after all the links under Sales. I am getting this as follows :

    See? It's not appearing as a seperate Group like we have under Settings.

    • Edited by CRM Junkie Wednesday, June 6, 2012 12:25 PM Added Screenshot
    Wednesday, June 6, 2012 12:20 PM
  • Hi,

    Just add ShowGroups="true" attribute in <Area> node as below :-

    <Area Id="SFA" ResourceId="Area_Sales" ShowGroups="true" Icon="/_imgs/sales_24x24.gif" DescriptionResourceId="Sales_Description">

    • Proposed as answer by _Vikram Wednesday, June 6, 2012 12:30 PM
    • Marked as answer by CRM Junkie Wednesday, June 6, 2012 12:42 PM
    Wednesday, June 6, 2012 12:30 PM
  • Awesome _Vikram! Works like magic! :)

    Thanks a ton! I had been struggling with this for quite some time.


    • Edited by CRM Junkie Wednesday, June 6, 2012 12:42 PM
    Wednesday, June 6, 2012 12:42 PM