locked
Three client PC's can find WHS, one can't. HELP. Redeploying WHS after a rebuild. RRS feed

  • Question

  • After 4 months of faithful service, my Windows Home Server machine took a dump (technical term) on me two weeks ago and wouldn't boot up.  I constructed a new machine with a new Intel Motherboard, CPU, power supply, and case.  The hard drives from the old WHS server were installed in the new case.  After some minor bios issues, I was able to get WHS to boot from the CDROM and install a restored version, keeping the previous backups and shared file data.  YEAH!! So happy about that.

    I've finally gotten the WHS completely updated with all patches and updates.   I've opened the console and gotten into the "Settings/Remote Access" portion.  After assigning a fixed IP Address to this machine (more on that later), I'm able to get the Home Server domain name to walk all the way through the status checks with all green check marks.  The reason I had to assign a fixed IP address is because I have port forwarding set up on my router and a specific IP address setup to handle it.  This is the solution I found to Remote Access issues when I originally built the WHS machine.  It worked then.  Backed up just fine.  Used the Remote Access from outside the network to get on the server and network computers.  No issues with the original build, that is until it took a dump.

    GOOD NEWS : So now the new WHS Machine seems to be working fine, except that the PC's that I had setup on the old WHS can't see or find the Server.  The server Remote Access has passed all status checks.  I can access the WHS from outside my local network just as I could in the past.  Network computers can access the shared files just as they could before with a mapped drive.

    PROBLEM :  I can't get WHS to recognize the computers that it used to back up and the computers that it used to backup can't see the WHS.  The little icon in the tray of the network computers is GREY instead of GREEN. 

    I can log into the Windows Home Server Console from a network computer IF I use "Remote Desktop Connection" but when I try to use the system tray ICON, it can't find the Server. 

    What do I do to re-establish the relationship between the network computers and the WHS?

    Thanks in advance for your help in this matter.
    Wednesday, October 14, 2009 4:09 PM

All replies

  • ...
    What do I do to re-establish the relationship between the network computers and the WHS?
    ...
    Try running (on the client computers) C:\Program Files\Windows Home Server\discovery.exe.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, October 14, 2009 4:29 PM
    Moderator
  • Ken

    Just tried running that on your recommendation.  It asked for the Windows Home Server Password.  Entered it.  Got an error message: "This operation cannot be completed at this time."

    I know that the password is correct.  I've got a connection to the Home Server on my second screen via RDC and I checked the password.  When I click the link for a password hint, it gives me a window that says: "Ensure that your home server is powered on and connected to the network..."

    It seems weird that I can use RDC to get to the homeserver machine but the client computer WHS tray icon doesn't seem to know where WHS is.

    Thanks for the suggestion though. 

    What next.
    Wednesday, October 14, 2009 4:37 PM
  • I downloaded the WHS Connector Troubleshooter toolkit to the client computer.  Then I loaded it onto the WHS machine.  What's funny is I think the client machine uploaded it to the WHS machine.  I went to Start/Windows Homeserver Tool Kit/Publish Server Add-in.  Then I checked the WHS on my second screen (connected by RDC) and it appeared on the Add-in list.  I loaded it.  I ran the toolkit on the WHS machine and not no negative messages in response to the system check using the toolkit.  "No connectivity issues found!"  BUT when I run the toolkit on the client machine, it comes back with an error report.

    Errors reported:

    Cannot connect to the server internal Web site (password hint page)
    Cannot connect to the server secure internal Web site
    Cannot connect to the server internal Web site (simple page)
    Cannot connect to the server internal Web site (ASPX page)
    Cannot connect to the server internal Web site over IP address (password hint page)
    Cannot connect to the server internal Web site over IP address (ASPX page)
    Cannot connect to the server internal Web site over IP address (simple page)
    Windows Home Server Connector troubleshooting article

    Additionally , I've rebooted both the client that I am trying to re-establish and the WHS machine.  No change.

    UPDATE :  I bellied up to a different client PC and ran Discovery and it re-established the connection.  Maybe my issue has something to do with the client PC?
    • Edited by vegoilrecycler Wednesday, October 14, 2009 4:44 PM additional info
    Wednesday, October 14, 2009 4:41 PM
  • Try rebooting the server again.
    After that uninstall the Connector software on the clients and reinstall it from http://yourservername:55000.
    If this still does not work, did you install any additional applications on your WHS, which may have altered the IIS configuration on the server?
    Is there a 3rd party firewall installed locally on the clients, which might block necessary ports?
    Best greetings from Germany
    Olaf
    Wednesday, October 14, 2009 6:51 PM
    Moderator
  • Olaf,

    Thanks for the response.

    I've rebooted the server several times but I will do it again.  If no change, I'll address with your suggestion. 

    No additional apps have been installed on WHS that I am aware of.  It was installed from the OEM disk. 

    There could be a client side firewall issue that popped up without my knowledge.  However, I've got one client recognized but not the other.  Weird. 

    Why would one of them connect but not the other?

    Greetings from Texas USA.
    Wednesday, October 14, 2009 8:08 PM
  • I removed the Home Server Client software on the client.  I deleted the remaining files manually in Program Files.  Restarted.  Released the IP address for the client PC and renewed.

    I accessed the setup.exe file on the server shared folder / software.  I tried installing but no success.  It brings me to the window where I enter the password, then after I enter the password, it tells me that "This operation cannot be completed at this time."  Same problem.

    What's ironic is that I can see files in the server shared folder from the client PC with no issues.  BUT my client PC can't make the connection to the WHS to establish a client account.

    I tried turning the firewall off on the client pc.  No difference. 

    I'm up for attempting some more suggestions.

    Thanks.


    ALSO , I noticed that the Home Server Connector Software on the server that I tried to load is connector software for windows home server power pack 1.  I know that my home server has been updated to power pack 2.  Could this be the issue?  An old version of the connector software?  If so, where can I download a new copy?

    NARROWING IT DOWN : So the problem has to be with the client computer and not the WHS.  Especially since other computers are successfully finding and connecting to the WHS and I can see them indicated as being connected on the WHS console.  From the desktop of the client PC that I'm having trouble with, I can hit my WHS server at the IP address http://<myservername>.  No problems there.


    Thursday, October 15, 2009 3:04 AM
  • Did you alter the hosts file on that client at any time in the past? If so, it could be that the IP address in that file does no longer match the new installation.
    Best greetings from Germany
    Olaf
    Thursday, October 15, 2009 5:33 PM
    Moderator
  • Olaf, as far as the host file, I don't think I did anything different with this client versus another.  That's the strange part.  I've got 3 other clients recognized on the WHS.  1 new one and two old ones that were established before the restore of the WHS machine.  They are all on the same network, same router.  The client computer hasn't moved.  This particular client can't see the WHS machine but the other ones can. 
    Thursday, October 15, 2009 8:24 PM
  • Something could also have changed lately on the server.
    If you added the other clients in the past, and the failing client just now, this may indicate such an issue. Logon to your server locally and check the Event logs for error messages and warnings (especially also such about DCOM issues).
    Best greetings from Germany
    Olaf
    Saturday, October 17, 2009 9:26 AM
    Moderator
  • Olaf,

    Thanks for the suggestion but I don't think we're looking in the correct direction. 

    I've added a new client after the rebuild and its backing up fine.  This client is one that existed on the WHS before the rebuild.  Two other machines, one laptop and one desktop existed as clients on the WHS prior to the rebuild and they are now backing up fine too.  The problem MUST be on the client itself.

    The problem client hasn't been altered.  It worked before, but its not working now.  Other machines that were working before ARE working now.  A new client is working now.  I'm going to get two machines side by side and compare.  Let's hope I find something.
    Sunday, October 18, 2009 8:44 PM
  • Hey Gentlemen,

    I still can't get this 3rd client PC to connect to the WHS.  It's been over a month and I don't know what to do.  I can view the server from the problem client.  I can use RDP or the http://myservername:55000 and its there.

    Three other PC's aren't having this trouble.  Please help me. 
    Thursday, November 5, 2009 9:01 PM
  • Hi,
    please step through the FAQ How to Troubleshoot Network Connection Problems with Windows Home Server, if you find something, which may be relevant for that client.
    Maybe you have altered something on the client in the past (i.e. edited the hosts file, which does not longer match - it should be easy to check its contents by opening it in notepad).
    Post also the output of ipconfig /all on the client.
    Best greetings from Germany
    Olaf
    Thursday, November 5, 2009 10:13 PM
    Moderator
  • Someone suggested I flush the dns cache and refresh the connector for the same problem - it worked.
    Start, run, cmd
    ipconfig /flushdns
    exit
    then http://myservername:55000 to update the connector
    good luck
    Saturday, November 28, 2009 9:32 PM