locked
hard drive issues- any help appreciated RRS feed

  • Question


  • I have built an WHS box that includes 4*1TB WD greenpower drives
    .  The rig seems to function perfectly until I start a backup or large copy, at which point it crashes.  Memtest and windows hard drive disc scans seem to find no problems.  Any suggestions?

    Sunday, July 13, 2008 8:18 PM

Answers

  • I had the very same problem and as soon as I replaced the green WD drives with regular disks, all my problems went away.
    It seems to me that the variable speed of the green
    drives cannot be handled by WHS. What a pity.

    Thursday, July 24, 2008 7:21 PM

All replies

  • I have heard conflicting reviews on the greenpower drives with regards to their performance.

     

    Monday, July 14, 2008 3:02 AM
  • I am a bit stumped.  WHS installed with no problems and the system seems to be functioning fine.  Hard drive tests from both windows and western digital indicate thst the drives are all functioning well.  But when I try to do a back-up, or to copy a large amount of data from other computers onto the server, it freezes up after 2-3GB.  The event log shows a repeating pattern of 5-7 type 5 errors, separated by type 11 errors.  These seem to point to a hard drive cable or hard drive problem, but I've taken the cables off and replaced them and they seem to be tight.

     

    I suppose I will have to wipe the WHS install and try to reinstall it, perhaps on only 2 of the 1TB drives, and see if that makes things better.  Anyone out there got any ideas?

     

    Monday, July 14, 2008 3:21 AM
  • Network congestion maybe? You could be timing out, Is there anything between your computer and the WHS, such as a router? Are you doing anything with your computer (like using uTorrent) that can interrupt the data stream?
    Monday, July 14, 2008 8:37 AM
  • Have you tried to reconfigure backup on the computer you are trying to backup? This will tell you if the problem is on the computer you're trying to backup. I had a situation where I tried to reconfigure backup and it would hang and then report the computer wasn't responding. I ran error checking and selected fix errors on the computer I was trying to backup which fixed several errors. I was then able to reconfigure backups with no problem.

     

    Monday, July 14, 2008 12:33 PM
  • Stalling at 2 to 3GB sounds to me more like a congestion problem, either through the router, or maybe the motherboard. When you built the WHS system, you did use Server 2003 drivers for the NIC, hard drives etc?

     

    Colin

     

    Monday, July 14, 2008 3:42 PM
  • I have checked the drivers for the ethernet, hard drives etc and they seem to be fine.  I have also tried loarding information through a usb connection, and had no problems.  So the problem certainly seems to be something to do with my router- but what doesnt make sense is that the other two computers (and one xbox) all seem to be having no problems.  Since I run into the same problem trying to copy information from either of the other computers, it has to be something about how the server interacts with the router, but I am still struggling to suss it out...

     

    Tuesday, July 15, 2008 11:30 PM
  • Well at least part of the problem was driver-related.  Got new chipset drivers from the VIA website (asus website and drivers that came with MB weren't doing it" and that fixed my disc accessing errors.  I am still getting crashes whenever I try to do a backup or copy files to the server over the network but now they are "hash map" errors...

    Sunday, July 20, 2008 5:23 PM
  • I had the very same problem and as soon as I replaced the green WD drives with regular disks, all my problems went away.
    It seems to me that the variable speed of the green
    drives cannot be handled by WHS. What a pity.

    Thursday, July 24, 2008 7:21 PM
  • Do you have Power Pack 1 installed?  I think the changes made to the Drive Extender would perhaps help your problem which I am guessing is a swap file issue.
    Friday, July 25, 2008 3:40 PM
  •  

    I do have it installed, unfortunately it has not helped.

    Friday, July 25, 2008 3:45 PM
  • I wonder why this is?  I am using a WD 1T "green" drive as my system drive.  I regularly move .ISO video files to the WHS.  These files often are about 8GB in size. 

    Using a "green" or variable speed HDD as the system drive is maybe not the choice I would make again but it has not caused me the problems mentioned above.  I noticed a major performance improvement in copying files to the WHS when I installed the PP1 beta.  Reading the documentation for PP1 suggested to me that there was a change in how DE was handling incoming filesthat was being manifested by the preformance improvement I observed.  

    One last thought - have you tried TeraCopy?
    Friday, July 25, 2008 4:14 PM
  • I have not tried teracopy- but will try it when I get home.

     

    This may be more information than you want, but I am using the asus a8v-x motherboard because I thought it was worth the $45 to get that board new in an attempt to use an AMD 939 4600+ CPU and RAM that I had leftover.  I have struggled with this long enough and have ordered a new 780G motherboard, 4850e CPU and RAM.  I am just going to rebuild the rig with those all new components and see if things are any better.

     

    I don't know for sure, but suspect that, even though I have the latest VIA SATA drivers, the controller on this 939 motherboard may be the issue.  Western Digital diagnostics show "cable" errors on all four drives.

     

     

    We'll see.
    Friday, July 25, 2008 6:14 PM