locked
Required dotnet version for SyncToy? RRS feed

  • Question

  • I have limited disk space and speed so had removed all of dotnet using the removal tool.  Windows update showed all critical updates were installed on my XP PRO system (SP2).  I then installed SyncToy 2.0 and it installed dotnet 2.0.  No problem there, but then Windows Update says it needed a critical update of dotnet 3.0 & 3.5 and wanted to download and install a 248MB file!!!  But SyncToy works fine with dotnet 2.0.  Secunia also said that dotnet 2.0 had a needed security update, but it gave me a link to KB928365 on the MS site just for dotnet 2.0 that was 15 MB.  This still is a huge size for just a security update, especially since SyncToy is a much smaller, reasonable size.  But at least it is only 6% of the size that Windows Update wanted to install.  After installing the KB928365 Secunia says that the security problem was fixed.  However, Windows Update still says I must install the critical update for dotnet 3.0/3.5 of 248MB!

    Do I have a security problem after installing the KB file I did?

    If not, why does Windows Update want me to install this huge file?

    Does SyncToy really require several hundred MBs of files to be installed to work securely, or will it work securely with dotnet 2.0, that it installed?

    Thank you for your help.  I love SyncToy, but if it needs hundreds of MB of support files, it makes it not so useful.
    Saturday, February 7, 2009 6:29 AM

Answers

  • Hi -

    Sorry it has taken me time to get back to you but this is a specific .net 2.0 framework issue. SyncToy needs .net 2.0 to work and you would need to ask on the .net developments forums to find out why that specific KB needs to be installed to ensure that there is no security risk involved.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, February 25, 2009 11:03 PM

All replies

  • SyncToy only needs the .net framework 2.0 to work correctly. We do not depend on 3.0 or 3.5

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Tuesday, February 10, 2009 11:42 PM
  • Thank you for our reply, Deepa.  As soon as I installed SyncToy (and it installed dotnet 2.0) Microsoft Update tells me there is a high priority critical update that I must install dotnet 3.0 and 3.5.  Why would MS Update say this if it is not needed?  I installed an update for dotnet 2.0 and Secunia says I have no security problems now, but Microsoft still says I do, but I don't want to install the 248MB file that apparantly is not needed.  Why does MS Update report this security problem incorrectly?  I had no high priority updates listed before installing SyncToy.
    Wednesday, February 11, 2009 3:16 AM
  • Hi -

    Does the critical update for 3.0/3.5 have a KB article with that ? I do not know why Microsoft would mandate an update to a newer CLR version. Any critical update to a particular CLR version is released as Service Packs. If you can send me the KB article I can take a look.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, February 11, 2009 5:48 PM
  • Yes, the number is KB951847 and it has a file size of 248.3 MB and is listed in Microsoft Update as “High Priority”.  I didn't understand why it would ask for this either.  After installing SyncToy 2.0 I did download and install a MS security patch for dotnet 2.0 (Secunia gave me the Microsoft link for this file).  After installing that MS patch Secunia now says that there are no security risks on my computer, but MS Update does say that it needs the huge file for dotnet 3.0/3.5 still.  Makes no sense to me.  Thanks for looking into this for me.
    Wednesday, February 11, 2009 7:57 PM
  • Hi -

    Sorry it has taken me time to get back to you but this is a specific .net 2.0 framework issue. SyncToy needs .net 2.0 to work and you would need to ask on the .net developments forums to find out why that specific KB needs to be installed to ensure that there is no security risk involved.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, February 25, 2009 11:03 PM
  • Why can't it run on dotnet 4.0?  dotnet2.0 is like y2k technology.  Thats like asking to run an app on IE6!  Microsoft please update it.  Its an embarassment.
    Sunday, November 11, 2012 8:25 AM