locked
UM integration withou Exchange Sp1 RRS feed

  • Question

  • Hi,

     

    I would like to try OCS & UM integration without installing ExchangeSp1 (we have exchange 2007 in production server, and i think it's not safe to install Sp1Beta)

    I read in another thread that on Beta2 documentation there was an explanation on how to do this "manually" without the script.

     

    Is there anyone who still have Beta2 docs?

     

    Thanks in advance,

     

    Mick

    Wednesday, June 20, 2007 8:39 AM

Answers

  •  

    Hi all,

     

    Find below the steps without SP1. But the I'll think there's a problem in granting OCS permission to read UM AD Objects.

     

    Following object does not exists

    (b) In the console tree, expand CN=Services, CN=First Organization, and CN=properties.

    (c) Right click then CN=Securities, and then click Properties.

    This should be

    (b) In the console tree, expand CN=Services, CN=Exchange Server.

    (c) Right click then CN=First Organization, and then click Properties.

     

    And

    (g) Right-click CN=dialplan container, and then click Properties.

     

    Should be

    (g) Right-click CN=UM dialplan container, and then click Properties.

     

     

    But I'm not succeeding in correctly setup Exchange UM with OCS without SP1. Anyone else?

     

    ocsumutil.exe runs fine

    and the Exchange UM Integration Utility shows also no errors.

     

    When calling Voicemail from OC; I'll get in ExUMRouting logging: Dial plan DefaultLocation.artiliumdemo.local is empty. No servers are defined.

    And in SIPStack.txt logging: Dial plan has no servers

     

    Regards,

    Dieter

     

     

     

    That's an excerpt from OCSVoIpGuide.doc private beta.

     

    1.       Create an Exchange Server UM IP gateway for the Communications Server pool. If the pool is an Enterprise Edition Pool, you must also create a gateway for each Front End Server.

    New-umipgateway -name  <OCS server gateway name>  -address  <fqdn of OCS server>

    2.       Create a huntgroup that matches each dial plan you created for Office Communications Server with each gateway that you created in step 4. The huntgroup pilot identifier should be the name of the dialplan created in step 1.

    New-umhuntgroup  -name  <huntgroupname>  -Pilotidentifier  <name of dialplan created in step 1>  -umipgateway  <OCS server gateway name> -umdialplan  <name of dialplan created in step 1>

    3.       Grant Communications Server permission to read UM Active Directory objects.

    Important

    Before performing this step, Communications Server and Exchange Server UM must either be deployed in the same forest, or if they are in different forests, a one-way trust must have been created from the Exchange Server forest to the Communications Server forest.


     

    To perform this step, you must use ADSI Edit, a tool that is installed with Windows Support Tools. If you do not already have Windows Support Tools installed, install them on the Exchange Server UM server before continuing. For installation instructions, see Install Windows Support Tools on the Microsoft Web site (Install Windows Support Tools on the Microsoft Web site (http://go.microsoft.com/fwlink/?LinkId=62270).

    To grant Communications Server permission to read UM Active Directory objects

    (a) Click Start, and then Run, and then type ADSI Edit.

    (b) In the console tree, expand CN=Services, CN=First Organization, and CN=properties.

    (c) Right click then CN=Securities, and then click Properties.

    (d) On the Security tab click Add.

    (e) Add RTCComponentUniversalServices to the list of group or user names, and then click OK..

    (f)  Click OK to close the Securities property sheet.

    (g) Right-click CN=dialplan container, and then click Properties.

    (h) On the Security tab click Add.

    (i)   Add RTCComponentUniversalServices to the list of group or user names, and then click OK.

    (j)   Click Advanced, and then click the Effective Permissions tab.

    (k) In Permission entries, select RTCComponentUniversalServices and click Edit.

    (l)   Click the Properties tab.

    (m)                In Apply onto, select This object and all child objects, and then click OK.

    (n) Click OK two more times, and then close ADSI Edit.

     

    Wednesday, June 20, 2007 2:59 PM

All replies

  • I run the OCS class across Europe and we successfully connect OCS to UM - without SP1. This is not supported in production, but it works in testing.

    Why not try it and see if it works?

    Naturally, be careful when using beta software (OCS) on a production network.


    Wednesday, June 20, 2007 10:15 AM
  • Thanks for your reply.

     

    The problem is that I can't find docs on how to to it manually without the script in Exchange Sp1.

     

    We have Ocs2007 beta3 public working, Enabled UM on Exchange 2007 server. The problem is that Ocs2007 can't see Exchange UM.

     

    I need to know how to manually configure UM & OCS to see each other.

     

    Thanks

    Mick

    Wednesday, June 20, 2007 10:20 AM
  • I'd like to second this request. I'm also wanting to set up OCS/Exchange UM integration, but without deploying sp1 (because I don't have access to it) The Public Beta documentation only includes instructions that involve running the scrpts that come with sp1 for integration.

     

    I understand that the Beta 2 documentation contained instructions on how to do this, so perhaps someone who has a copy of that might be able to post the details from the appropriate section.

    Wednesday, June 20, 2007 12:49 PM
  •  

    Hi all,

     

    Find below the steps without SP1. But the I'll think there's a problem in granting OCS permission to read UM AD Objects.

     

    Following object does not exists

    (b) In the console tree, expand CN=Services, CN=First Organization, and CN=properties.

    (c) Right click then CN=Securities, and then click Properties.

    This should be

    (b) In the console tree, expand CN=Services, CN=Exchange Server.

    (c) Right click then CN=First Organization, and then click Properties.

     

    And

    (g) Right-click CN=dialplan container, and then click Properties.

     

    Should be

    (g) Right-click CN=UM dialplan container, and then click Properties.

     

     

    But I'm not succeeding in correctly setup Exchange UM with OCS without SP1. Anyone else?

     

    ocsumutil.exe runs fine

    and the Exchange UM Integration Utility shows also no errors.

     

    When calling Voicemail from OC; I'll get in ExUMRouting logging: Dial plan DefaultLocation.artiliumdemo.local is empty. No servers are defined.

    And in SIPStack.txt logging: Dial plan has no servers

     

    Regards,

    Dieter

     

     

     

    That's an excerpt from OCSVoIpGuide.doc private beta.

     

    1.       Create an Exchange Server UM IP gateway for the Communications Server pool. If the pool is an Enterprise Edition Pool, you must also create a gateway for each Front End Server.

    New-umipgateway -name  <OCS server gateway name>  -address  <fqdn of OCS server>

    2.       Create a huntgroup that matches each dial plan you created for Office Communications Server with each gateway that you created in step 4. The huntgroup pilot identifier should be the name of the dialplan created in step 1.

    New-umhuntgroup  -name  <huntgroupname>  -Pilotidentifier  <name of dialplan created in step 1>  -umipgateway  <OCS server gateway name> -umdialplan  <name of dialplan created in step 1>

    3.       Grant Communications Server permission to read UM Active Directory objects.

    Important

    Before performing this step, Communications Server and Exchange Server UM must either be deployed in the same forest, or if they are in different forests, a one-way trust must have been created from the Exchange Server forest to the Communications Server forest.


     

    To perform this step, you must use ADSI Edit, a tool that is installed with Windows Support Tools. If you do not already have Windows Support Tools installed, install them on the Exchange Server UM server before continuing. For installation instructions, see Install Windows Support Tools on the Microsoft Web site (Install Windows Support Tools on the Microsoft Web site (http://go.microsoft.com/fwlink/?LinkId=62270).

    To grant Communications Server permission to read UM Active Directory objects

    (a) Click Start, and then Run, and then type ADSI Edit.

    (b) In the console tree, expand CN=Services, CN=First Organization, and CN=properties.

    (c) Right click then CN=Securities, and then click Properties.

    (d) On the Security tab click Add.

    (e) Add RTCComponentUniversalServices to the list of group or user names, and then click OK..

    (f)  Click OK to close the Securities property sheet.

    (g) Right-click CN=dialplan container, and then click Properties.

    (h) On the Security tab click Add.

    (i)   Add RTCComponentUniversalServices to the list of group or user names, and then click OK.

    (j)   Click Advanced, and then click the Effective Permissions tab.

    (k) In Permission entries, select RTCComponentUniversalServices and click Edit.

    (l)   Click the Properties tab.

    (m)                In Apply onto, select This object and all child objects, and then click OK.

    (n) Click OK two more times, and then close ADSI Edit.

     

    Wednesday, June 20, 2007 2:59 PM
  • Thanks a lot!

     

    I'll try asap and then I'll let you know!

     

    Bye

    Wednesday, June 20, 2007 3:29 PM
  • Hi,

     

    can you please send me the full file " OCSVoIpGuide.doc " at ilpeck@hotmail.com ?

     

    Thanks in advance,

    Mick

    Thursday, June 21, 2007 6:01 AM
  • Hi,

     

    finally it works :-)

     

    Thanks for sending me the guide! I used part of your guide and part of latest beta3 public guide.

     

    The first time i used Exchange Console to configure dial plans in UM but this way you can't specify some options and OCS will not see the dial plan.

     

    I deleted them and configured everything from Managemente Shell and everything worked!

     

    Thanks again!

     

    Mick

     

     Here is the list of command i used to create dialplan, associate it with server, enable mailbox, create gateway, create huntgroup and create autoattendant.

    Code Snippet

    new-umdialplan -name umDPName -UriType "SipName" -VoipSecurity "sipsecured" -NumberOfDigitsInExtension x -AccessTelephoneNumbers “xxx”

     


    $ums=get-umserver;
    $dp=get-umdialplan –id umDPName;
    $ums.DialPlans +=$dp.Identity;
    $ums | set-umserver


    enable-ummailbox -id mymailbox -ummailboxpolicy "default policy" -Extensions xxx -SIPResourceIdentifier "myaccount@domain" -PIN xxxxx

    New-umipgateway –name gwname –address gwaddress

    New-umhuntgroup  –name  hgname  -Pilotidentifier  dialplanname  -umipgateway  gwname -umdialplan  dialplanname

    New-umautoattendant –name attendantname –umdialplan dialplanname –PilotIdentifierList name,number

     

     

     After this i just used ocsumutil to create autoattendand contacts and everything worked!

    Monday, June 25, 2007 10:44 AM
  • I tried to associate dial plan created from shell with server but got error message when using set-umserver "the dial plan does not comply with the security setting of the other dial plans associated with this server".  I have not installed SP1.  I used Sipsecured for voipsecurity setting.  The other dial plan was created from Exchange Mgmt Console & connects to my ip pbx.  I don't know what the implication is of sipsecured.  Any suggestions? 

    I assume it's still possible to integrate without SP1 installed & without running exchucutil.ps1 script?  Or is the concensus to wait until SP1 is released.

    Lastly do you recommend enabling um from shell vs. mgmt. console?

    Thanks in advance, Fred
    Tuesday, September 25, 2007 4:55 AM