locked
Marvell Yukon 88E8972 NIC driver not found during Restore Cd startup RRS feed

  • Question

  •    I have just installed the Trial version of WHS and cannot load the Marvell Yukon 88E8072 NIC driver on the client machine when trying to restore the system via the restore boot cd. I have tried using the drivers from the clients backup file from the server (Two different driver versions from two seperate backups) and I have also downloaded the driver from Window Update Catalog. None of these drivers are recognised when put on the USB flash drive or FDD. It finds the Intel Wireless adapter but not the Marvell one.... Maybe I should just stick to Acronis or similar to backup the PC...

      If anyone can think of a suggestion to help solve this it would be great. Thanks.

    • Edited by BOTR Thursday, April 22, 2010 1:25 AM corrected errors
    Wednesday, April 21, 2010 5:22 AM

All replies

  • Are you trying to restore a 64 Bit Operating System?  If so you will need to load the 32-bit drives for your network card.


    --
    Wednesday, April 21, 2010 9:41 AM
  • Are you trying to restore a 64 Bit Operating System?  If so you will need to load the 32-bit drives for your network card.


    --

    Hi, It is a standard XP Pro SP3 installation. 32 bit. I was thinking of recommending WHS s to a friend for their small business. Now I have had second thoughts seeing how something so simple as loading a network driver can fail so easily. No support seems to be available except here. Also WHS is sold as an OEM so MS probably does not have to do any support for it.... just pass it on to the supplier...
    • Edited by BOTR Wednesday, April 21, 2010 6:13 PM typos
    Wednesday, April 21, 2010 6:12 PM
  • Hi,

    The problem is with cheap chipset vendors like SiS, Marvell and RealTek who produce PHY/MAC solutions *down* to a price.  Unfortunately they fix problems that shouldn't be present in hardware through software fixes and as a result they can never achieve a unified driver approach and as you can see in these forums most network problems are caused by rubbish hardware.

    Loading a network driver is not 'so simple' - yes Windows Home Server is OEM, if you don't want (or can't) provide the support yourself then you would be best advised to buy a complete solution from the like of HP, Acer, Lenovo or Fujitsu.

    You might have better luck if you get the model number of your Network Card right - I only got one hit in google - in fact 88E8972 is unique to this thread did you mean 88E8072?

    Did you try drivers from for Vista? As the restore CD is based on Vista:

    http://www.marvell.com/support.html

    Cheers,
    Al


    --
    Wednesday, April 21, 2010 7:20 PM
  • Yes it is 88E8072. Was half asleep when making the initial post. I will try the vista driver and see if that helps. I didn't see anything in the WHS help file about using Vista drivers... or in any FAQ...

    It is sad to know that Toshiba would use such garbage network components in their systems.

    Wednesday, April 21, 2010 7:44 PM
  • I think what originally happened is that when testing the recovery CD they just hit XP drivers that would load in the Vista recovery environment - with so many hardware configurations possible it's very hard to test every possible scenario. 
    --
    Wednesday, April 21, 2010 7:51 PM
  • Hi again,

     Tried the vista driver and it recognised it,

     however I get the message :- "An unknown network error has occurred during PC Restore.

    Please verify that your network connection is active and the your Windows Home Server is powered on."

    This has happened on two attempts so far, the error message seems to appear at random points during the restore setup pages.

    Anyway thanks for the suggestions. I will try it on another PC now to see how it goes.

    Wednesday, April 21, 2010 8:22 PM
  • BOTR, try using the x-files version 1.2 of the restore cd; it has many more drivers and has saved me and others in this forum with the same problem....... http://xfiles.breakinghomeserver.com/X-Files/ClientRestore/1.2/ 

    Also check out this thread.... http://social.microsoft.com/Forums/en-US/whssoftware/thread/14499b06-eabc-463b-9d1c-ca526f2c7efb 

    Wednesday, April 21, 2010 8:33 PM
  • Hi,

    Thanks for that, looks promising. Downloading them now.....

    Wednesday, April 21, 2010 8:48 PM
  • fwki, I downloaded and tested it, no luck with the drivers though. Still the same issues as I mentioned before. Thanks anyway.

    Wednesday, April 21, 2010 11:34 PM