FTP Hangs on "Getting Contents of Folder" RRS feed

  • Question

  • Hi

    I am trying to set up FTP so I can back up computers and access files over WAN. 

    I have followed Microsoft's guide to setting up the FTP sites here: 

    Have double checked and all is correct. 

    When I try and access the FTP site from an external point it logs in however times out on "Getting contents of folder"

    I have opened up ports in the WHS firewall and in my router firewall. 

    I have also tried using Filezilla with exactly the same result.

    When I try and log in from a LAN pc or localhost the username and password are not recognised. 

    Am I supposed to set up separate usernames and passwords?

    Not sure where to go from here.


    Tuesday, December 8, 2009 6:39 PM

All replies

  • Joe, using your server as an FTP server isn't supported. You'll be much more secure, and much better off, using the remote access web site.

    That said, it should be possible, as long as you don't try to interfere with the Windows Home Server shares. You can use the Windows Home Server users, however. My recommendation would be to start with anonymous access, and make sure your firewalls are all set to allow FTP traffic.

    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by kariya21Moderator Tuesday, December 29, 2009 4:38 AM
    • Unproposed as answer by joewalch Tuesday, December 29, 2009 9:15 AM
    Tuesday, December 8, 2009 9:13 PM
  • This should really be possible. Anonymous access does not work nor does log in access?
    Tuesday, December 29, 2009 9:16 AM