locked
CRM and ADO.NET 8080-8082 Version Incompatible? RRS feed

  • Question

  • Hello all I am an IT Admin for Gaylor Inc.

    We recently have implemented Microsoft CRM. Immediately afterward we have noticed that any computer with CRM, makes one of our other programs "Toolwatch"(a tool tracking program) unusable. When we try to login into Toolwatch we get this error:

    "The application is trying to load native components of version 8080 that are incompatible with ADO.NET provider of version 8082. Incompatible"

    Toolwatch i believe is run in an IE environment. I have included a screenshot of programs installed/version of sql compact and the error. I could really use some help trying to figure out what is going on here I’ve been researching it for a long while and still am coming up blank. Thanks!

    • Moved by Bob Beauchemin Monday, September 12, 2011 2:19 PM Moved to a more relevent forum (From:.NET Framework inside SQL Server)
    • Edited by JClarkAdmin Monday, September 12, 2011 2:24 PM
    Monday, September 12, 2011 2:17 PM

All replies

  • Monday, September 12, 2011 2:23 PM
  • You may need to upgrade the x64 version of SQL Compact 3.5 to version 3.5.8082.0 with the 
    http://support.microsoft.com/kb/2289547/en-us
    Let me know if this solves your problem.
    I hope this helps.

    Amreek singh Senior CRM Consultant CDC Praxa Sydney,Australia http://mscrmshop.blogspot.com/
    • Proposed as answer by Amreek Singh Tuesday, September 13, 2011 1:35 AM
    Tuesday, September 13, 2011 1:35 AM
  • Hello, I verified that the x64 and x86 versions of SQL Server compact were the same version (3.5.8082.0) and still see the same error message.

    I even went as far as removing CRM (my user doesn't need it), cleaning the registry, rebooting the computer and then reinstalling the SQL Server Components fresh. Still the same error appears.

    To be effecient I have gone ahead and sent this user a new computer with just ToolWatch loaded and have had no issues. Something definitely happened when CRM was added to this machine.

    Although my issue is technically resolved, due to my in-bred IT-Control-Freak Mentatlity I want to know why!!!!

    Anyone have any ideas?

    Wednesday, November 6, 2013 2:12 PM