locked
Distribution group service could not perform this action-Contact your sys admin

    Question

  • Running OCS2007 r2.   Had to shut down our ocs server yesterday to install an expansion SAN.  Brought the server up tested and all was fine.  We have added all our users in a group to everyones contact list on OCS.  Now when we try to access those groups under the contact list in OCS it gives us the following error

    "Distribution group service could not perform this action, Contact your sys admin." 
    Also getting another error message, 
    "cannot syncronize with the corporate address book". 
    Although we can access individuals on OCS and can send and recieve as well.  Any suggestions?

    TIA
    • Moved by Gavin-ZhangModerator Monday, October 26, 2009 10:30 AM related the abs (From:OCS Setup & Deployment)
    Monday, October 19, 2009 5:01 PM

Answers

  • Gavin,

    thanks for the reply, i finally had to contact MS support.  They were able to resolve the issue.  They had me go into IE, under IE I went to the internet options, advance tab, then to the security check boxes and I unchecked Check for server certifcate revocation.  According to the MS support that is a known issue.  I then added the setting in one of my Group Policies and now all my users OC is working correctly. 

    Thanks,
    DC
    • Marked as answer by DougCC Monday, October 26, 2009 7:52 PM
    Monday, October 26, 2009 7:51 PM

All replies

  • Monday, October 19, 2009 5:15 PM
  • when I login into the communicator web access it does not error out, I can open up the group list without a problem.  But when I still try to access OCS internally I get the errors and cannot open the group in ocs.  Any ideas?  Very frustrating!
    Monday, October 19, 2009 10:39 PM
  • Hi,

    Ok, things seems to be a bit confusing here right now DougCC. Do provide the followings so we can help you further:

    1. What was the exact changes that you'd made before the issue encountered?
    2. Try removing the Distribution Groups and adding them

    I'll putting the Address Book synchronization error aside as I suggest to solve the problem 1 at the time, if is related, it should be solved along this thread :)

    Cheers.


    James Ooi MCTS - Office Communications Server 2007 - Blog:http://JamesOSW.Wordpress.com
    Tuesday, October 20, 2009 10:59 AM
  • James thanks for the reply.  All that was done with that server was a shut down and then a start up so we can install an additional  SAN.  It worked for awhile after the restart.  I have removed and re-added the groups with no luck.  Any other suggestions?

    Thanks again
    Tuesday, October 20, 2009 3:38 PM
  • Hi
    Some suggestion for you, per your description, those issue usually caused by invalid certificate assigned on the default web site on the office communication server front-end.

    So, ensure that corrected the certificate on the web site to be with the subject name of the pool. communicator client use the pool name by derault to download the address book through the web site over an ssl connection. 
    And you can reassign download certificate to the IIS default website and test it again.
    Then you can run the Absserver.exe -syncnow on your FE server.
    And check the RTCComponenetService account's password is expired or not.

    Some other related link you can refer to
    http://support.microsoft.com/kb/940779/ 
    http://support.microsoft.com/kb/938286/ 
    http://support.microsoft.com/kb/939530/
    http://support.microsoft.com/kb/937314/

    Regards!

    • Marked as answer by DougCC Monday, October 26, 2009 7:51 PM
    • Unmarked as answer by DougCC Monday, October 26, 2009 7:52 PM
    Monday, October 26, 2009 10:29 AM
    Moderator
  • Gavin,

    thanks for the reply, i finally had to contact MS support.  They were able to resolve the issue.  They had me go into IE, under IE I went to the internet options, advance tab, then to the security check boxes and I unchecked Check for server certifcate revocation.  According to the MS support that is a known issue.  I then added the setting in one of my Group Policies and now all my users OC is working correctly. 

    Thanks,
    DC
    • Marked as answer by DougCC Monday, October 26, 2009 7:52 PM
    Monday, October 26, 2009 7:51 PM
  • Did you do this on the OCS server or the client? Sounds like the client, but wanted to confirm.
    Brian Day, Overall Exchange & AD Geek
    MCSA 2000/2003, CCNA
    MCTS: Microsoft Exchange Server 2010 Configuration
    LMNOP
    Monday, November 23, 2009 5:05 PM