locked
Corrupted Backup from Windows 7 Home Premium Laptop RRS feed

  • Question

  • I have a home server with PP3 on it, and HP dv2z laptop with windows 7 home premium 64bit on it and i wanted to replace the drive in the laptop with an SSD.   I have had regular backups of it with no failures indicated anywhere in the console.  So I popped in the new drive, booted off the restore CD, got started with the restore, and while it was restoring it gave me the error:

    I/O error reading clusters xxxx through xxxx on the server.
    Do you want to Continue?

    I just hit continue, and then as it continued onward, the error popped up again, and again.  Each time the xxxx was a different number and I believe it always indicated a single sector.  Just to see what would happen, I kept hitting continue until the restore finished.  I don't know how many errors it was but probably 100 or so.  After reboot, windows booted fine off the new drive, but then i noticed certain applications were not working, which were fine on the original disk.   So it seemed the data was in fact missing for those sectors. 

    So I figured I'd try from a clean slate.  I popped in the original drive, removed the laptop from the homeserver backups, ran backup cleanup, and backup repair.  I reinstalled the connector on the laptop, and ran a chkdsk there too which said everything was fine.  So i re-added the laptop to the homeserver, and ran a manual backup.  Once completed, I tried the restore again, with the same errors.   I also tried putting the new drive in a different pc (which long ago I restored from a backup of itself with no problems) and restoring the laptop backup there to the drive, with the same results.  I then attached the new drive into a working pc, mounted its backup using the connector, and tried copying the files to the drive that way.  Sure enough part way through it failed saying it couldn't find the data for a sector.

    At this point I am unsure how to proceed.  I am also very concerned about all my backups and their data integrity.

    Any suggestions?
    Tuesday, December 22, 2009 8:33 PM

All replies

  • I assume from your description, that the problem is settled on the server.
    It is configured in a way to not panic the user too fast (which in my opinion is wrong in case of discovery of bad sectors or file system errors).
    To verify this, please login locally on the server as Administrator with the console password and check the event viewer in Control Panel/Administrative Tools.
    Can you see any NTFS related error messages here? If so, a failing disk in the server with damaged or hard to read sectors in the area of the backup database files can be the reason.
    If so, you could try How to check all the drives in your server for errors (which would usually not be able to fix already existing problems with corrupted files) and consider to replace the affected disk as soon as possible.
    Best greetings from Germany
    Olaf
    Wednesday, December 23, 2009 2:56 PM
    Moderator
  • I took your advice and followed the instructions on the linked page to run chkdsk on all my volumes.  No errors or bad sectors were found.  So that does not seem to be the problem.  At this point I have to assume that the backup functionality is worthless for me, which is basically the only thing I use WHS for.  I'm very disappointed, as I had previously held WHS in high esteem, and have recommended it to many family members and coworkers.  Is there anything else I can look at to try to fix this problem, or provide more information to help diagnose it?  I know I'm not the only one with the problem as someone else posted the same day as me with the exact same symptoms.
    Saturday, December 26, 2009 2:43 AM
  • Same problem here... With several people having this issue in recent days is it possible that it's related to a recent WHS update?

    About 3 weeks ago, I was able to successfully restore this particular PC that's now giving me the error...
    Wednesday, December 30, 2009 5:30 AM
  • I've been using WHS since it was Beta.  Until yesterday, I had never had this problem in 20+ restores.  Yesterday I had a problem with a drive and had this message pop up 8-10 times while trying to recover. 

    I'm hoping more complaints of the same problem will get more response, especially if (as Matt suggests) this is a bug introduced recently.  How can I tell the status of all of my backups?  Is there a test which will tell which ones are good? 
    Wednesday, January 13, 2010 5:45 PM
  • The problem with single instance storage is, that if a part of the backup database is damaged (maybe due to a bad sector on the server disk), which contains a backup of a cluster with critical information, all backups can be affected.
    Thats why I from time to time try to open a backup in the console and if this fails, check the event logs of the server for disk related errors.
    Also usually if your backup database is broken (usually due to a hardware fault on the server or a server crash/unexpected reboot during a write operation to the backup database) and it doesn't happen in a critical moment, the best method would be to wipe the backups and start over.

    If you have enough storage somewhere, you also could perform a snapshot of the backup database with the Add-In WHS Database Backup.
    Best greetings from Germany
    Olaf
    Thursday, January 14, 2010 10:20 AM
    Moderator
  • Olaf,
    I understand what you are saying, however it I'm not convinced that is the case here.   Firstly I ran chkdsk on all drives and found no problems at all and no bad sectors.  Secondly it seems like the problem has only cropped up recently, as there were no threads about this issue, and then 2 in the same day, followed now by multiple other reports.  Thirdly, a major update (PP3) was released only weeks before.   Obviously there is no solid evidence of a new bug being introduced, but the timing does indicate a possible correlation.
    Thursday, January 14, 2010 2:58 PM
  • I'm seeing what I suspect could be a related issue with my Windows Home Server (HP MediaSmart Server, first generation).

    I like to back up my backup database to an external hard drive from time to time and keep the external hard drive at my parents' house, in case of some sort of disaster befalling both our PCs and our home server!

    To do this, I plug in a 1.5TB eSATA hard drive, which comes up as E: in the Home Server, then run:
    net stop PDL
    net stop WHSBackup
    E:
    cd backup
    FOR /F "tokens=*" %%i in ('dir /a:d /b') do SET olddate=%%i
    rmdir e:\backup\%olddate% /Q /S
    set newdate=%date:~-4,4%-%date:~3,2%-%date:~0,2%
    xcopy D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\*.* E:\Backup\%newdate% /Q /H /I /R /K /Y
    net start WHSBackup
    net start PDL
    pause
    In other words, I stop the PDL and WHSBackup services, delete the old backup from the external hard drive, then copy the backup database files from D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4 to the external hard drive.

    All very good but I got a bit slack and hadn't done a backup-backup since last July until this weekend, when I attempted to copy the nearly-1TB backup files over to my hard drive. I was doing it manually in Windows Explorer (on the Home Server through Remote Desktop) and when it got almost halfway it stopped and said file copying had failed due to an I/O error. I tried copying the one backup data file that had failed again and got the same error.

    I ran a backup repair and a backup cleanup in the WHS console and tried again, but I got the same error (at a different stage in the process).

    I'm now running the checkdisk routine set out here - http://social.microsoft.com/Forums/en-US/whsfaq/thread/b5372407-1f24-4eff-9092-069c4b4f0cee - but from what I'm reading here it may not find anything anyway.

    Either way, shouldn't WHS have something built in to monitor hard disks' health and report if there are problems interfering with the integrity of the backups?

    Otherwise, as others here have said, the backups become completely worthless and like many others WHS's seemingly brilliant backup capabilities (which I've benefitted from in the past) are the only reason I have a WHS.

    I wonder if this can be traced to any recent updates. Do people from Microsoft monitor these forums? Will they be actively investigating these reports?
    Wednesday, January 20, 2010 7:24 PM
  • I have had the same problem on restoring two different PC. I had to go back to the first back up (that I have marked to be kept) to get the restore process run without any messages about I/O errors.

    In one of the cases I tried to click continue through the whole process but was not able to start the PC after the restore (Messages about critical files missing or damaged).

    The whole point with backups with WHS feels meaningless with this behavior.

    Wednesday, February 3, 2010 10:25 PM
  • I see it's been a year.  Is there a patch for this yet?  This summer my PC bit it and all my backups were corrupted except for the original January 2010.  I decided to do a factory resent yesterday and today Vista SP2 broke a firewire driver.  So I tried a system restore but got all those I/O Error messages - on my very first backup!  First of all, currupted backups should never happen.  2nd, if it's unavoidable why can't WHS tell me something went wrong ahead of time?  If WHS can can identify a problem during a recovery then it can clearly do it before a recovery is needed.  Knowing ahead of time would allow me to delete the failed backup (better yet WHS could do it) and I could run a manual backup.  How do I make that happen?  Next what can I do to prevent all these failed backups?  I have zero confidence any backup will work and I'm wondering if my stored music is safe.

    Monday, November 22, 2010 8:01 PM
  • Darnit!

    Unfreakin real. I built a home server finally this summer. Even did a restore to a PC without flaw two months ago.

    Had a laptop PC crash and I get this I/O reading clusters errors all the way back to my first backup!

    What the frick is the point of this 'backup system' if it does not fricken work. I've been living in bliss now I am completely screwed.

    Thanks again Microsoft.

    Saturday, December 4, 2010 5:22 AM
  • I am still trying to figure out what is causing the corrupted backups.  Sometime between December 2009 and February 2010 every backup on every PC started failing.  When I attempt to restore a PC I get the message "I/O errors reading clusters A through B on the server, Do you want to continue?"  Continuing leads to many of the same messages but with different clusters - and ultimately a PC that won't boot.  Not continuing leads to an unreadable hard drive - and Windows must be completely re-installed.  Pleasee keep in mind I would not have known the backups were broken had a PC not crashed.  I'm guessing a lot of people will eventually discover their backups are no good - it can't be just me.

    After discovering the above I logged into the WHS and opened several backups.  I tried copying the "Win32" and "Program Files" folders to my desktop.  There were serveral unreadable files that I couldn't copy and had to "skip".  Only the folders from November 2009 copied entirely without a problem, and only those backups worked.  I'm speculating the unreadable file locations are the same places I would get the I/O cluster errors.

    I added a 2 TB Seagate hard drive to my WHS around Dec 2010 so I'm wondering if that might be the culprit.  Unfortunately I can't remove it to find out.

    I reinstalled the WHS OS (but left my files intact) and I'm still having the I/O errors.  To be clear, I ran a database repair from the WHS console, deleted all my backups, ran the clean-up tool, re-ran the database repair, rebooted the server, and backuped up the PCs.  All backups appeared to be bad for every PC based on not being able to open and copy folders without having to skip some files.  Interestingly the same file names are being skipped with a brand new backup.  That's when I re-installed the WHS OS and am still experiencing the same problems.

    I keep all my music on the WHS and regulary record TV shows which archive to it.  All my music plays perfectly, I've never had an issue playing a recorded TV show.  The issue seems to be isolated to PC backups - everything else seems safe.  This also tells me the Seagate hard drive is probably fine.

    Today I used a spare hard drive to backup one of my PCs and tried the WHS restore CD - confirmed, many I/O cluster errors.  Next I'll apply a jumper to the Seagate drive and see if that fixes the issues - I read somewhere that Western Digital Green drives were not behaving properly with WHS and using the jumper to reduce the transfer rate solved the problem.  The problems started before I bought a new router but I might switch back to my old router so I can officially rule that out.

    Is anyone else having this issue?  I'm hopeful someone can track down a solution before I completely give up.

    • Proposed as answer by Bri _1263_ Thursday, January 27, 2011 4:00 PM
    Monday, January 24, 2011 5:46 PM
  • SOLVED by changing the jumper setting on the hard drives from
    SATA II to SATA I (or 3.0 GB/sec to 1.5 GB/sec).

    I only had to do this on the 2 TB hard drives.  The 1 TB hard drives and smaller run fine at SATA II settings.  I am using Seagate Barracuda LPs but saw where another person had the same issue with the Western Digital Green 2 TB drives.

    Lastly, I built the WHS from an old PC that uses the Nvidia chipset on an MSI motherboard.  Perhaps its simply a driver issue - MSI and Nvidia do not specifically offer Win Server 2003 chipset drivers for that board.

    • Proposed as answer by Bri _1263_ Thursday, January 27, 2011 4:08 PM
    Thursday, January 27, 2011 4:08 PM