locked
MSCRMEmail error 26234 RRS feed

  • Question

  • Dear all,

    I have a crm error logged error that I have no idea where it comes from.

    Due to that the CMR email service is consuming all CPU and memory. After desabling the service CPU goes drastically down as well as memory.

    In even logger I have following error entry :

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="MSCRMEmail" /> 
      <EventID Qualifiers="0">26234</EventID> 
      <Level>2</Level> 
      <Task>0</Task> 
      <Keywords>0x80000000000000</Keywords> 
      <TimeCreated SystemTime="2011-11-29T08:48:57.000000000Z" /> 
      <EventRecordID>43498618</EventRecordID> 
      <Channel>Application</Channel> 
      <Computer>CRM-SRVR.solatys.local</Computer> 
      <Security /> 
      </System>
    - <EventData>
      <Data>#26234 - The E-mail Router service could not process a provider work item using assembly: Microsoft.Crm.Tools.EmailProviders.dll and class: Microsoft.Crm.Tools.Email.Providers.ExchangeOnlinePollingSendEmailProvider. System.ServiceModel.FaultException: The server was unable to process the request due to an internal error. For more information about the error, either turn on IncludeExceptionDetailInFaults (either from ServiceBehaviorAttribute or from the <serviceDebug> configuration behavior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft .NET Framework 3.0 SDK documentation and inspect the server trace logs. Server stack trace: at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter) at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc) at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message) Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) at Microsoft.Xrm.Sdk.Discovery.IDiscoveryService.Execute(DiscoveryRequest request) at Microsoft.Xrm.Sdk.Client.DiscoveryServiceProxy.Execute(DiscoveryRequest request) at Microsoft.Crm.Tools.Email.Providers.Utility.GetOrganizationUrl(Uri discoveryServiceUrl, Credential credentials, String organizationName) at Microsoft.Crm.Tools.Email.Providers.Utility.GetCrmService(Uri discoveryUri, String authMode, String userName, String password) at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run() at Microsoft.Crm.Tools.Email.Agent.ServiceCore.ExecuteProviderWork(Object providerQueueRequestObject)</Data> 
      </EventData>
      </Event>
    

     

    And in Task manager windows I have the following entries and Doctore wastson which start instances again and again

     

    Any idea what could it be or how to solve it ?

    regards

    serge

     


    Your knowledge is enhanced by that of others.
    Tuesday, November 29, 2011 9:01 AM

All replies

  • Hi Serge,

    The following article http://blogs.msdn.com/b/benlec/archive/2009/09/30/microsoft-dynamics-crm-4-0-e-mail-router-unexpectedly-stalls.aspx refers to CRM 4.0, but I think it might be the same issue for you - the application is running out of connections. 


    Paul Dowman, CRM Developer
    Tuesday, November 29, 2011 10:26 AM
  • I have follow the procedure on the link you provide and get same issue.
    As soon as I start the CRM Email service, it start to consumme 100 CPU ressource and memory and same error in eventlog

    I am running CRM 2011 so not sure id settings or file configuration are the same

    Any other idea?

    regards

    serge


    Your knowledge is enhanced by that of others.
    Tuesday, November 29, 2011 11:24 AM
  • I have the exact same situation as you Serge. Did you find a solution?

    I noticed WMI is using the most of the CPU time, maybe because of error logging.

    Thanks!

    Tamas

    Friday, March 16, 2012 7:28 PM
  • Hello Tamas,

    I spend 2 weeks trying to find this trouble and finally give up using the MSCRMail, that s a pitty because before it was working well and suddenly not.
    I am using through outlook directly now.

    But if you find something keep me post would be interrested to know.

    regards

    serge


    Your knowledge is enhanced by that of others.

    Saturday, March 17, 2012 9:18 AM
  • Wednesday, May 9, 2012 3:14 PM
  • We just resolved the similar issue by checking that service account/deployment manager account password was expired. Once set to never expired the issue was resolved. 

    Hop it helps.

    Thanks

    Monday, September 10, 2012 9:12 AM