locked
Router settings appear correct, but no remote access? RRS feed

  • Question

  • Home Server 2011

    1. I can ping xxx.homeserver.com successfully and it finds the correct ip address assigned by my ISP to my wireless router.

    2. I disabled UPNP on my router and set it up manually since allowing Homeserver to set the router automatically didn't work.  

    3. I can connect remotely with no problems to my Subsonic server on the same PC. The router is set identically for HS and Subsonic except for port number (80 for WHS, 800 for Subsonic).

    4. Dashboard > Server Settings indicates that Homeserver doesn't see the settings on the router ("Router IP: Unknown", "Model: Unknown"). How do I tell Homeserver the router IP, etc.?

    5. WHS has fixed ip outside the DHCP pool.

    6. Ports 80, 443, 4125 point at WHS ip

    7. ipconfig/all:

    Microsoft Windows [Version 6.1.7601]

    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

     

    C:\Users\Administrator>ipconfig/all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : OLDDESKTOP

       Primary Dns Suffix  . . . . . . . :

       Node Type . . . . . . . . . . . . : Hybrid

       IP Routing Enabled. . . . . . . . : No

       WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection:

       Media State . . . . . . . . . . . : Media disconnected

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter

       Physical Address. . . . . . . . . : 00-1C-DF-0D-16-4F

       DHCP Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : NVIDIA nForce Networking Controller

       Physical Address. . . . . . . . . : 10-78-D2-83-BE-B8

       DHCP Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : fe80::169:bbd8:e104:1d8c%11(Preferred)

       IPv4 Address. . . . . . . . . . . : 192.168.0.150(Preferred)

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Lease Obtained. . . . . . . . . . : Saturday, November 05, 2011 3:35:02 PM

       Lease Expires . . . . . . . . . . : Wednesday, November 16, 2011 11:53:20 AM

       Default Gateway . . . . . . . . . : 192.168.0.1

       DHCP Server . . . . . . . . . . . : 192.168.0.1

       DHCPv6 IAID . . . . . . . . . . . : 235960530

       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-06-F3-31-10-78-D2-83-BE-B8

       DNS Servers . . . . . . . . . . . : 192.168.0.1

       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{7879CAE7-E426-4B86-9C26-998E0973AEDE}:

       Media State . . . . . . . . . . . : Media disconnected

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Microsoft ISATAP Adapter

       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:24f2:1018:bc5b:6cb4(Pref

    erred)

       Link-local IPv6 Address . . . . . : fe80::24f2:1018:bc5b:6cb4%16(Preferred)

       Default Gateway . . . . . . . . . : ::

       NetBIOS over Tcpip. . . . . . . . : Disabled

    C:\Users\Administrator>

    Thanks.
    Wednesday, November 9, 2011 8:11 PM

All replies

  • Have you used a port scanning web site such as Shields Up! to test the ports you have set on your router? I would suggest a custom port scan of ports 80, 443, and 800. Also, have you tried simply accessing your remote access web site, both from within your house and from another location?
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, November 9, 2011 8:49 PM
  • Ken:

    Thanks for you quick response.

    I don't understand what I can learn from ShieldsUp! I have used it for years and it almost always shows all my ports are "Stealthed" and gives me no information about what my ports are connected to. I just tried it again for the three ports in question and all it tells me is that they are Stealthed and I'm apparently very secure. How does that help me know why I can't connect remotely to WHS?

    I also tried (on my LAN) connecting to xxx.homeserver.com (no luck), 192.168.0.150:80 (successful), 67.164.147.75:80 (ip address of my router from my ISP - no luck). 

    Earlier today I tried from outside my LAN xxx.homeserver.com (no luck) and 67.164.147.75:80 (ip address of my router from my ISP - no luck). 

    Also while outside I tried xxx.subsonic.com (successful) and 67.164.147.75:800 (ip address of my router from my ISP - successful). 

    I don't what else to try.

    Wednesday, November 9, 2011 9:39 PM
  • What you're describing suggests that the issue is not with your server per se, but with something "upstream".

    "Stealth" generally means one of two things:

    1. The ports are not forwarded correctly (i.e. forwarded to the wrong IP address). If you have subsonic running on your home server, and it works from outside your LAN, then I'd say that this is less likely.
    2. The ports are blocked somewhere, usually by your ISP, but also possibly by a second device in your network that's also acting as a router. Broadband modems often include this functionality, for instance, and it's sometimes turned on by default.

    Something else you can try is going through the remote access setup wizard again. Since you have UPnP turned off, or it doesn't exist in the first place, you'll see an error that your server was unable to configure your router. Choose to continue, and work your way through the rest of the wizard. Test again (from off site) to see if it works now.


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, November 9, 2011 10:21 PM
  • I am experiencing a similiar issue.  My ports are open correctly but the remote access wizard says access to remote access web site blocked.  what is IP or domain name of the server on the internet that the remote access wizard connects with when registering your internet IP for the xxxx.homeserver.com domain?  in my case, it appears that either the WHS 2011 built-in dynamic DNS update service is crashing or is unable to report my internet IP back to the microsoft domain server for registration to my xxxx.homeserver.com.
    Thursday, November 10, 2011 2:37 AM