locked
New install CRM 2011. Create new organization error. Error: Error occurred while finding an item on the report server. The request failed with HTTP status 401: Unauthorized. RRS feed

  • Question

  • I have a new install of Dynamic CRM 2011 with 3 servers setup like this Frontend with Deployment Manager, Backend, SQLserver.   After finishing installing the CRM Reporting Extensions on the SQLserver I tried to create a New Organization.   After giving the organization a name and database name of test I get to System Checks.  Microsoft CRM Organization , and Microsoft SQL Server both check out ok   When it goes to check Microsoft SQL Server Reporting Services I get the following error.

     

    Setup failed to validate specified Reporting Services Report Server http://sql0801/ReportServer_MSSQL0801. Error: Error occurred while finding an item on the report server.
    The request failed with HTTP status 401: Unauthorized.

    Any help or guidance would appreciated very much.

    Thank you,

    Rob

     

    Thursday, July 14, 2011 6:34 PM

All replies

  • Have you installed the Reporting Extensions on the SQL-Server?

    Information you can find here:

    http://www.microsoft.com/download/en/details.aspx?id=3621

    In file:

    Microsoft Dynamics CRM 2011 Installing Guide.docx

     

    cheers

    Friday, July 15, 2011 10:35 AM
  • Yes its installed but as Sven Vanoirbeek said in this other post, I don't have the rights to browse the reporting service.

    https://community.dynamics.com/product/crm/f/117/p/59434/107341.aspx#107341

    I am looking into what I need to do to fix that now.

    Friday, July 15, 2011 1:09 PM
  • Im looking around on my sql server and I see the following error when I restart the reporting service.

    Report Server Windows Service (MSSQL0801),Error,The report server cannot decrypt the symmetric key. Most likely<c/> the service account or password has changed. To continue<c/> run rsconfig.exe to update the report server account information.\r\n,Activation,120,,SQL0801.gwa-inc.com

    Also I get the following error in security when I try to access the reporting service address with the account Im using to install CRM.

    7/15/2011 09:31:13,Microsoft-Windows-Security-Auditing,Failure Audit,An account failed to log on.<nl/><nl/>Subject:<nl/>    Security ID:        S-1-0-0<nl/>    Account Name:        -<nl/>    Account Domain:        -<nl/>    Logon ID:        0x0<nl/><nl/>Logon Type:            3<nl/><nl/>Account For Which Logon Failed:<nl/>    Security ID:        S-1-0-0<nl/>    Account Name:        <nl/>    Account Domain:        <nl/><nl/>Failure Information:<nl/>    Failure Reason:        %%2313<nl/>    Status:            0xc000006d<nl/>    Sub Status:        0xc000006a<nl/><nl/>Process Information:<nl/>    Caller Process ID:    0x0<nl/>    Caller Process Name:    -<nl/><nl/>Network Information:<nl/>    Workstation Name:    -<nl/>    Source Network Address:    -<nl/>    Source Port:        -<nl/><nl/>Detailed Authentication Information:<nl/>    Logon Process:        Kerberos<nl/>    Authentication Package:    Kerberos<nl/>    Transited Services:    -<nl/>    Package Name (NTLM only):    -<nl/>    Key Length:        0<nl/><nl/>This event is generated when a logon request fails. It is generated on the computer where access was attempted.<nl/><nl/>The Subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service<c/> or a local process such as Winlogon.exe or Services.exe.<nl/><nl/>The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network).<nl/><nl/>The Process Information fields indicate which account and process on the system requested the logon.<nl/><nl/>The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.<nl/><nl/>The authentication information fields provide detailed information about this specific logon request.<nl/>    - Transited services indicate which intermediate services have participated in this logon request.<nl/>    - Package name indicates which sub-protocol was used among the NTLM protocols.<nl/>    - Key length indicates the length of the generated session key. This will be 0 if no session key was requested.,(12544),4625,,SQL0801.gwa-inc.com

    Think I may be on the right track.
    Friday, July 15, 2011 1:54 PM
  • Hi Shocks,

    Please go through this link it will helpfull to you, me too faced same prob now it solved.

    http://forums.asp.net/t/1219671.aspx/1?Dynamic+CRM+4+0+Error+401+Unauthorized

    http://ayazahmad.wordpress.com/2007/02/06/http-status-401-unauthorized-errors/

    or

    follow this steps:

    Open the User Accounts icon.
    Click the Advanced tab.
    Click Manage Passwords.
    Click Add.
    Enter the server name of the CRM server
    Enter the username as domain\username
    Enter the password.
    Click OK, then click Close and then click OK.

    On the client open IE, click the Tools menu and then click Internet Options.
    Click the Security tab.
    Click the Local Intranet icon.
    Click the Sites button.
    Click the Advanced button.
    Enter the website for access Microsoft CRM and then click the Add button.
    Click OK 3 times.
    Close any open IE sessions.

    The problem got solved for us !

     

     


    Thanks & Regards, MS CRM Consultant, V.Surya.
    • Proposed as answer by pschneider Monday, December 16, 2013 11:40 PM
    Saturday, July 30, 2011 9:36 AM
    Answerer
  • Hi,

    Seems like you need to reconfigure SQL Server Reporting Services, for refrence you may have a look into the following post on SQL Server Reporting Services Conifguration Tool: http://www.mssqltips.com/tip.asp?tip=1453


    Jehanzeb Javeed

    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile

    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Sunday, July 31, 2011 12:30 PM