none
Line spacing removed by forum editor RRS feed

Answers

All replies

  • On 2011-09-23 17:40, SQLUSA wrote:

    In the following thread, I placed empty/blank lines before and after the "Mapping" section (my second post). The editor removed both.

    http://social.msdn.microsoft.com/Forums/en/transactsql/thread/b1a8b621-be52-4c6b-8221-e21817314ab7

     


    Kalman Toth, SQL Server & Business Intelligence Training; SQL 2008 GRAND SLAM

         
         
    Try adding some spaces to the "blank" lines/paragraphs; the spaces should be converted to nonbreaking spaces (  in HTML markup).


    Stefan Blom, Microsoft Word MVP
    Friday, September 23, 2011 5:28 PM
  • I can fix it in the html by adding <br /> or similar, the issue is why the editor removing the visible blank lines when I post (submit) the note?

    It appears to me that some of the editor malfunctions occur when I post code.

     


    Kalman Toth, SQL Server & Business Intelligence Training; SQL 2008 GRAND SLAM

    Saturday, September 24, 2011 9:25 AM
  • On 2011-09-24 11:25, SQLUSA wrote:

    I can fix it in the html by adding <br /> or similar, the issue is why the editor removing the visible blank lines when I post (submit) the note?

     


    Kalman Toth, SQL Server & Business Intelligence Training; SQL 2008 GRAND SLAM
         
         
         
    I don't know why it happens. What I did was offer a possible workaround. I make use of it myself when I want some extra vertical spacing (such as between my reply and the quote from yours).


    Stefan Blom, Microsoft Word MVP
    Saturday, September 24, 2011 9:36 AM
  • Thanks Stefan.

    I know html, so I am doing the workarounds since this issue popped up with a version release. I hope to get a fix for it soon because it is a real troubling formatting issue.

     


    Kalman Toth, SQL Server & Business Intelligence Training; SQL 2008 GRAND SLAM
    Saturday, September 24, 2011 11:34 AM
  • On 2011-09-24 13:34, SQLUSA wrote:

    Thanks Stefan.

    I know html, so I am doing the workarounds since this issue popped up with a version release. I hope to get a fix for it soon because it is a real troubling formatting issue.

     


    Kalman Toth, SQL Server & Business Intelligence Training; SQL 2008 GRAND SLAM
         
        
        
    I wasn't aware that this is a new issue with the forum editor. Thanks for clarifying. I'm posting from a newsreader via the NNTP Bridge so I also have to consider what the Bridge and the newsreader support and don't support...


    Stefan Blom, Microsoft Word MVP
    Saturday, September 24, 2011 11:51 AM
  • the issue is why the editor removing the visible blank lines when I post (submit) the note?


    Probably because it is just white space and you aren't using <pre>.   No Microsoft forum does <pre> properly.   That's why the Code feature doesn't work.    It can get worse if you Edit, unless you edit with a view to insert <br /> and &nbsp;, e.g. by pressing   Shift-Enter  and  Shift-Space.

    WTH?   I had to press Shift-Enter twice to get two <br /> but pressing it once didn't get me one?   When did we get this "feechur"?   Knowing about it would change reliable editing a lot.

    ---

    Saturday, September 24, 2011 12:46 PM
  • I agree that the <pre> tag doesn't seem to be implemented correctly. I stopped using the the "Insert Code Block" feature long ago because of this and similar problems (like no fixed width font and indenting removed). I use the "Edit HTML Source" feature. I have a script to convert my code in a text file into HTML. Now I no longer see problems.

     


    Richard Mueller - MVP Directory Services
    Saturday, September 24, 2011 4:57 PM
    Moderator
  •    
         
    Try adding some spaces to the "blank" lines/paragraphs; the spaces should be converted to nonbreaking spaces (&nbsp; in HTML markup).

    Stefan Blom, Microsoft Word MVP
    I proposed this as the answer. The reason is because you could argue that many web editors do this by design because they don't know the intentions of extra spaces. The simple, extra step of pressing the space key seems to be a solid solution that I also use in the Wiki editor and in many other editors.

    Ed Price a.k.a User Ed, Microsoft Experience Program Manager (Blog, Twitter, Wiki)
    Friday, October 14, 2011 1:00 AM
    Owner
  • I can fix it in the html by adding <br /> or similar, the issue is why the editor removing the visible blank lines when I post (submit) the note?

    It appears to me that some of the editor malfunctions occur when I post code.

     


    Kalman Toth, SQL Server & Business Intelligence Training; SQL 2008 GRAND SLAM


    This solution also works, but Stefan's space key solution is much faster and easier.
    Ed Price a.k.a User Ed, Microsoft Experience Program Manager (Blog, Twitter, Wiki)
    Friday, October 14, 2011 1:01 AM
    Owner